Perché tmux / byobu riempie lo schermo di caratteri illeggibili quando copio una selezione?

13

Quando copio una selezione da tmux con una finestra divisa, il mio schermo si riempie di caratteri illeggibili. A seconda della dimensione della selezione, potrebbe essere molto, o solo una riga. Le seguenti immagini dimostrano:

Quindi, dopo aver colpito per effettuare la selezione:

Nota tutti i caratteri illeggibili nel pannello di destra.

Come faccio a eliminare questo comportamento?

    
posta dpb 05.08.2014 - 17:53
fonte

2 risposte

13

Esiste un'opzione set-clipboard che tenterà di copiare la selezione negli x-clipboard con una sequenza di escape.

:set-option -s set-clipboard off

gnome-terminal non supporta questo metodo di utilizzo degli appunti, che è il terminale predefinito in Ubuntu.

    
risposta data dpb 05.08.2014 - 17:53
fonte
3

Modifica ~/.tmux.conf o con Byobu $HOME/.byobu/.tmux.conf :

set -g set-clipboard off
risposta data Igor Parra 07.05.2016 - 16:08
fonte

Leggi altre domande sui tag