Autorizzazione SSH negata (chiave pubblica), ma root ssh funziona

13

Sto cercando di configurare l'accesso ssh per un account utente che ho creato con lo chef su un server ubuntu 12.04 dell'oceano digitale. Ho avuto le opzioni impostate in digital ocean per copiare automaticamente la chiave ssh del mio mac quando viene creato il droplet.

Posso ssh come root senza problemi, ma il mio altro utente non riesce ad autenticarsi. questo sembra essere un problema comune, e ho controllato alcune delle altre risposte, e ho trovato questo comando per ottenere maggiori informazioni:

ssh -vvv -i id_rsa user@serverIP

I log per l'utente root (che ha esito positivo) con quel comando sono

debug

1: Offering RSA public key: /Users/evan/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Server accepts key: pkalg ssh-rsa blen 279
debug2: input_userauth_pk_ok: fp snip!
debug3: sign_and_send_pubkey: snip!
debug1: read PEM private key done: type RSA
debug1: Authentication succeeded (publickey).

utente non funzionante:

debug

1: Authentications that can continue: publickey
debug3: start over, passed a different list publickey
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /Users/evan/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey
debug1: Trying private key: /Users/evan/.ssh/id_dsa
debug3: no such identity: /Users/evan/.ssh/id_dsa: No such file or directory
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.

Che per me significa che la chiave pubblica non è corretta. Ma, se accedo come utente root e vado a home/otheraccount/.ssh/authorized_keys , posso vedere che la mia chiave ssh è lì. Ho pensato che forse c'era un errore, quindi ho fatto cp .ssh/authorized_keys ~/home/otheraccout/.ssh/authorized_keys ma questo non ha aiutato. Non so dove altro guardare.

my etc/ssh/sshd_conig :

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
"sshd_config" 88L, 2508C
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile     %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no

# GS

SAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding no
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60

AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server
UsePAM no
Banner /etc/ssh_banner

modifica:

drwx------ 2 deploy deploy 4096 Apr 20 06:00 .ssh
-rw------- 1 deploy deploy 820 Apr 20 05:35 authorized_keys

Edit2:

Come suggerito nei commenti: /var/log/authlog :

Apr 21 04:59:30 localhost sshd[586]: User deploy not allowed because account is locked
Apr 21 04:59:30 localhost sshd[586]: input_userauth_request: invalid user deploy [preauth]

Ho provato a fare sudo usermod --expiredate -1 deploy e ha restituito no changes

    
posta user2936314 20.04.2014 - 12:05
fonte

2 risposte

16
  • Gli accessi SSH possono fallire per vari motivi (permessi di directory / file errati, chiavi errate, ecc.) e il client di connessione otterrà solo Permission denied o No more authentication methods to try o qualche errore generico.

  • Il motivo esatto per l'errore di accesso sarà disponibile nel log ssh /var/log/auth.log o /var/log/secure in base alla configurazione syslog.

risposta data clement 21.04.2014 - 17:35
fonte
3

Stesso problema per l'installazione di CentOS7.

1. controlla i permessi home dir e ~ / .ssh e ~ / .ssh / authorized_keys (come dice @clement)

chmod o-w ~/; chmod 700 ~/.ssh; chmod 600 ~/.ssh/authorized_keys

2. verifica / etc / ssh / sshd_config settings & amp; & amp; servizio sshd restart (dopo ogni modifica) Utile: prova "LogLevel VERBOSE" in sshd_config.

Ho ancora ricevuto il prompt della password dopo aver verificato tutto ciò che era ok

Esegui il client ssh con i registri -vvv:

debug3: send_pubkey_test 
debug2: we sent a publickey packet, wait for reply

Registri server (/ var / log / sicuro):

Failed publickey for * from * port * ssh2: RSA *

Il server ssh non invia più informazioni di errore al client poiché ciò costituirebbe un rischio per la sicurezza.

Se ho eseguito sshd su porta diversa 'sshd -p 5555 -d'. La chiave ha funzionato. Login senza password ok. WTF?

SAD :-( per dire ho quindi disabilitato selinux (imposta SELINUX = disabilitato in / etc / selinux / config) e riavvia. Accesso senza password poi ha funzionato bene.

my impostazioni sshd_config attive:

[root@hp-bl-05 ~]# grep -vE "^#|^$" /etc/ssh/sshd_config  
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
SyslogFacility AUTHPRIV
LogLevel VERBOSE
RSAAuthentication yes
PubkeyAuthentication yes
AuthorizedKeysFile  .ssh/authorized_keys
HostbasedAuthentication yes
PasswordAuthentication yes
ChallengeResponseAuthentication no
GSSAPIAuthentication no
GSSAPICleanupCredentials no
UsePAM yes
X11Forwarding yes
UseDNS no
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
AcceptEnv LC_IDENTIFICATION LC_ALL LANGUAGE
AcceptEnv XMODIFIERS
Subsystem   sftp    /usr/libexec/openssh/sftp-server

Quindi sarebbe bello sapere che potremmo cambiare qualcosa di piccolo in selinux per ottenere login ssh senza password per funzionare. Qualcuno può migliorare la risposta?

stesso qui: link

    
risposta data gaoithe 04.05.2016 - 14:52
fonte

Leggi altre domande sui tag