Directory mutex non valida nel file degli argomenti: $ {APACHE_LOCK_DIR}

15

ciao ogni corpo dopo l'installazione pulita di ubuntu 16.04 e taskel lamp apache2 ha ottenuto questo errore:

[Mon Jul 18 22:42:00.114578 2016] [core:warn] [pid 4654] AH00111: Config variable ${APACHE_LOCK_DIR} is not defined
[Mon Jul 18 22:42:00.114623 2016] [core:warn] [pid 4654] AH00111: Config variable ${APACHE_PID_FILE} is not defined
[Mon Jul 18 22:42:00.114641 2016] [core:warn] [pid 4654] AH00111: Config variable ${APACHE_RUN_USER} is not defined
[Mon Jul 18 22:42:00.114645 2016] [core:warn] [pid 4654] AH00111: Config variable ${APACHE_RUN_GROUP} is not defined
[Mon Jul 18 22:42:00.114657 2016] [core:warn] [pid 4654] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
[Mon Jul 18 22:42:00.133748 2016] [core:warn] [pid 4654] AH00111: Config variable ${APACHE_LOG_DIR} is not defined
AH00526: Syntax error on line 74 of /etc/apache2/apache2.conf:
Invalid Mutex directory in argument file:${APACHE_LOCK_DIR}
    
posta tal shulgin 18.07.2016 - 21:49
fonte

3 risposte

12

Sembra che tu abbia provato ad avviare Apache eseguendo qualcosa come

apache2

Questo non funziona. Usa

sudo service apache2 start

, invece.

    
risposta data Florian Diesch 18.07.2016 - 21:55
fonte
14

Mi sono imbattuto in questa volta e questo ha funzionato per me:

source /etc/apache2/envvars 
apache2 -V
sudo service apache2 restart

Da allora non ho avuto il problema.

    
risposta data EnterUserNameHere 19.07.2016 - 02:30
fonte
2

La risposta corretta è abbastanza semplice ma non ovvia.

Il servizio apache2 in Ubuntu / Debian utilizza il file di ambiente /etc/apache2/envvars durante l'avvio tramite apache2ctl restart o service apache2 restart .

Per visualizzare correttamente i dettagli di apache2 -V è sufficiente trovare il file di ambiente apache2:

# source /etc/apache2/envvars
# apache2 -V

Non dovrebbe esserci alcun errore di sintassi con apache2.conf, poiché le variabili d'ambiente mostrate nella riga 74 vengono automaticamente acquisite da apache2 durante l'avvio.

    
risposta data dimib 05.07.2017 - 01:19
fonte

Leggi altre domande sui tag