Unity funziona lentamente, come posso migliorare le sue prestazioni?

12

Mi piace come appare Unity, ma ho 2 problemi:

  1. Unity 3D
    Quando accedo a Unity 3D, il mio PC diventa più lento, ho un AMD II X3 con 2 GB di RAM, Nvidia Gforce 6150SE nForce 430 / PCI / SSE2 integrato.
    Quando provo ad aprire il cruscotto, mi prendo molto tempo per aprirlo, il più delle volte richiede fino a 5 secondi e mentre l'apertura rimane sfocata e non reagita, anche le app o le cartelle prendono lo stesso tempo per aprirsi e la stessa reazione.

  2. Unity 2D Quando accedo a Unity 2D il mio pc va più veloce, l'unico problema è che non posso configurare Unity come voglio, provo a configurare il plugin Unity in CCSM.
    Ad esempio: ho cambiato "nascondi launcher" in: Mai. Non salva le modifiche, nemmeno quando riavvio il mio computer.

Non so se il problema è con Unity 3D o con il mio pc.

    
posta Cesar Gomez 16.10.2011 - 01:36
fonte

5 risposte

16

In CCSM, vai nelle opzioni per Ubuntu Unity Plugin e nella scheda Sperimentale , cambia opzione Dash Blur da "Active Blur" a "Sfocatura statica" o "Nessuna sfocatura".

Puoi anche accedere all'opzione Composito e disabilitare "Detect Refresh Rate" e aumentare l'opzione Frequenza di aggiornamento a oltre 60.

Per aumentare ulteriormente le prestazioni, devi avere i driver propietari di Nvidia installati (assicurati di utilizzare la versione più recente ). Accedi a Impostazioni server NVIDIA X e in Impostazioni OpenGL Cambia "Impostazioni immagine" a "Prestazioni elevate".

Ricorda che queste opzioni si applicano solo con * Unity 3D *

    
risposta data Evan 18.10.2011 - 09:55
fonte
2

Non è possibile utilizzare CCSM per configurare Unity-2D poiché non sta utilizzando Compiz per mostrare Unity. Devi usare dconf-editor o puoi usare questo strumento:

link

Spero che questo aiuti.

Luis Da Costa     

risposta data aliasbody 16.10.2011 - 02:03
fonte
0

Ho avuto la stessa cosa con ati-driver è un problema perché alcuni driver non supportano le procedure "GLX_EXT_texture_from_bitmap" è necessario lavorare AIGLX. se non c'è AIGLX tutto passa attraverso XGL, incluso 3D e quindi lento.

    
risposta data Radziej 19.10.2011 - 15:45
fonte
0

Prova a installare i driver nvidia-96 . Unity 3d funziona bene per me dopo.

Inoltre, i miglioramenti apportati da Compiz aiuteranno.

    
risposta data martu 20.10.2011 - 05:19
fonte
-1

Prova a utilizzare CCSM (CompizConfig Settings Manager) per disabilitare prima altri plug-in.

Ti aiuta?

    
risposta data fixedit 16.10.2011 - 01:52
fonte

Leggi altre domande sui tag