I pulsanti del volume non funzionano in 14.04

11

Quando si usano i pulsanti del volume (+, -, mute) non si verifica alcuna reazione, né sulla tastiera del laptop né sulla tastiera USB. Nessun popup, nessun cambio di volume e nessuna indicazione del suono.

Il controllo del volume con il mouse funziona bene.

I pulsanti funzionano e vengono riconosciuti:

Controllato con lo strumento delle impostazioni di sistema della tastiera: viene riconosciuto dallo strumento sia direttamente dal laptop che dalla mia tastiera USB.

Chi può aiutarti?

    
posta ohoservices 05.05.2014 - 14:51
fonte

4 risposte

29

Sembra un bug noto su Launchpad .

Secondo la discussione, la correzione attuale è ...

  1. Apri terminale ( Ctrl + Alt + T )
  2. Scrivi i seguenti tre comandi per ripristinare i tasti volume / mute sulla tastiera ...

    gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up
    gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-down
    gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-mute
    

Ha funzionato per me, spero che funzioni anche per te.

    
risposta data jakesantos 17.05.2014 - 05:44
fonte
7

Se il ripristino delle scorciatoie da tastiera non ha funzionato (come nel mio caso) sposta o cancella la directory .gconf:

cd && mv .gconf .gconf.old

Esci e accedi di nuovo.

    
risposta data niry 07.05.2015 - 08:49
fonte
2

Inoltre, per correggere il pulsante mute, esegui

gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-mute

da una shell. Ha funzionato per me, spero che aiuti anche te.

    
risposta data spqpad 22.07.2014 - 15:40
fonte
1

Penso di aver risolto questo problema reinstallando lightdm (fare attenzione a reinstallare e non a rimuoverlo poiché ciò potrebbe causare problemi con il riavvio). Nessuna delle altre soluzioni ha funzionato per me.

sudo apt install --reinstall lightdm

Aggiornamento: Questo è successo di nuovo e questa volta reinstallare lightdm non ha risolto il problema. Ciò che ha funzionato invece è stato questo: 1) Ho installato dconf-editor e ripristinato il valore / org / gnome / settings-daemon / plugins / media-keys / custom-keybind ing / su default, mantenendo una copia del suo valore in un file. 2) Dopo aver effettuato il logout e aver effettuato nuovamente l'accesso, ho reinserito il valore originale (ad esempio, le mie scorciatoie personalizzate). Ora, tutto sembra funzionare di nuovo.

    
risposta data bilbo 29.01.2017 - 06:26
fonte

Leggi altre domande sui tag