Spotify ha smesso di funzionare sull'ultima Ubuntu oggi, 15.04 [chiusa]

11

Ho installato l'ultima versione di Ubuntu oggi, 15.04. Spotify ha smesso di funzionare. Come si può far funzionare di nuovo?

La barra Unity lampeggia verde 4 o 5 volte e poi smette di lampeggiare. Non ci sono messaggi di errore. È stato installato con successo e ha giocato bene il 14.10 fino all'aggiornamento poche ore fa. Semplicemente non appare sullo schermo.

    
posta IndianArt 24.04.2015 - 01:30
fonte

5 risposte

23

C'è un tutorial in modo da poterlo risolvere (sotto la reinstallazione). Basta eseguire questi due comandi, ha funzionato per me:

$ wget http://security.ubuntu.com/ubuntu/pool/main/libg/libgcrypt11/libgcrypt11_1.5.4-2ubuntu1.1_amd64.deb
$ sudo dpkg -i libgcrypt11_1.5.4-2ubuntu1.1_amd64.deb

Link al sorgente / tutorial: link

    
risposta data Saturiel 25.04.2015 - 16:58
fonte
8

Prima di eseguire i passaggi successivi, rimuovi eventuali ppa di Spotify.

Installa Spotify ppa:

sudo apt-add-repository -y "deb http://repository.spotify.com stable non-free" && sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 94558F59 && sudo apt-get update -qq && sudo apt-get install spotify-client

Quindi installare quanto segue:

wget http://ftp.au.debian.org/debian/pool/main/libg/libgcrypt11/libgcrypt11_1.5.0-5+deb7u2_amd64.deb

sudo dpkg -i libgcrypt11_1.5.0-5+deb7u2_amd64.deb

Enjoy!

    
risposta data clvx 24.04.2015 - 03:22
fonte
3

Questo ha funzionato per me:

wget http://security.debian.org/debian-security/pool/updates/main/libg/libgcrypt11/libgcrypt11_1.5.0-5+deb7u3_amd64.deb

sudo dpkg -i libgcrypt11_1.5.0-5+deb7u3_amd64.deb

fonte: link

    
risposta data dwaynemac 27.04.2015 - 21:30
fonte
2

L'installazione di libgcrypt11 implica problemi di sicurezza (vedi questo post sul forum di Spotify che rimanda a questa pagina NVD ). Come menzionato nel post sul forum Spotify linkato sopra, probabilmente è meglio usare la versione di prova del client Spotify, disponibile per il download su questa pagina repository-origin.spotify.com . Non è nemmeno l'ideale, ma probabilmente l'opzione migliore.

    
risposta data bartovan 09.08.2015 - 09:33
fonte
1

La tua versione di Spotify utilizza una libreria chiamata libgcrypt11 che è stata sostituita in Ubuntu 15.04 da libgcrypt20 . Una versione di Spotify che non richiede libgcrypt11 è disponibile nel repository di test. Questo è lo Spotify che alla fine (dopo che è stato testato e se sono stati corretti eventuali errori gravi) sostituirà quello dal repository stabile che hai ora.

Modifica le fonti software per cambiare il repository Spotify da stabile a testing e quindi aggiorna il client Spotify. Alcune cose saranno diverse da prima, nel bene o nel male, ma almeno inizia.

    
risposta data Snurolss 06.07.2015 - 20:07
fonte

Leggi altre domande sui tag