CIFS montare su fstab non in fase di montaggio all'avvio

15

Ho una condivisione CIFS sul mio NAS che voglio avere montato all'avvio - è utilizzata dal mio server MythTV come archivio multimediale principale. Ho aggiunto una voce in fstab per farla montare ma non è così. Sembra che, dopo aver consultato i miei registri di sistema, venga letto fstab prima che le mie interfacce di rete siano online. C'è qualche modifica che posso apportare alla voce fstab che cambierebbe questo?

La voce fstab per il montaggio della condivisione è:

\192.168.0.26\mythtv\media  /media/mybooklive  cifs  username=user,password=pass,umask=002,uid=136,gid=144,iocharset=utf8   0       0

Si monta bene dopo l'avvio quando rilascio sudo mount -a e non ci sono altri problemi con esso.

Grazie!

    
posta douggro 03.01.2014 - 20:05
fonte

5 risposte

7

Si tratta di un errore di sintassi, penso che sia necessario un "/" piuttosto che un "\", come questo

//192.168.0.26/mythtv/media  /media/mybooklive  cifs  username=user,password=pass,_netdev,umask=002,uid=136,gid=144,iocharset=utf8  0 0

Vedi: link per ulteriori informazioni.

    
risposta data Panther 04.01.2014 - 16:35
fonte
19

Hai provato ad aggiungere l'opzione _netdev alla tua voce fstab ? Lo aggiungerebbe con le altre opzioni nella stringa in questo modo

//192.168.0.26/mythtv/media  /media/mybooklive  cifs  username=user,password=pass,_netdev,umask=002,uid=136,gid=144,iocharset=utf8   0       0

_netdev dovrebbe ritardare il mount fino a dopo la connessione della rete.

    
risposta data djmadscribbler 03.01.2014 - 20:22
fonte
9

se _netdev non funziona, prova l'opzione:

% Bl0ck_qu0te%

, invece. Funziona montando l'unità al primo accesso.

Per testare l'automount, smonta la condivisione se è attualmente montata:

$ sudo umount /media/mybooklive

E quindi riavvia l'unità systemd remote-fs :

$ sudo systemctl daemon-reload
$ sudo systemctl restart remote-fs.target
    
risposta data t-dome 09.09.2016 - 21:06
fonte
4

Sto utilizzando la build Raspbian-Stretch datata 2017-09-07 e ho riscontrato lo stesso problema. Tuttavia, sono stato in grado di superare questo problema andando in raspi-config e nel menu Boot Options, ho abilitato l'opzione "Wait for network at boot".

    
risposta data Chris 26.11.2017 - 12:22
fonte
2

-Utilizzando le barre (/) NON è stato corretto per me.
-Inoltre, aggiungendo l'opzione _netdev alla mia voce /etc/fstab NON ho risolto il problema per me.

Quello che ho fatto per risolvere questo problema (sul mio Pi3) è modificare /etc/rc.local per dormire 20 secondi (chiamando sleep 20 ) e quindi chiamare mount -a . In questo modo, anche se la rete NON è ancora connessa quando il sistema legge per la prima volta il file fstab, quindi il mount fallisce, costringo il sistema ad attendere 20 secondi qui (concedendo il tempo di connessione alla rete), quindi lo costringo a chiamare% nuovamente co_de% per montare tutte le unità nel file mount -a .

Ecco come appare il mio file fstab :

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# Print the IP address
#GS notes: a *minimum* of sleep 10 is required for the mount below to work on the Pi 3; it failed with sleep 5, but worked with sleep 10, sleep 15, and sleep 30
sleep 20
_IP=$(hostname -I) || true
if [ "$_IP" ]; then
  printf "My IP address is %s\n" "$_IP"
  mount -a #GS: mount all drives in /etc/fstab
fi

exit 0

Fatto! Ora funziona perfettamente per me!

References:

risposta data Gabriel Staples 21.03.2017 - 04:09
fonte

Leggi altre domande sui tag