Nessun suono su Ubuntu 12.04

11

Dopo aver installato Ubuntu 12.04, non ci sono suoni sulla mia cuffia (pannello jack posteriore).

Impostazioni audio & gt; riproduzione, sembrava che i suoni sono stati rilevati dopo aver scelto 'Riproduci suono'.

Chiunque può risolvere questo problema ??

Grazie.

    
posta Denni 12.05.2012 - 04:02
fonte

11 risposte

10

link

Ho appena fatto il passaggio 1 e poi riavvio il mio laptop e il suono funziona.

Se stai usando Ubuntu 12.04 o successivo, esegui questo comando e riavvia:

  

Leggi attentamente e capisci cosa fanno questi comandi. Ad esempio, il sudo apt-get install   comando include l'intero desktop di Ubuntu . Questo probabilmente creerà    problemi per gli utenti degli altri sapori di Ubuntu - un utente di Kubuntu   non vorrebbe l'interfaccia Unity installata. Mentre il risultato di   eseguire la stringa di comando suggerita di seguito potrebbe in effetti risolvere certi   problemi seri, sii consapevole che è un approccio molto schietto e potrebbe   causare conseguenze indesiderate.

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa;              \ 
sudo apt-get update;                                           \ 
sudo apt-get dist-upgrade;                                     \ 
sudo apt-get install linux-sound-base alsa-base alsa-utils gdm \           
     ubuntu-desktop  linux-image-'uname -r' libasound2;        \
sudo apt-get -y --reinstall install linux-sound-base alsa-base \ 
     alsa-utils gdm ubuntu-desktop  linux-image-'uname -r'     \     
     libasound2;                                               \ 
killall pulseaudio;                                            \  
rm -r ~/.pulse*;                                               \
sudo                                                           \ 
    usermod -aG $(                                             \
          cat /etc/group |                                     \
          grep -e '^pulse:' -e '^audio:' -e '^pulse-access:'   \
          -e '^pulse-rt:' -e '^video:' |                       \
          awk -F: '{print }' |                               \ 
          tr '\n' ',' |                                        \
          sed 's:,$::g'                                        \ 
    ) $(whoami)

Incolla l'intero blocco di codice nel tuo terminale con CTRL - SHIFT - V , quindi premi invio.

    
risposta data Antonio_Sid 20.06.2012 - 10:49
fonte
7

Prova questo:

sudo killall pulseaudio
sudo alsa force-reload
    
risposta data erik 05.10.2012 - 17:25
fonte
4

Qualunque cosa tu faccia non inserire l'enorme codice nella prima risposta ! Ha rovinato completamente la mia schermata di accesso.

Utilizza solo killall pulseaudio nel terminale.

    
risposta data Joseph Beck 03.08.2012 - 23:05
fonte
3

Sei stato disattivato? Per pulseaudio, prova pavucontrol e controlla se il pulsante mute è attivo nella scheda Output Devices :

    
risposta data Xiè Jìléi 12.05.2012 - 04:40
fonte
1

Ho avuto lo stesso problema, ho finito per collegare i miei altoparlanti all'uscita audio posteriore e ha funzionato. Nel test del suono in "modalità stereo" funziona la parte anteriore sinistra / destra, ma quando la metto in 5.1, i miei diffusori vengono convertiti nei canali posteriori come dovrebbero. Quindi lo lascio in stereo (è quello che sono comunque).

Sebbene, se disponi di un laptop o di un hardware "non HD audio" (solo ingresso, uscita, microfono), ciò non sarà possibile.

Inoltre, la cosa strana è che l'audio del mio pannello frontale funziona bene, deve essere qualcosa di sciocco con i driver audio Realtek HD ...

    
risposta data Andy 08.08.2012 - 08:37
fonte
1

Avevo lo stesso problema dell'OP per un po 'e alla fine ho capito.

Controlla il tuo BIOS e assicurati che l'audio di bordo sia impostato su Abilitato. Non automatico o disabilitato. Il mio era su auto e nulla avrebbe reso 12.04 vedere il dispositivo.

    
risposta data Bill Todd 14.12.2012 - 02:21
fonte
1

Questo è ciò che ha risolto per me.

Apri terminale

sudo gedit /etc/modprobe.d/modprobe.conf

Verrà aperto un nuovo file, scrivere una riga sotto e poi salvare.

options snd_hda_intel model=mb5

Chiudi il file Riavvia il computer.

Grazie a Nessun suono su un iMac

    
risposta data Akshat Kedia 27.08.2013 - 12:42
fonte
0

Questo non ha funzionato per il mio caso Ubuntu AMD 64 12.04 con RAM quad-core per PC HP 5GB. Altri problemi esistevano e il suono scompariva dopo l'installazione di aggiornamenti e altri software. Potrebbe aver avuto anche un bug di script? Trovati file dispari e cancellati dalla home page. trovato che il driver di Kubuntu per il PC che utilizza l'ISO DVD era NVidea MCP61 usato sudo apt-get install Nvidea MCP61

Trovati file sinaptici che sono stati danneggiati e hanno provato a risolverli. Un installato o rimosso, installato un altro, aggiornato il terzo file.

Turned of PC e riavviato dopo aver atteso aggiornamenti e aggiornamenti da installare. Il giorno dopo, le impostazioni audio tornano alla normalità e l'impostazione dell'uscita Dummy è scomparsa.

    
risposta data Tom Sucic 24.09.2012 - 08:32
fonte
0

In un terminale, ho eseguito gstreamer-properties , forzato l'input e l'output in ALSA Advanced Linux Sound Architecture e riavviato. Quindi ha funzionato bene!

    
risposta data broomie 20.08.2012 - 11:21
fonte
0
risposta data Vladimir S. 18.06.2013 - 09:13
fonte
0

Okey. Vedo il tuo problema Anch'io l'ho avuto Prova questo. È sicuro e ha funzionato per me.

Apri il terminale e digita

  

alsamixer

Premere S e selezionare l'opzione Generico HD-Audio. Scorri per automatizzarlo e disattivarlo ora apri tutte le opzioni di volume Premi Esc per uscire

Fatto!

Adesso prova a suonare qualcosa Buona fortuna;): D

    
risposta data Jatttt 19.06.2014 - 21:33
fonte

Leggi altre domande sui tag