Il desktop non mostra quando ho installato i driver nvidia!

69

Il desktop non viene visualizzato dopo aver installato i driver sperimentali nvidia. Ho provato i driver proprietari nvidia semplici e non hanno funzionato neanche.

Ecco come appare. Questo non è ritagliato o qualsiasi cosa. Ecco come appare, dopo l'installazione dei driver la risoluzione del desktop è diminuita da 1440x900 a 1024x768

Il desktop mostra solo desh e pannelli quando utilizzo i driver open source.

C'è un modo per risolvere questo problema in modo da ottenere prestazioni migliori?

    
posta Levan 18.10.2012 - 19:59

10 risposte

79

Ho fatto succedere la stessa cosa Ecco come l'ho risolto:

  1. Passa a un terminale Ctrl + Alt + F1 .

  2. Accedi come nome utente.

  3. Installa le intestazioni di Linux:

    sudo apt-get install linux-headers-generic
    
  4. Disinstalla il driver nvidia - dipende dalla versione installata:

    sudo apt-get remove nvidia-current
    

    o

    sudo apt-get remove nvidia-current-updates 
    

    o

    sudo apt-get remove nvidia-experimental-304
    
  5. Reinstalla il driver nvidia

    sudo apt-get install nvidia-current-updates
    

    Quando lo fai, deve dire qualcosa del tipo:

    Building initial module for 3.5.0-17-generic
    Done.
    

    Se dice

    Module build for the currently running kernel was
    skipped since the kernel source for this kernel
    does not seem to be installed.
    

    allora il problema non sarà risolto. Non credere al messaggio. Non sta chiedendo l'installazione di linux-source , lo vuole solo le intestazioni ma devi installare le intestazioni -generic specifiche per il tuo kernel Esegui:

    sudo apt-get install linux-headers-'uname -r'
    

    non funzionerà solo con linux-headers-generic o linux-headers-3.5.0-17 (ad esempio).

  6. Se si installa correttamente, riavvia il computer:

    sudo shutdown -r now
    

Questo dovrebbe consentire al modulo del kernel di compilare e installare correttamente. Ha fatto per me!

    
risposta data rft183 18.10.2012 - 20:39
9

Se il desktop continua a non essere visualizzato, potrebbe essere causato dalla scheda grafica Nvidia Optimus . Ho un laptop con GT 650M e questa è anche una carta Optimus. Le schede Optimus si comportano in modo leggermente diverso e per loro impostazione predefinita non esiste alcun supporto Linux. Maggiori informazioni su Optimus in linux: link

Ma è possibile farlo funzionare con Bumblebee . Ecco come l'ho fatto nella nuova installazione di Ubuntu 12.10 (nessun driver nvidia installato):

sudo add-apt-repository ppa:bumblebee/stable 
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update 
sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic 

Quindi riavvia o ri-accedi.

Non ha funzionato prima quando ho interrotto questo secondo comando. Quindi per eseguire qualcosa con tipo di scheda grafica optirun prima del comando. Nell'esempio: optirun glxspheres o optirun ./executable-file . Un buon modo per testare la differenza tra la grafica integrata e la tua scheda grafica è eseguire glxspheres con e senza optirun .

link

Ciò consente di risparmiare energia quando si attiva la scheda grafica solo quando è necessaria. Spero di aver aiutato qualcuno, perché ho passato ore a scoprire il problema con la mia scheda grafica (sì, sono abbastanza nuovo con questi driver grafici Linux).

    
risposta data Arttu 04.12.2012 - 15:18
5

Dopo essermi immerso per alcune sere (scomparendo il desktop dell'unità, solo risoluzione 640x480, strani artefatti sullo schermo) sulla mia Geforce GT 630, questo è ciò che ha funzionato per me:

  1. Nuova installazione di Ubuntu 12.10
  2. Immediatamente dopo l'installazione, eseguire il programma di aggiornamento del software. Scarica & amp; Installa tutti gli aggiornamenti
  3. Reboot
  4. sudo apt-get install linux-sources && sudo apt-get install linux-headers-generic (Non sono del tutto sicuro se / perché questo passaggio sia necessario, ma l'ho visto in questa discussione e ho pensato di fare un tentativo)
  5. Apri "Sorgenti software" da Dash
  6. Fai clic sulla scheda "driver aggiuntivi".
  7. Attiva il driver binario xorg NVIDIA (proprietario, testato)
  8. Reboot

Fin qui tutto bene - Ho il pannello delle impostazioni NVIDIA (senza il messaggio di errore Xconfig), i monitor doppi e l'alta risoluzione.

Nota speciale: NON installare il pacchetto "driver aggiuntivi" (Jockey). Questo pacchetto in realtà sembra scomparire dopo il passaggio 2 (aggiornamenti software): il metodo per aggiungere driver aggiuntivi sembra essere stato spostato nell'app "fonti software".

    
risposta data Jim Keller 22.11.2012 - 03:00
3

Ho appena installato Ubuntu 12.10 oggi e ho riscontrato questo problema con il driver nvidia.

Ho provato a seguire le istruzioni precedenti, ma tutte queste operazioni sono fallite a causa di due parole che sono piuttosto importanti: "generico" e "-17".

Alla fine ho scoperto che il modo migliore di installare il driver NVidia è di usare effettivamente il programma di installazione fornito da nvidia. Così sono andato a:

link

e versione scaricata per Linux-64bit (installa synaptic sudo apt-get install synaptic e cerca nel menu Impostazioni - & gt; Repository - & gt; Driver aggiuntivi per scoprire il nome esatto della tua scheda nvidia)

Quindi esegui lo strumento e dice che hai bisogno di intestazioni del kernel, tuttavia leggi attentamente perché richiede intestazioni "generiche".

Devi verificare la versione del tuo kernel, il mio era 3.5.0-17 (questo "-17" alla fine conta), quindi nel mio caso l'ho fatto:

sudo apt-get install linux-headers-3.5.0-17-generic

(scopri la versione del tuo kernel digitando ina terminal uname -r )

Devi uccidere il demone di accesso alla GUI:

killall lightdm

e successivamente è possibile eseguire:

sudo sh NVIDIA-Linux-x86_64-310.19.run

Il programma di installazione probabilmente ti dirà che il modulo del kernel di Noveau è caricato e ti suggerirà di aggiungere lo script modprobe. Dovresti dire Ok / Sì a tutto ciò che ti dice e poi riavviare ed eseguire nuovamente NVIDIA-Linux-x86_64-310.19.run.

Non sono sicuro che un altro approccio funzionerebbe allo stesso modo, ma questo è sicuro.

    
risposta data Radek 21.12.2012 - 13:14
2

Questo funziona anche con le schede Nvidia 7400. Ma se gli aggiornamenti del kernel è necessario modificare la linea di installazione per la versione più recente ora è:

sudo apt-get install linux-headers-3.5.0-18-generic

invece spento:

sudo apt-get install linux-headers-3.5.0-17-generic
    
risposta data Daniel Zippert 20.10.2012 - 19:19
0
sudo apt-get install nvidia-current nvidia-settings
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
sudo nvidia-xconfig

Riavvia il sistema!

    
risposta data BlitzkriegBop 19.10.2012 - 18:08
0

Ho provato quasi tutto, ma qui è quello che ha funzionato davvero per me:

esegui i seguenti comandi:

sudo add-apt-repository ppa:amith/ubuntutools
sudo apt-get update
sudo apt-get install unity-reset

quindi resettare l'unità con questo comando:

unity-reset

riavvia e Unity è tornato !! Spero che funzioni per te.

    
risposta data camilo garcia 12.11.2012 - 00:27
0

Ho risolto il problema stasera. Ho installato l'ultimo kernel 3.7.1 dopo averlo compilato come faccio sempre. Quindi ho installato i driver nVidia da Synaptic. Ciò ha causato la scomparsa dei menu Unity come mostrato nel tuo screenshot. La soluzione per me è la seguente:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Ora non solo il problema risolto da te ha i driver nVidia più recenti!

    
risposta data Joel Frese 09.01.2013 - 05:16
0

Se la tua installazione non funziona (il modulo iniziale non viene compilato), devi assicurarti di avere solo un set di intestazioni installato.

dpkg --get-selections | grep linux-headers

Questo non funziona

linux-headers-3.5.0-26              install
linux-headers-3.5.0-26-generic      install
linux-headers-generic               install

Questo funziona

linux-headers-3.5.0-26              install
linux-headers-3.5.0-26-generic      install

In questo caso, semplicemente

apt-get remove linux-headers-generic

Ora, il programma di installazione di nvidia funzionerà.

    
risposta data Nate Symer 07.04.2013 - 04:02
-1

Ho fatto questo:

sudo apt-get autoremove fglrx --purge

Ha funzionato alla grande.

    
risposta data Shaun 06.12.2012 - 05:10

Leggi altre domande sui tag