Come installo Adobe Acrobat Reader dal repository?

56

Come installo Adobe Acrobat Reader in Ubuntu 14.04 utilizzando un repository Trusty apt ?

Questo NON è un duplicato di Come installo il pacchetto deb di Adobe Acrobat Reader scaricato dal sito Web di Adobe? . In Synaptic > Repositories > Other software ho attivato "Canonical Partners", ma non riesco ancora a installare acroread poiché non è disponibile sul mio sistema a 64 bit.

Ecco l'output dalla console:

[email protected]:/home/liv# apt-get install acroread
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package acroread
[email protected]:/home/liv# apt-get install acroread:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package acroread
    
posta landroni 25.04.2014 - 13:07

8 risposte

66

È un po 'più manuale installare Adobe Acrobat Reader in Ubuntu 14.04, ma non è difficile.

Apri un terminale.

Tipo:

cd ~/Downloads && wget -c http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb

Questo scarica il file DEB da Adobe e lo inserisce nella cartella Download. Tipo successivo:

sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb

Questo installerà Adobe Acrobat Reader.

Se si è su una macchina a 64 bit, potrebbe essere necessario aggiungere le librerie mancanti menzionate da Nim:

sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386

Se si desidera Acrobat Reader come applicazione predefinita per i PDF, digitare:

mimeopen -d *.pdf

Verrà visualizzato un elenco di programmi (visualizzato per me 3). Seleziona il numero con Acrobat Reader. Aprirà Acrobat Reader e dirà che non è possibile aprire "* .pdf". Ignora questo errore e chiudi Adobe Reader. Dovresti essere impostato ora.

    
risposta data G Trawo 03.05.2014 - 13:46
25

Invece di elencare tutte le dipendenze in modo esplicito, puoi fare questo:

sudo apt-get install -f

Questo risolverà automaticamente tutte le dipendenze non risolte.

Quindi l'intera sequenza di comandi deve essere così:

cd ~/Downloads && wget -c http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb
sudo apt-get install -f
    
risposta data Undespairable 17.08.2014 - 23:32
4

Puoi vedere dal link: ubuntu-updates (vedi colonna di rilascio) quel pacchetto acroread non è ancora stato rilasciato per 14.04 (fidato)

Quindi, attendi fino all'aggiunta ai repository dei partner Canonical. Altrimenti puoi installare la vecchia versione. Vedi domanda simile : Domanda simile a awn.

In questo caso ottengo lo stesso errore per awn: E: Unable to locate package avant-window-navigator

    
risposta data Pandya 25.04.2014 - 13:26
4
  1. Scarica Adobe Reader da: link .

Seleziona sistema: Linux, la tua lingua, Reader 9.5.5 per Linux (.deb)

  1. Installa gdebi:
sudo apt-get install gdebi
  1. Installa Adobe Reader tramite gdebi e accetta le dipendenze:
sudo gdebi PACKAGENAME.deb
  1. Installa le librerie richieste:
sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386

Infine avvia Adobe Reader dal menu di scelta rapida Menu, Dash o PDF.

tramite: ubuntuhandbook.org

    
risposta data Nim 28.04.2014 - 12:17
1

dal 2014-10-23 la risposta è ancora "tu non" (o non puoi)

improbabile che accada mai, anche.

l'ultima versione di Acrobat reader per unix / linux è 9.5.5

Questo ha funzionato per me (la risposta da irreprensibile il 17 agosto non è riuscita a installare alcuni pacchetti necessari) su Xubuntu 14.04

# as root (prefix with sudo if you are running as an unprivileged user)
apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386
apt-get install --reinstall gtk2-engines-murrine:i386 gtk2-engines-pixbuf:i386
cd /tmp && wget -c http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb

dopo il test:

rm -rf /tmp/acroread_1000_1000
rm /tmp/AdbeRdr9.5.5-1_i386linux_enu.deb
    
risposta data Derek Shaw 24.10.2014 - 22:49
0

Prova a utilizzare il terminale:

sudo apt-get install acroread

e se non funziona - usa:

sudo apt-get install acroread:i386

Modifica: usa i seguenti comandi:

sudo apt-add-repository multiverse
sudo apt-get update
    
risposta data aastefanov 25.04.2014 - 13:12
0

Oggi ho testato con successo le seguenti operazioni in una nuova installazione di kUbuntu 14.04.4 (un tocco ufficiale di Ubuntu).

Aggiungi PPA canonico

sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"

Aggiorna e installa

sudo aptitude update  
sudo aptitude install acroread  

Funziona su kUbuntu 14.04 LTS
A partire dal 30 aprile 2016, non funziona sul nuovo kUbuntu 16.04 LTS

    
risposta data jtlindsey 19.02.2016 - 17:58
-1

Come ho finalmente installato Acrobat Reader su Ubuntu 14.04 su una macchina a 64 bit:

  1. Ho scaricato la versione .deb da adobe.com;

  2. Installa il pacchetto utilizzando gedbi ;

  3. Installa le librerie:

    sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386 
    

Fatto!

    
risposta data ionelf 04.05.2014 - 10:28

Leggi altre domande sui tag