Come installare Teamviewer il 14.04? [duplicare]

57

Ho provato ad installare Teamviewer 9 su Ubuntu 14.04, senza successo.

Ho scaricato i seguenti pacchetti extra (Raring):

http://archive.ubuntu.com/ubuntu/pool/universe/i/ia32-libs/ia32-libs-multiarch_20090808ubuntu36_i386.deb
http://archive.ubuntu.com/ubuntu/pool/universe/i/ia32-libs/ia32-libs_20090808ubuntu36_amd64.deb
http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/libasound2_1.0.25-4ubuntu3.1_i386.deb
http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/libasound2_1.0.25-4ubuntu3.1_amd64.deb
http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/lib32asound2_1.0.25-4ubuntu3.1_amd64.deb
http://www.teamviewer.com/en/download/linux.aspx

Ma questi errori sono accaduti mentre stavo installando i pacchetti (ho anche provato a installare con il Software Center di Ubuntu, lo stesso):

$ sudo dpkg -i *.deb


Selecting previously unselected package ia32-libs.
(Reading database ... 254553 files and directories currently installed.)
Preparing to unpack ia32-libs_20090808ubuntu36_amd64.deb ...
Unpacking ia32-libs (20090808ubuntu36) ...
Selecting previously unselected package ia32-libs-multiarch.
Preparing to unpack ia32-libs-multiarch_20090808ubuntu36_i386.deb ...
Unpacking ia32-libs-multiarch (20090808ubuntu36) ...
Selecting previously unselected package lib32asound2.
Preparing to unpack lib32asound2_1.0.25-4ubuntu3.1_amd64.deb ...
Unpacking lib32asound2 (1.0.25-4ubuntu3.1) ...
dpkg: warning: downgrading libasound2:amd64 from 1.0.27.2-3ubuntu7 to 1.0.25-4ubuntu3.1
Preparing to unpack libasound2_1.0.25-4ubuntu3.1_amd64.deb ...
De-configuring libasound2:i386 (1.0.27.2-3ubuntu7) ...
Unpacking libasound2:amd64 (1.0.25-4ubuntu3.1) over (1.0.27.2-3ubuntu7) ...
Replaced by files in installed package libasound2-data (1.0.27.2-3ubuntu7) ...
dpkg: warning: downgrading libasound2:i386 from 1.0.27.2-3ubuntu7 to 1.0.25-4ubuntu3.1
Preparing to unpack libasound2_1.0.25-4ubuntu3.1_i386.deb ...
Unpacking libasound2:i386 (1.0.25-4ubuntu3.1) over (1.0.27.2-3ubuntu7) ...
Replaced by files in installed package libasound2-data (1.0.27.2-3ubuntu7) ...
Selecting previously unselected package teamviewer.
Preparing to unpack teamviewer_linux_x64.deb ...
Unpacking teamviewer (9.0.27891) ...
More than one copy of package libasound2:i386 has been unpacked
 in this run !  Only configuring it once.
dpkg: dependency problems prevent configuration of ia32-libs-multiarch:
 ia32-libs-multiarch depends on bluez-alsa; however:
  Package bluez-alsa:i386 is not installed.
 ia32-libs-multiarch depends on libgettextpo0; however:
  Package libgettextpo0 is not installed.
 ia32-libs-multiarch depends on gstreamer0.10-plugins-good; however:
  Package gstreamer0.10-plugins-good:i386 is not installed.
 ia32-libs-multiarch depends on gtk2-engines; however:
  Package gtk2-engines is not installed.
 ia32-libs-multiarch depends on gtk2-engines-murrine; however:
  Package gtk2-engines-murrine is not installed.
 ia32-libs-multiarch depends on gtk2-engines-pixbuf; however:
  Package gtk2-engines-pixbuf is not installed.
 ia32-libs-multiarch depends on gtk2-engines-oxygen; however:
  Package gtk2-engines-oxygen is not installed.
 ia32-libs-multiarch depends on ibus-gtk; however:
  Package ibus-gtk is not installed.
 ia32-libs-multiarch depends on libaio1; however:
  Package libaio1:i386 is not installed.
 ia32-libs-multiarch depen
dpkg: error processing package ia32-libs-multiarch (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libasound2:amd64:
 libasound2-data (1.0.27.2-3ubuntu7) breaks libasound2 (<< 1.0.27-4) and is installed.
  Version of libasound2:amd64 to be configured is 1.0.25-4ubuntu3.1.

dpkg: error processing package libasound2:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libasound2:i386:
 libasound2-data (1.0.27.2-3ubuntu7) breaks libasound2 (<< 1.0.27-4) and is installed.
  Version of libasound2:i386 to be configured is 1.0.25-4ubuntu3.1.

dpkg: error processing package libasound2:i386 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ia32-libs:
 ia32-libs depends on ia32-libs-multiarch; however:
  Package ia32-libs-multiarch is not configured yet.

dpkg: error processing package ia32-libs (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lib32asound2:
 lib32asound2 depends on libasound2 (= 1.0.25-4ubuntu3.1); however:
  Package libasound2:amd64 is not configured yet.

dpkg: error processing package lib32asound2 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of teamviewer:
 teamviewer depends on lib32asound2; however:
  Package lib32asound2 is not configured yet.
 teamviewer depends on ia32-libs; however:
  Package ia32-libs is not configured yet.

dpkg: error processing package teamviewer (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 ia32-libs-multiarch
 libasound2:amd64
 libasound2:i386
 ia32-libs
 lib32asound2
 teamviewer

Qualcuno sa come installare Teamviewer il 14.04?

    
posta antivirtel 22.04.2014 - 22:24

2 risposte

106

A partire da Ubuntu 11.10, non esiste più un pacchetto ia32-libs . Per questo motivo, i vecchi pacchetti x64 (come la versione x64 distribuita sul loro sito) non potranno più essere installati.

Da allora TeamViewer ha rimosso il download solo x64 e offre solo la versione i386.

Per installare TeamViewer ora, è semplice come visitare la pagina di download ufficiale , facendo clic su "Download" pulsante, quindi eseguendo il file .deb scaricato.

Se vuoi usare il terminale per questa operazione, è ancora fattibile:

  1. Afferra il debfile di TeamViewer:

     wget https://download.teamviewer.com/download/teamviewer_i386.deb
    
  2. Installa il file DEB scaricato:

     sudo dpkg -i teamviewer_i386.deb
    
  3. Se DPKG genera errori, correggi eventuali problemi di dipendenza per assicurarti che tutto funzioni correttamente:

     sudo apt update && sudo apt -f install
    

TeamViewer sarà ora pronto per l'uso e sarà presente nel tuo menu.

    
risposta data Kaz Wolfe 23.04.2014 - 00:35
0

Assicurati di aver installato wine, proprio come la risposta nel link fornito da @B. Roland. Wine è necessario, perché TeamViewer utilizza alcune librerie.dll fornite da wine.

    
risposta data oscarMg 22.04.2014 - 23:03

Leggi altre domande sui tag