Come installare il plugin Java per Firefox?

65

Sto cercando di installare Java e plugin per Firefox. Ho installato sia JDK che JRE.

Quando provo con il comando sudo update-alternatives --config java mostra solo una scelta disponibile.

I plugin non sono utilizzabili in Firefox.

    
posta user199273 06.10.2013 - 13:51

6 risposte

72

Se utilizzi una versione successiva a 52 (non ESR), quale NPAPI disattivato , sei fuori di fortuna. Se si sta usando un precedente, che non si vorrebbe assolutamente, è possibile installare OpenJDK JRE, che consentirebbe di eseguire i binari Java localmente usando il% b_e java . Questo, tuttavia, non è sufficiente per eseguire applet web Java sul tuo browser, cosa che può essere ottenuta installando il plugin Icedtea:

sudo apt-get install icedtea-plugin

Quindi vai a about:addons , nella sezione plugin, controlla se il plugin è abilitato. Mozilla disabilita i plugin non sicuri per impostazione predefinita, il che significa che Java è disabilitato anche dopo l'installazione a causa di problemi di sicurezza. Devi attivarlo prima di usarlo.

    
risposta data Braiam 06.10.2013 - 16:26
22

Installazione del plugin Java IcedTea:

Per installare il plug-in IcedTea Java, apri un terminale e digita:

sudo apt-get install icedtea-7-plugin

Installa il plug-in di Firefox - Oracle

In un terminale:

mkdir ~/.mozilla/plugins

Rimuovi il plugin IcedTea, se è stato installato.

sudo apt-get remove icedtea6-plugin

Rimuovi una versione precedente del plugin Java (potrebbe essere o non essere presente)

rm ~/.mozilla/plugins/libnpjp2.so

Ora puoi installare il plugin, creando un collegamento simbolico (dirai a Firefox dove si trova il plugin). Per Java a 32 bit, utilizzare

ln -s /usr/lib/jvm/jre1.7.0/lib/i386/libnpjp2.so ~/.mozilla/plugins/

Per uso Java a 64 bit

ln -s /usr/lib/jvm/jre1.7.0/lib/amd64/libnpjp2.so ~/.mozilla/plugins/

Conferma che JRE ha avuto successo utilizzando il sito Web Oracle ufficiale .

Fonte: Installazione Java

    
risposta data M.Tarun 13.04.2017 - 14:24
5

A partire dalla versione 52 di Firefox, il supporto per i plugin NPAPI (applet java) in Firefox è terminato, a causa di problemi di prestazioni e sicurezza, il modo in cui riesco a eseguire le applet java consiste nell'installare la Extended Support Release (ESR) di firefox .

scarica qui: link

maggiori dettagli qui: link

    
risposta data mozzi zadok 12.03.2017 - 22:25
3

Se hai appena scaricato e installato java jdk da oracle, diciamo che hai installato jdk-8u91-linux-x64.tar.gz su

/ mio / java / directory /

Quindi avrai una directory come:

/my/java/directory/jdk1.8.0_91 /

Tutto quello che devi fare è andare nella directory dei plugin di ubuntu firefox e creare un link:

$: cd /usr/lib/firefox-addons/plugins/
$: sudo ln -s /my/java/directory/jdk1.8.0_91/jre/lib/amd64/libnpjp2.so
    
risposta data luis_js 26.05.2016 - 15:55
2

Questo è un thread vecchio, ma mi sono imbattuto in esso mentre cercavo su Google una soluzione al mio problema oggi. Ho pensato che qualcun altro potesse trovarsi nella stessa situazione.

Ho bisogno di Java in-browser per siti Web correlati al lavoro legacy, e il plugin java oracle non lo taglia. Dopo un lungo approccio trial-and-error, ho fatto in modo che IcedTea funzionasse in modo coerente in una versione precedente di firefox come questa:

  • Scarica un pacchetto di Firefox, versione 51 (la versione più recente non supporta il plugin)
  • Installa OpenJDK (7 o 8)
  • Installa il plugin icedtea - e il plugin icedtea
  • Ora la tua installazione di openJDK conterrà un file IcedTeaPlugin.so nella cartella jre / lib
  • copia questo nelle cartelle del plugin mozilla / firefox (non riuscivo a capire quale copiare per copiarlo, quindi l'ho appena copiato su qualsiasi cosa firefox / plugins o mozilla / plugins)
  • avvia la tua vecchia versione di firefox
  • verifica che il plugin sia attivo (controlla su: plugins)

Uno dei miei colleghi ha creato uno script per rimuovere il vecchio firefox e decomprimerlo ad ogni esecuzione. In questo modo non viene mai aggiornato accidentalmente. Assicurati di non farlo con la tua applicazione firefox principale.

Spero che questo ti aiuti.

    
risposta data Stijn Dejongh 26.06.2017 - 19:28
0

È stata una battaglia, soprattutto da quando ho passato questo un paio di mesi fa con 14.04, ho dimenticato la soluzione, aggiornato a 16.04 .....

È diverso che Iced-the e Oracle funzionassero con firefox nel 14.04. In realtà preferisco Oracle (non in generale, ma il mio uso lo richiede quasi) quindi l'ho solo ora. Non ho provato più installazioni o repository. Anche i collegamenti simbolici come per la maggior parte delle istruzioni non sono validi.

Alla fine, in Firefox è andato a Modifica - & gt; Preferenze - & gt; Le applicazioni scorrono fino all'estensione del file JNLP e selezionano "Usa altro ..." dal menu a discesa. Quindi trovato javaws dalla directory pertinente.

È solo una soluzione alternativa e non sono sicuro che soddisferà le tue esigenze. Tieni presente che la maggior parte dei plug-in sarà disattivata entro marzo.

    
risposta data michael 31.01.2017 - 14:42

Leggi altre domande sui tag