Perché passare alla tty mi dà uno schermo vuoto?

66

Dopo l'avvio alla GUI in 12.04, cerco di passare al terminale virtuale (o shell, o tty) tramite Ctrl - Alt - F1 ( F1 attraverso F6 ), e lo schermo rimane vuoto. Ho provato tutte le 6 istanze di tty e i risultati sono gli stessi. Ctrl - alt - F7 mi riporta alla GUI senza problemi. Qualche idea?

    
posta SeanO 11.07.2012 - 21:47

5 risposte

62

Questo di solito è causato dal fatto che la risoluzione in modalità testo impostata all'avvio non è compatibile con la tua scheda video. La soluzione è passare alla modalità testo vero configurando Grub in modo appropriato:

  1. Apri il terminale con Ctrl + Alt + T
  2. Incolla il seguente e inserisci la tua password quando richiesto:

    sudo sed -i -e 's/#GRUB_TERMINAL/GRUB_TERMINAL/g' /etc/default/grub
    
  3. Quindi digita sudo update-grub

  4. Riavvia e ora i terminali virtuali dovrebbero funzionare.
risposta data ish 12.07.2012 - 00:56
14

Ciò che ha risolto questo problema per me è stato l'aggiunta di nomodeset alla riga GRUB_CMDLINE_LINUX_DEFAULT nel file /etc/default/grub . Ecco come:

  1. Digita terminale: gksu gedit /etc/default/grub

  2. Cerca questa riga: GRUB_CMDLINE_LINUX_DEFAULT

    Quindi ad esempio se hai:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"
    

    cambialo in:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 nomodeset"
    
  3. Al termine, aggiorna grub ( sudo update-grub ) e riavvia ( sudo reboot ) affinché le modifiche abbiano effetto.

Facoltativo : puoi aggiungere nomodeset vga=xxx (non solo nomodeset ), il xxx è un codice dello schermo VESA che si adatta meglio alla risoluzione dello schermo. Dai un'occhiata a questo .

    
risposta data Mina Michael 18.01.2016 - 21:15
5

Questo è per la versione più recente di Ubuntu:

  1. Modifica il file di configurazione di GRUB:

    sudo nano /etc/default/grub
    
  2. Trova la linea

    #GRUB_GFXMODE=640x480
    

    cambialo in

    GRUB_GFXMODE=auto
    

    e salva il file.

  3. Quindi aggiorna grub

    sudo update-grub
    
risposta data Michael 10.09.2017 - 20:01
1

Dai un'occhiata alla mia domanda al link , per quanto riguarda il terminale virtuale non funzionante su Ubuntu 16.04 su Lenovo Thinkpad T400.

La soluzione che ho presentato è orientata verso l'utente con Hybrid Graphics Card, in particolare, la scheda grafica AMD / ATI e la scheda grafica integrata Intel. Per me, disabilitare la scheda grafica Intel e abilitare il modulo radeon ATI / AMD opensource aiuta nel mio caso.

Se utilizzi una vecchia scheda grafica Radeon come la mia (Radeon HD 3450/3470), ora puoi passare dal terminale virtuale al desktop grafico con facilità per risolvere i potenziali problemi.

Se aggiungi blacklist intel_graphics_card in /etc/modprobe.d/blacklist.conf ed esegui

sudo depmod -a 

continua a non funzionare a causa del kernel di Linux o altre dipendenze, ti consigliamo di aggiungere modprobe.blacklist=<module_name> a /etc/default/grub come nell'esempio seguente:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash crashkernel=384M-:128M radeon.dpm=1  modprobe.blacklist=i915"
    
risposta data Jiawan 탁가만 Yovan 19.06.2017 - 07:59
0

Devi chiudere il driver grafico dopo Ctrl + Alt + F1 prima di provare a installare il driver Nvidia

As in sudo /etc/init.d/lightdm stop

    
risposta data Pat Hertel 26.02.2015 - 01:25

Leggi altre domande sui tag