Come posso disabilitare lo spostamento della finestra con alt + tasto sinistro del mouse in GNOME Shell?

71

Ci sono lotti di posts su questo su Unity, questo riguarda la shell GNOME .

Come con altri poster, uso app (Inkscape in particolare) che usa Alt -Click e Alt -drag. La shell GNOME mi sta scaricando e quindi disabilita le funzionalità nell'applicazione.

Ho provato

  • utilizzando il plug-in Move di ccsm - puoi disattivarlo e puoi ancora spostare la finestra di trascinamento Alt.

  • utilizzando l'editor gconf per modificare /apps/metacity/general/mouse_button_modifier - questo non ha alcun effetto AFAICS.

Mi sta davvero ostacolando. In caso contrario, trovo la shell GNOME un ambiente davvero produttivo.

    
posta artfulrobot 02.04.2012 - 13:02

8 risposte

104

Prima di tutto, installa dconf-tools .

Per farlo, esegui il seguente comando:

sudo apt-get install dconf-tools

Quindi aprilo, Alt + F2 dconf-editor .

Scorri verso il basso fino a orggnomedesktopwmpreferencesmouse-button-modifier → Imposta su qualsiasi chiave che ti piace.

O,equivalentemente,

gsettingssetorg.gnome.desktop.wm.preferencesmouse-button-modifier"<Super>"

nel terminale. (Questo non richiede né dconf-editor , né dconf-tools )

Avviso: impostarlo su nulla significa che tutti i clic spostano le finestre, invece di disabilitarle!

    
risposta data jokerdino 02.04.2012 - 14:34
8

Per risolvere il problema di trascinamento della finestra di spostamento Alt + clic:

sudo gconftool-2 --set /org/gnome/desktop/wm/preferences/mouse-button-modifier --type string '<Super>'

Fa la stessa cosa, davvero, solo con uno strumento di configurazione diverso e meno caccia e clicca.

Per le versioni più recenti che usano dconf / gsettings, usa questo:

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>"
    
risposta data cajhne 18.05.2012 - 20:03
7

Utilizza lo strumento Tweak ( gnome-tweak-tool ):

Windows & gt; Tasto azione finestra

    
risposta data simplegamer 21.02.2017 - 00:34
6

Ho impostato Alt + Super come una soluzione temporanea. Quindi posso usare la chiave Alt in Inkscape e Super per le attività.

    
risposta data KEIII 19.04.2012 - 03:34
3

In UBUNTU 14.04 LTS usa in sintassi dconf come

<Alt><Super>

Funziona bene per me.

BTW: se si imposta qualcosa di sbagliato, inizia a spostare la finestra ad ogni clic. Utilizzare per accedere al pulsante "Imposta su predefinito". E colpisci.

    
risposta data Matěj Kříž 31.03.2015 - 10:05
2

In Mint questo può essere modificato o disabilitato in system settings & gt; windows & gt; behavior & gt; % Co_de%

    
risposta data charsi 29.01.2018 - 12:11
1
  1. Vai a Impostazioni di sistema
  2. Seleziona tastiera
  3. In basso a sinistra, fai clic su "Impostazioni di layout"
  4. Seleziona la tua lingua e fai clic sul pulsante "Opzioni" in basso a destra
  5. Seleziona 'Alt / Win key behavior'
  6. Sostituiscilo con quello che ti piace. Io uso 'Left Alt è scambiato con Left Win'.
risposta data user143321 25.03.2013 - 17:32
0

in CentOS 7, ho dovuto usare

 gsettings set org.gnome.desktop.wm.keybindings activate-window-menu "['<Alt>F10']"

Questa impostazione non era stata specificata, il che significava che il pulsante centrale del mouse attivava il menu della finestra. Anche impostando

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier '<Super>'

non ha spostato quell'azione in Alt-middle; Ho dovuto associare activate-window-menu .

    
risposta data djb 19.04.2017 - 21:54

Leggi altre domande sui tag