Come faccio a scaricare e installare il freno a mano?

60

Sono nuovo su Ubuntu quindi non conosco molto bene come utilizzare il terminale per scaricare e installare programmi che non si trovano nel centro software. Ho provato senza successo a scaricare e installare Handbrake.

Qualcuno potrebbe aiutarmi, guidandomi attraverso il download e l'installazione di Handbrake?

    
posta Paula 26.02.2012 - 13:45

6 risposte

77

Ci sono due PPA di HandBrake ufficiali, ppa:stebbins/handbrake-releases e ppa:stebbins/handbrake-git-snapshots .

Il primo contiene versioni stabili, che vengono aggiornate una volta all'anno. Queste versioni tendono ad essere piuttosto antiquate quando si avvicina la fine della loro vita. L'attuale versione stabile (0.9.8) è stata rilasciata il 18-07-2012.

Quest'ultimo contiene build notturni, che vengono aggiornati quotidianamente (o di notte, per così dire). Questi sono ovviamente meno stabili e non documentati per l'avvio, ma sono comunque un buon software. Inoltre, con l'invecchiamento della versione stabile, gli sviluppatori tendono a consigliare agli utenti di provare invece le versioni notturne.

Per aggiungere uno di questi ai tuoi sorgenti, esegui semplicemente:

sudo add-apt-repository ppa:stebbins/handbrake-releases

o

sudo add-apt-repository ppa:stebbins/handbrake-git-snapshots

dipende da quale vuoi. Per installare HandBrake con la GUI, esegui:

sudo apt-get update
sudo apt-get install handbrake

In alternativa, se preferisci la CLI (interfaccia della riga di comando) sulla GUI, sostituisci l'ultima riga con:

sudo apt-get install handbrake-cli
    
risposta data bessman 26.02.2012 - 14:34
9

Il freno a mano ppa è stato aggiornato con l'ultima versione del freno a mano.

PPA

Per installare copia / incolla le prossime linee di codici una per una nel tuo gnome-terminal

sudo add-apt-repository ppa:stebbins/handbrake-releases
sudo apt-get update
sudo apt-get install handbrake-cli handbrake-gtk

Attualmente supporta : Raring (13.04), Quantal (12.10), Precise (12.04), Oneiric (11.10), Natty (11.04), Maverick (10.10), Lucid (10.04), Karmic (9.10).

Nota : puoi ancora installare l'ultima versione del freno a mano su Ubuntu 13.10, scaricando manualmente i file .deb appropriati:

Sono riuscito a installarli su Ubuntu 13.10 amd64 senza problemi

Dall'origine

Se vuoi compilarlo dal sorgente, ecco cosa ha funzionato per me:

installa prima le dipendenze.

sudo apt-get install bzr subversion yasm build-essential \
autoconf libtool zlib1g-dev libbz2-dev libfribidi-dev \
intltool libglib2.0-dev libdbus-glib-1-dev libgtk2.0-dev \
libgudev-1.0-dev libwebkit-dev libnotify-dev \
libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev

Quindi scarica e compila

bzr branch lp:handbrake
cd handbrake
./configure
cd ./build
sudo make
sudo make install

Origine :

risposta data blade19899 27.02.2012 - 10:24
3

HandBrake è disponibile nel Software Center di Ubuntu, cercalo

Se non hai apportato alcuna modifica alle Sorgenti software, dovresti essere indirizzato a una pagina di installazione anziché a ciò che è nell'immagine sopra. Per aggiungere la fonte "universo" alle tue fonti, vai a Modifica & gt; Sorgenti software e controlla sotto la scheda Software Ubuntu il "Software gratuito e open-source (universo) gestito dalla community" e chiudi.

Oppure fai clic sul pulsante per utilizzare tale fonte.

    
risposta data arsaKasra 23.05.2014 - 15:53
1

Il freno a mano non ha alcun supporto ppa in 12.04. Se hai provato ad aggiungere i PPA e ottieni ancora l'errore, questa soluzione ha risolto il problema per me

sudo rm /etc/apt/sources.list.d/stebbins-handbrake-*
sudo apt-get update

sudo apt-add-repository ppa:stebbins/handbrake-snapshots
sudo apt-get update

sudo apt-get install handbrake-gtk handbrake-cli

Devi eseguire il processo di aggiornamento due volte, la prima volta per rimuovere i ppas non validi dalla lista dei risultati, e la seconda volta aggiunge il PPA corretto.

    
risposta data Jason 30.05.2012 - 14:09
0

Ho dovuto aggiungere questi pacchetti per compilare su Ubuntu 12.04 LTS:

sudo apt-get install libass-dev libtheora-dev libvorbis-dev libsamplerate-dev

Il binario è quindi in build/gtk/src (ghb) e puoi eseguirlo direttamente senza utilizzare makeinstall .

    
risposta data Joe nobody 26.08.2013 - 17:08
0

Nessuna delle precedenti soluzioni ha funzionato con Ubuntu 13.10. Quello che coinvolge "bzr" è finito con:

../libhb/decssasub.c:30:21: fatal error: ass/ass.h: No such file or directory
 #include <ass/ass.h>
                 ^
compilation terminated.
make: *** [libhb/decssasub.o] Error 1

Tuttavia sono riuscito a farlo funzionare scaricando direttamente e installando usando dpkg. (tratto da link )

Per 32 bit:

wget https://launchpad.net/~stebbins/+archive/handbrake-releases/+files/handbrakegtk_0.9.9ppa1~raring1_i386.deb

Per 64 bit:

wget https://launchpad.net/~stebbins/+archive/handbrake-releases/+files/handbrakegtk_0.9.9ppa1~raring1_amd64.deb

Quindi installare     sudo dpkg -i handbrake-gtk_0.9.9ppa1 ~ raring1 _ *. deb

e correzione delle dipendenze    sudo apt-get -f install

Per favore dimmi nei commenti se sai quale libreria mi manca per l'opzione "bzr" per funzionare. Ho una installazione di Ubuntu abbastanza nuova.

Saluti,   Stuart.

    
risposta data u02sgb 14.03.2014 - 21:14

Leggi altre domande sui tag