Ubuntu supporta USB 3.0?

60

Ho un hard disk esterno desktop Western 3.0 My Book 3.0 - 1 TB USB 3.0, e volevo sapere se avrebbe funzionato su Ubuntu 10.10 Maverick Meerkat.

    
posta sudobash 08.11.2010 - 19:25

10 risposte

60

Sì, Ubuntu supporta USB 3.0.

Linux ha iniziato a supportare USB 3.0 nella versione di settembre 2009 del kernel 2.6.31 e Ubuntu 9.10 Karmic Koala è stata la prima versione di Ubuntu a supportare USB 3.0.

Nelle versioni di Ubuntu precedenti a Ubuntu 11.04 Natty Narwhal, c'è un bug nel modulo del kernel XHCI (USB 3.0) che impedisce la sospensione: Bug # 522998 .

    
risposta data Sid 08.11.2010 - 19:29
11

a quanto pare c'è un problema: ( 522998 )

Quando il modulo XHCI viene caricato per il funzionamento USB 3.0, il sistema non può sospendere. Lo scarico manuale di XHCI consentirà il completamento normale della sospensione.

Per evitare futuri problemi di sospensione, la soluzione alternativa è aggiungere SUSPEND_MODULES="xhci-hcd" per /etc/pm/config.d/unload_module il sistema può quindi sospendere normalmente.

    
risposta data hhlp 08.11.2010 - 19:34
5

Sì, lo sarà. Il kernel attuale supporta USB 3.0, quindi non dovresti avere problemi a usare l'unità.

A proposito, Linux è stato il primo ad avere il supporto per USB 3.0: link

    
risposta data Rafał Cieślak 08.11.2010 - 19:31
2

Potrebbe essere utile notare che avvio USB 3.0 non è ancora supportato.
Segnala bug 565047 .

    
risposta data nik 29.04.2011 - 11:55
1

Sì, supporta USB 3.0, vedi il link qui sotto, Ho collegato due tramite USB 2.0 funziona perfettamente. USB 3.0 è in calo con 2.0. Le mie porte USB sono 2.0 ma l'HDD è 3.0.

link

    
risposta data karthick87 08.11.2010 - 19:34
1

Ho Ubuntu 11.10 in esecuzione su VMware Player 4.0 e, dopo molte ricerche, ho trovato quanto segue nelle note di rilascio di VMware:

  

Il supporto USB 3.0 è disponibile per i guest Linux che eseguono la versione del kernel 2.6.35 o successiva (Ubuntu 10.10) attraverso un nuovo controller xHCI USB virtuale. Per abilitare questa funzione, aggiungi la seguente riga al file .vmx: usb_xhci.present="true". Non abilitare questa funzione per i guest Windows. Poiché Windows non dispone attualmente di un driver xHCI generico, questa funzione non funzionerà in Windows.

Dopo aver aggiunto questa linea al mio file .vmx, il sistema ora rileva l'HDD USB 3.0 che ho collegato.

    
risposta data lsoutar 17.12.2011 - 15:19
1

Credo che il problema sia legato all'hardware e nulla a che fare con (k) ubuntu. Ho un nuovo PC con 2 porte USB3 configurate per il dual boot tra Windoze 7 e Kubuntu 13.10. Le porte funzionavano bene con Windoze ma non con Kubuntu.

Navigando nei forum per una soluzione, ho trovato la risposta in un forum Linux Mint (derivato di Ubuntu). Apparentemente le porte USB3 interne inserite nell'header a 20 pin della scheda madre non saranno riconosciute da Linux.

La risposta è comprare una scheda di espansione da PCI-E a USB 3. Ho acquistato la scheda Inateck Superspeed da Amazon, l'ho inserita nello slot di espansione PCI-E della mia scheda madre (DEVE essere uno slot PCI-E, non funzionerà con lo standard PCI) e all'avvio il mio PC ha riconosciuto immediatamente le porte e le unità connesse. (Windoze ha dovuto aspettare fino a quando non ho installato il driver in dotazione).

    
risposta data David Broom 18.02.2014 - 03:04
0

Oltre ai post di cui sopra devo anche aggiungere che Linux è il primo sistema operativo a supportare USB 3.0 grazie all'hacker di Intel Sarah Sharp. Il che lo rende uno dei primi passi che fa un piccolo suggerimento su come Linux sarà nel prossimo futuro rispetto ad altri ..... "sistemi"

    
risposta data Luis Alvarado 03.01.2011 - 22:26
0

Sembra che il sistema cerchi un'unità USB 2.0 da qualche parte durante la sequenza di avvio, anche se è stata avviata da un'unità USB 3.0. Questo è quello che ho fatto:

Possiedo un'unità Western Digital MyPassport (USB 3.0) e un PC HP Elitebook 8540W con 2 porte USB 3.0 e 2 porte USB 2.0. Quando avvio da una porta USB 2.0, va tutto bene. Quando avvio da una porta USB 3.0, si avvia l'avvio, ma si ferma da qualche parte nel mezzo riportando un errore (nessun sistema live trovato o qualcosa del genere - posso inviare il codice specifico se lo si desidera)

Così ho creato un altro HD avviabile: Lacie 300GB (USB 2.0 e installato la stessa versione di Ubuntu su di esso: Ubuntu 10.10 i386 (Il mio PC è un processore a 64 bit, ma uso i dischi USB avviabili anche su altri PC)

Strano:

Quando collego ENTRAMBI il Lacie a una porta USB 2.0 E Western Digital a una porta USB 3.0 ALLO STESSO TEMPO e avvio il PC, riesco ad avviare l'avvio da USB 3.0 (tramite la sequenza di avvio Bios del mio PC ) ma ottengo il desktop del sistema che si trova sull'unità Lacie USB 2.0. Ho usato uno sfondo desktop diverso per essere sicuro al 100% per distinguere entrambi i sistemi. A parte il desktop, sono identici.

Quindi penso da qualche parte durante la sequenza di avvio, il sistema cerca un'unità collegata alla porta USB 2.0 e non quella connessa alla porta USB 3.0 anche se ha avviato l'avvio da USB 3.0

    
risposta data hvanmunster 16.01.2011 - 11:18
0

Ho avuto lo stesso problema. Questa era una carta di espansione. Dopo un'ora di confusione, ho pensato di guardare di nuovo la carta all'interno. e naturalmente ho dimenticato di collegare il cavo di alimentazione alla scheda. Correzione semplice.

    
risposta data Daniel O'Brien 14.12.2016 - 04:23

Leggi altre domande sui tag