Skype e VLC suona sfrigolante / distorto / cattivo

51

Ho lo stesso problema descritto nelle domande suoni di notifica skype sfrigolati e Suono errato all'accesso per skype . Ma non è solo il login, la notifica, ma anche quando si parla con qualcuno. Ho provato la soluzione per rimuovere / reinstallare skype e la maggior parte delle soluzioni in queste domande, ad es. controllo del mixer, impostazioni del suono e installazione di alsa-hda-dkms (incluso il riavvio del sistema).
Dopo l'installazione di skype (e anche dopo l'upgrade a skype 4.0) in Ubuntu 12.04 (AMD 64) non si sentiva alcun suono. Ho seguito il primo passaggio della SoundTroubleshootingProcedure e almeno ora c'è il suono:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa; sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-'uname -r' libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-'uname -r' libasound2; killall pulseaudio; rm -r ~/.pulse*; sudo usermod -aG 'cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print }' | tr '\n' ',' | sed 's:,$::g'' 'whoami'

Il suono di jitter a volte scompare, ad es. su Echo-Testcall dopo aver riprodotto la parte registrata. E ho notato che se lascio che la musica suoni nel rhythmbox e poi inizi a skype, il suono va bene. Quindi ho una soluzione debole, ma sarei felice che funzionerebbe senza questa deviazione.

In VLC quando suono, riavvio dopo pausa, ho lo stesso suono jitter.

Come richiesto: La mia scheda audio è un "dispositivo audio AMD ad alta definizione" denominato Advanced Micro Devices (AMD) controller Hudson Azalia (rev01), sottosistema Lenovo Device 21ea (secondo sysinfo) su Lenovo Thinkpad Edge 525.

    
posta Filbuntu 30.06.2012 - 09:03

9 risposte

92

Non è solo un problema con Skype, credo che sia un problema, lo hai indovinato, PulseAudio.

Per risolvere il problema? In effetti c'è.

Disattivare Audio Glitch Free di PulseAudio sembra aver risolto il crepitio per me (che divenne insopportabile su Ubuntu 12.10 Beta 2)

Per fare ciò, modifica il file /etc/pulse/default.pa nel tuo editor di testo preferito.

Cerca la seguente riga:

load-module module-hal-detect

e aggiungi " tsched=0 " alla fine:

load-module module-hal-detect tsched=0

riavvia l'impulso (o riavvia il sistema) e il crepitio dovrebbe sparire.

Non sei sicuro di quali siano gli effetti collaterali disattivando l'audio Glitch Free, ma non riesco a trovarlo.

UPDATE: Se non hai una linea con load-module module-hal-detect , cerca la seguente riga:

load-module module-udev-detect  

e aggiungi " tsched=0 " alla fine:

load-module module-udev-detect tsched=0

riavvia l'impulso (o riavvia il sistema) e il crepitio dovrebbe sparire.

    
risposta data Robert Ian Hawdon 16.10.2012 - 16:28
3

Se sospetti che sia colpa di pulseaudio i problemi, potrebbe esserci una soluzione più semplice per te. Ho pubblicato un articolo con le istruzioni passo passo sul mio blog su come correggere il suono cattivo in Ubuntu . Questa è una correzione per Wine, ma poiché si tratta di una modifica di un file di configurazione di pulseaudio, potrebbe essere applicabile ad altri problemi simili.

    
risposta data Seven_Six_Two 11.07.2012 - 16:28
3

La soluzione fornita sopra da Robert ha funzionato per me. Avevo aggiornato a 12.10 ubuntu e il nuovo aggiornamento di skype 4.0 aveva un suono inutilizzabile (graffiante e distorto). modifica secondo le istruzioni precedenti e aggiungendo la seguente riga a: load-module module-hal-detect tsched = 0 nel file /etc/pulse/default.pa ha risolto perfettamente il problema.

Per consapevolezza, l'aggiornamento alla 12.10 ha causato il mancato riconoscimento della mia scheda Soundblaster come predefinita. Per qualche ragione, ora era in default a pensare che la mia scheda grafica NVIDIA fosse la scheda audio predefinita. Inizialmente Skype avrebbe reso NO suono .
Questo può essere corretto seguendo le indicazioni riportate nel forum di Ubuntu da billesboelle il 27 luglio 2008. Qui ripetuto per inclusività: Non riesco ad avere Ubuntu di default selezionare la scheda pci, dopo aver provato le impostazioni dalla guida completa di soundprob come di seguito:
Sembra che la funzione index = 0 non mi aiuti. Forse è dovuto al fatto che la mia macchina registra 2 driver audio con lo stesso nome? cat /proc/asound/modules fornisce questa risposta:

0 snd_hda_intel  
1 snd_hda_intel  
2 snd_cmipci  

Qualche idea o qualcosa che vuoi vedere prima di essere in grado di aiutarmi. Btw, ho dimenticato di menzionare. Se provo l'opzione index, my pci può essere rimosso da aplay -l e cat / proc / asound / modules.

Configurazione delle schede audio predefinite / arresto di più schede audio dalla commutazione Nota: questa sezione presuppone che sia stata installata correttamente ciascuna scheda audio.

In una shell, digita

    cat /proc/asound/modules 

Questo darà il nome e l'indice di ogni scheda audio che hai al momento. Prendi nota dei nomi e decidi quale vuoi essere la carta predefinita.

Adesso scrivi

    sudo nano /etc/modprobe.d/alsa-base

Alla fine del file, aggiungi quanto segue (assumendo che tu abbia 3 carte con i nomi dei moduli A, B e C e desideri averle nell'ordine CAB)

options snd-C index=0  
options snd-A index=1  
options snd-B index=2
    
risposta data Coop999 23.11.2012 - 16:39
2

Correzione per ubuntu 16.04

sudo vim /etc/pulse/daemon.conf trova default-fragment-size-msec , nel mio caso è stato disabilitato, quindi rimuovi ; all'inizio della riga, quindi dovrebbe apparire come default-fragment-size-msec = 5 (ho sostituito il valore predefinito 25 di 5 ). Quindi basta uccidere il servizio pulseaudio --kill e ubuntu si riavvierà pulseaudio, se non si verifica per qualsiasi motivo, quindi basta riavviare il sistema.

Ora riesco a sentire la voce di skype molto chiara.

    
risposta data Viktor 26.02.2018 - 22:31
1

Ho avuto lo stesso problema su Archlinux. È venuto fuori che pulseaudio stava causando questo. Per liberarmi di pulseaudio ho ripristinato il suono chiaro in Skype per me. Per le distribuzioni basate su Gnome come Ubuntu principale è probabilmente impossibile rimuovere pulseaudio poiché è una dipendenza per la maggior parte delle cose di gnome, incluso gdm, ma su kubuntu, xubuntu e lubuntu questo potrebbe effettivamente funzionare dato che inizialmente non vengono con pulseaudio e gnome bloatware, e se è stato installato molto probabilmente è successo come dipendenza da qualche altro pacchetto che dipende da gnome o dalle sue librerie.

    
risposta data ccpizza 30.06.2012 - 10:00
1

Ho appena rimosso pulseaudio da Ubuntu 12.04 sul mio toshiba p875-s7200 e ho risolto skype splendidamente! il suono è andato da schifo a fantastico :) nota: ho dovuto installare alsa-hda-dkms per ottenere il suono su questo laptop

    
risposta data dave 13.07.2012 - 01:31
0

Questo ha funzionato per me, ubuntu 12.10 / 64, mb asus m4a785tdv-evo amd64 (audio VIA VT1708S)

modificato il /etc/pulse/default.pa ( sudo pico /etc/pulse/default.pa )

non ha trovato load-module module-hal-detect

quindi ho appena modificato la riga load-module module-udev-detect , in modo da avere:

load-module module-udev-detect tsched=0

salvate le modifiche e riavviato il sistema. Adesso Skype sembra a posto. fino ad ora ho avuto problemi nell'usare Skype con crepitio / eco / rumore che a volte si sono adattati / fermati durante la conversazione (a volte si risolvevano quando si chiudeva il browser), ma a volte continuava a compromettere pesantemente la conversazione. Skype apparentemente era l'unica situazione con problemi audio per me.

    
risposta data user119773 08.01.2013 - 18:55
0

Nessuna delle soluzioni pubblicate finora ha funzionato per me il 14.04, ma l'impostazione del modulo audio su alsa in Preferenze- & gt; Audio- & gt; L'output l'ha sistemata per me su vlc.

    
risposta data Chiel ten Brinke 28.03.2015 - 19:50
-4

Verifica la connessione Internet ( link per il test di velocità).

Inoltre, poiché funziona dopo RyhthmBox, puoi anche provare ad aggiornare i driver (per la scheda audio).

Potrebbe anche aiutare altri rispondenti se ci hai detto che tipo di scheda audio hai nel tuo computer.

    
risposta data Farid 30.06.2012 - 09:08

Leggi altre domande sui tag