Come disabilitare il comportamento di alt-hotkey sul terminale gnome?

55

Questo non è solo un terminale gnome, ma praticamente tutte le finestre gnome: quando si tiene premuto il tasto "alt", è possibile premere la prima lettera di una delle voci del menu. Questo ti permetterà di scorrere quel menu senza cliccarci direttamente.

Va ​​bene su qualsiasi altra finestra, come ad esempio Firefox, ma su terminale gnome, ruba i tasti che uso per emacs !! Ci sono poche possibilità che io impari nuove combinazioni di tasti se posso evitare.

Se non riesco a isolarlo solo su GNOME, sto bene.

    
posta farleyknight 13.03.2011 - 21:48

5 risposte

53

Modifica & gt; Tasti di scelta rapida ... e deseleziona "Abilita tasti di accesso al menu".

    
risposta data geekosaur 13.03.2011 - 22:01
4

Per il terminale Gnome 3.14.1: fai clic su Modifica (sulla barra dei menu) & gt; Preferenze & gt; Infine, nella scheda "Generale", deseleziona "attiva mnemonica ...".

    
risposta data Santropedro 10.01.2016 - 02:16
3

Anche questo mi sta facendo impazzire. Mi piacerebbe usare Alt-V per incollare perché è molto più ergonomico rispetto all'utilizzo di CTRL, ma questo non sembra possibile a causa dell'opzione di menu Visualizza.

Nel complesso questo sembra un errore perché quando disabilito i tasti di scelta rapida in Preferenze non sono più in grado di usare Alt-V per accedere al menu Visualizza, ma non sono in grado di usare questa combinazione per altre cose.

Sono riuscito a far funzionare Alt-Z perché non esiste un menu che inizia con Z.

    
risposta data Fonnae 25.03.2013 - 13:13
3

Se vuoi farlo globalmente, puoi provare questo metodo ( fonte ):

  

Per disabilitare i mnemonici dovresti creare (se non esiste già) ~ / .gtkrc-2.0.   Questo file dovrebbe contenere la riga gtk-enable-mnemonics = 0 (è possibile   aggiungi altre impostazioni GTK se lo desideri). Quindi, riavviare per le modifiche   avere effetto (potresti essere in grado di disconnettersi, quindi accedi invece).

     

Il tasto alt continuerà comunque a far apparire i menu in alcuni casi, ma il   i mnemonici ora sono disabilitati. Hoorah!

EDIT: questo metodo non funziona più. Ho presentato un rapporto sui bug riguardante la domanda dell'OP, quindi vedremo come evolverà.

    
risposta data metakermit 01.02.2013 - 23:10
2

In Ubuntu 16.04, vai su Impostazioni di sistema - & gt; Tastiera - & gt; Scorciatoie - & gt; Lanciatori e cancella il tasto per mostrare l'HUD (o cambialo su un altro tasto)

    
risposta data Peter 01.07.2016 - 06:17

Leggi altre domande sui tag