Audio proveniente da cuffie e altoparlanti

47

Credo che questa domanda abbia già avuto la risposta qui, ma non riesco a trovarla. Sto usando 12.04.

Aggiornamento:

Il problema è che riesco a sentire il suono dagli altoparlanti del mio portatile anche se ho collegato le cuffie. Le cuffie sono solo cuffie stereo standard. E la cosa più interessante è che tutto funzionava solo una settimana fa.

Ho provato a giocare con pulseaudio e alsamixer impostazioni - nessun risultato.

    
posta Ilay 14.06.2012 - 18:26

16 risposte

23

Soluzione originale

  1. Vai a sito ufficiale Realtek , accetta la dichiarazione di non responsabilità, quindi scarica il driver audio per linux / unix. Devi selezionare la versione 3 per Kernel 3 o successivo.

  2. Imposta gli strumenti necessari per compilare questo driver.

    sudo apt-get install build-essential gcc make

  3. Estrai il file scaricato, esegui sudo ./install file da un terminale dopo aver raggiunto la cartella estratta per compilare il driver.

  4. Leggi il file Readme.txt per ulteriori informazioni.

  5. Installa gnome-alsamixer con questo comando.

    sudo apt-get install gnome-alsamixer
    
  6. Apri gnome-alsamixer digitando alsamixer nel trattino.

  7. Seleziona la "Modalità silenziamento automatico" nella nuova finestra.

Riavvia e verifica se è stato riparato ora. (i passaggi 6 e 7 potrebbero non essere necessari) . Automuto verrà automaticamente abilitato al riavvio

Soluzione 2:

Ho appena trovato un'altra soluzione:

(Ha funzionato per me con il profilo Solo S / PDIF, Suono da entrambe le cuffie e altoparlante e non potendo cambiare profilo)

  1. Aggiungi questo ppa con il comando

     sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily
    
  2. Aggiorna l'elenco dei pacchetti. di

    sudo apt-get update
    
  3. Quindi installa il pacchetto "alsa-hda-dkms":

     sudo apt-get install alsa-hda-dkms
    

Riavvia e guarda il risultato!

    
risposta data Anwar 14.06.2012 - 22:07
30

Attenersi alla seguente procedura per disattivare automaticamente i diffusori quando si collegano le cuffie:

  1. Apri terminale ( Ctrl + Alt + T )
  2. Tipo: alsamixer e premi Invio / Invio
  3. Seleziona il dispositivo audio corretto premendo F6
  4. Spostati a destra con (tasto freccia destra) finché non evidenzi Auto-silenziamento
  5. Premi (Freccia su) e seleziona Abilitato (o Line Out )
  6. Premi Esc per uscire
risposta data user247077 11.02.2014 - 16:18
6

Ho riscontrato questo problema anche sul mio laptop HP. Ho trovato un post e ho preso uno dei consigli, che suggerisce di aggiungere due righe alla fine di il file /etc/modprobe.d/alsa-base.conf :

options snd-hda-intel model=laptop
options snd-hda-intel position_fix=1 enable=yes

salvalo e riavvia. Funziona per me!

    
risposta data hiqhan 07.01.2013 - 08:55
4

Avuto questo problema su XUbuntu 12.04, esaminato questa pagina, installato gnome-alsamixer package , eseguito gnome-alsamixer , spuntato l'opzione "Senso Jack delle cuffie" nella schermata dell'interfaccia grafica di gnome-alsamixer che si presentava, verificato che il problema è stato risolto. Grazie!

    
risposta data Bob 28.09.2012 - 20:27
2

Il comando sudo apt-get install gnome-alsa-mixer ha fatto il trucco per me sul mio Compaq nw8000 .

Potrei abilitare l'opzione Senso jack per cuffie e ora passa l'audio alle cuffie quando collego i miei telefoni.

    
risposta data crazygoda 10.12.2012 - 01:56
2

Ho avuto lo stesso problema su 13.04 con un Asus X201E, e ho provato la soluzione gnome-alsamixer ma non è andata a buon fine quando gnome-alsamixer si è bloccato con " non ho idea di cosa fare per l'elemento del mixer" Modalità Auto-Mute " ! ". Così ho aperto la riga di comando alsamixer e ho navigato nella modalità Auto-Mute usando le frecce (solo Auto-Mut è visibile nella finestra del terminale) e l'ho impostato da Disabilitato a Abilitato. Ora il collegamento delle cuffie silenzia gli altoparlanti interni.

    
risposta data asterx 27.08.2013 - 11:18
2

Ciò che ha funzionato per me era eseguire alsamixer e abilitare l'opzione auto-mute. L'ho fatto mentre le cuffie erano collegate e tutto ha funzionato perfettamente.

    
risposta data Vishal 04.10.2013 - 22:09
1

dopo l'aggiornamento dalla 15.04 - & gt; 15.10 e ora il 16.10 (dove il problema è iniziato)

l'unica risoluzione che ha funzionato per me era eseguire una reinstallazione completa

dpkg -l | grep 'alsa-'
apt-get install --reinstall  alsa-base alsa-utils
    
risposta data user3258557 19.10.2016 - 21:56
1

Questo ha funzionato perfettamente per me.

  1. Modifica /etc/modprobe.d/alsa-base.conf come super-utente con il tuo editor di testo preferito, e. g:.

    sudo gedit /etc/modprobe.d/alsa-base.conf
    
  2. Alla fine del file, incolla quanto segue:

    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=dell-m4-1 enable_msi=1
    
  3. Salva e riavvia.

Se questo non funziona, modifica nella seconda riga la parte relativa a model=dell-m4-1 a model=hp-m4 .

    
risposta data Ahmed Riad 07.07.2013 - 17:03
0

Prova a collegare correttamente le cuffie. Mi è successo una volta e poi, dopo aver corretto correttamente il piedino delle cuffie, ha funzionato correttamente.

    
risposta data Pranit Bauva 14.06.2012 - 18:41
0

Ho avuto lo stesso esatto problema con una nuova installazione di Xubuntu. Ho provato un sacco di cose, incluso digitare alsamixer nel terminale. L'opzione non era lì per me per accendere la cuffia Jack Sense. Ho installato gnome-alsamixer e ho trovato l'opzione Jack Sense per le cuffie, l'ho controllata e purtroppo nessun audio dagli altoparlanti del pc mentre le cuffie sono collegate. Questo ha funzionato per me.

    
risposta data Jason 28.06.2014 - 08:03
0

L'esecuzione di alsamixer nel terminale ha funzionato per me, impostala su Auto Mute e dovresti trovare che la tua macchina riprodurrà il suono attraverso l'uno o l'altro piuttosto che entrambi

    
risposta data Gordon Quinn 01.12.2014 - 14:09
0

in alsamixer, prova a usare il tasto freccia Su , quindi gira tutto al 100% e vedrai apparire la barra giusta. Dopo di che gira il tasto freccia in basso a% che ti piace. Ora dovrebbe essere giù insieme e il tuo diffusore destro funzionerà su entrambi i lati.

    
risposta data Lazy Lee 11.01.2015 - 00:08
0

Su un Asus X551MA stavo avendo questo problema non appena ho sostituito Windows con Ubuntu 14.04. Anche se ho disattivato gli altoparlanti in aslamixer , sarebbero tornati inaspettatamente.

Quando sono arrivato al terzo passaggio in questa procedura di risoluzione dei problemi , sembra che sia stato risolto tutto. È un comando lungo e complicato che installa vari pacchetti, quindi non sono sicuro di quale parte fosse realmente necessaria:

sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-'uname -r' libasound2; sudo apt-get -y --reinstall install linux- sound-base alsa-base alsa-utils lightdm ubuntu-desktop linux-image-'uname -r' libasound2; killall pulseaudio; rm -r ~/.pulse*; ubuntu-support-status; sudo usermod -aG 'cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse- access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print }' | tr '\n' ',' | sed 's:,$::g'' 'whoami'
    
risposta data Brian Z 12.01.2016 - 20:48
0

Basta semplicemente andare a alsamixer (alsamixer nel terminale) e usare i tasti freccia destra / sinistra per spostarsi sull'impostazione dei diffusori e fare clic su M. Ciò disabiliterà i diffusori ma non le cuffie.

    
risposta data Rhys 10.09.2016 - 02:37
0

Questo ha funzionato per me (Ubuntu 14.04 LTS in esecuzione su laptop Compaq NC6120):

  1. Ctrl + Alt + T (per aprire il terminale)
  2. Digita alsamixer
  3. Premi fino all'opzione "Senso Jack delle cuffie"
  4. Premi m per attivare (disattiva automaticamente gli altoparlanti quando la cuffia è collegata)
risposta data XqRG 09.10.2016 - 04:26

Leggi altre domande sui tag