phpStorm che perde l'input della tastiera

51

Ogni tanto phpStorm perderà input dalla mia tastiera. Posso ancora fare clic in giro, ma non registrerò alcuna chiave. Altre finestre vanno bene. Ci vuole un riavvio di phpStorm per riportarli indietro. Sembra che succeda di più quando controllo + Tab tra le schede aperte

Sto correndo: Ubuntu 13.10 phpStorm 7.1 JRE 1.7.0_51

    
posta neolaser 04.02.2014 - 22:44

5 risposte

48

Dovresti dare un'occhiata a questo bug qui: link

È esattamente il tuo problema e ha una soluzione alternativa:

sudo ibus restart

Spero che ti aiuti!

    
risposta data Mark Mandel 13.02.2014 - 00:30
5

Sembra che il problema / problema corretto per OP sia in realtà questo: IDEA-78860

Questa non è una versione specifica di Ubuntu, ma il problema di X Window / IBus e sta ancora accadendo in Ubuntu 14.04 con IBus & lt; 1.5.11

Opzione 1: Aggiorna IBus a 1.5.11 o successivo Controlla questa risposta su come aggiornare ibus su ubuntu

Opzione 2: La soluzione ufficiale è aggiungere la seguente riga al tuo ~ / .profile

export IBUS_ENABLE_SYNC_MODE=1

Ricorda che devi riavviare la sessione (logout) affinché questo abbia effetto.

Opzione 3: La soluzione più universale è ancora ibus restart , ma penso che valga la pena citare l'assegnatario del problema:

  

Il riavvio di IBus non è raccomandato (potrebbe rovinare l'IDE più tardi)

Sì, potrebbe succedere prima o poi. Inoltre, ripristina il layout della tastiera come predefinito (principalmente inglese). Quindi dovresti cambiarlo ogni volta che riavvii ibus.

Un'altra opzione è disabilitare ibus, ma questa non è una soluzione per le persone che non hanno un layout kb statunitense.

    
risposta data ruuter 09.02.2016 - 10:57
0
ibus restart && sleep 1 && ibus engine xkb:se::swe

ha funzionato per me

    
risposta data ali moradi 18.11.2015 - 21:31
0

prevengo questo problema, cambiando il "Metodo di input tastiera" (Impostazioni di sistema & gt; supporto lingua) da "IBus" a "nessuno".

link

    
risposta data Rudger 28.11.2015 - 20:12
0

puoi provare a rimuovere la cartella .idea nella radice del tuo progetto, quindi prova File → Invalida cache e riavvia .

    
risposta data Shobi P P 16.10.2017 - 19:35

Leggi altre domande sui tag