utilizzando ppa-purge (con / senza -i) risulta nel suggerire la rimozione di oltre 100 pacchetti Sono abbastanza sicuro che SONO disponibile nel repository standard di Ubuntu

9

Ho stupidamente aggiunto il pp kxstudio un po 'di tempo fa. Tutto andò bene per alcuni mesi, poi i problemi iniziarono a farsi vedere, e da allora non sono stati altro che un dolore. Ho inviato diverse segnalazioni di bug e ho perso molto tempo solo per scoprire che sono per lo più dovute a pacchetti "aggiornati" di kxstudio. Ora desidero rimuovere il ppa e ogni pacchetto che abbia mai installato, rimuovendo il pacchetto se non lo era prima, o ripristinando un'altra versione disponibile se si trova nel repository di ubuntu.

Ho usato ppa-purge, sia con che senza l'opzione -i, e ottengo qualcosa del genere:

sudo ppa-purge -i kxstudio-team
Updating packages lists
PPA to be removed: kxstudio-team ppa
comm: file 2 is not in sorted order
Package revert list generated:
 alsa-tools-gui/oneiric ardour/oneiric audacious/oneiric ffmpeg/oneiric 
gstreamer0.10-plugins-bad-multiverse/oneiric 
gstreamer0.10-plugins-bad-multiverse-dbg/oneiric ia32-libs/oneiric 
jackd/oneiric jackd1/oneiric jackd2/oneiric jackd2-firewire/oneiric 
libaudclient2/oneiric libaudcore1/oneiric libavcodec52/oneiric 
libavcodec53/oneiric libavcodec-dev/oneiric libavcodec-extra-53/oneiric 
libavdevice53/oneiric libavfilter2/oneiric libavformat52/oneiric 
libavformat53/oneiric libavformat-dev/oneiric libavformat-extra-53/oneiric 
libavutil50/oneiric libavutil51/oneiric libavutil-dev/oneiric 
libavutil-extra-51/oneiric libclucene0ldbl/oneiric libffado2/oneiric 
libflowcanvas5/oneiric libjack0/oneiric libjack-jackd2-0/oneiric 
libmlt++3/oneiric libmlt4/oneiric libmowgli2/oneiric libpostproc51/oneiric 
libpostproc52/oneiric libquicktime2/oneiric libswscale0/oneiric 
libswscale2/oneiric libswscale-dev/oneiric lmms/oneiric lmms-common/oneiric 
lmms-vst/oneiric mplayer/oneiric muse/oneiric wine1.2/oneiric wine1.3/oneiric 
zynaddsubfx/oneiric

Disabling kxstudio-team PPA from 
/etc/apt/sources.list.d/kxstudio-team-ppa-oneiric.list
Updating packages lists
Unable to find an archive "oneiric" for the package "libavcodec52"
Unable to find an archive "oneiric" for the package "libavformat52"
Unable to find an archive "oneiric" for the package "libavutil50"
Unable to find an archive "oneiric" for the package "libpostproc51"
Unable to find an archive "oneiric" for the package "libswscale0"
Unable to find an archive "oneiric" for the package "lmms-vst"
Unable to find an archive "oneiric" for the package "libavcodec52"
Unable to find an archive "oneiric" for the package "libavformat52"
Unable to find an archive "oneiric" for the package "libavutil50"
Unable to find an archive "oneiric" for the package "libpostproc51"
Unable to find an archive "oneiric" for the package "libswscale0"
Unable to find an archive "oneiric" for the package "lmms-vst"
The following packages will be DOWNGRADED:
  ffmpeg gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-bad-multiverse-dbg jackd2{b} jackd2-firewire{b} libavcodec-dev libavcodec-extra-53{b} libavdevice53 libavfilter2 libavformat-dev libavformat-extra-53{b} libavutil-dev 
  libavutil-extra-51{b} libjack-jackd2-0{b} libpostproc52 libswscale-dev libswscale2 lmms lmms-common wine1.3{b} 
The following NEW packages will be installed:
  ardour audacious audacious-plugins{a} cmt{a} gtk2-engines-pixbuf{a} jackd1{b} jackd1-firewire{ab} libaubio2{a} libaudclient2 libaudcore1 libavcodec53 libavformat53 libavutil51 libbinio1ldbl{a} libbs2b0{a} libcue1{a} libguess1{a} 
  libjack0{b} liblrdf0{a} libmlt++3 libmlt-data{a} libmlt4 libmowgli2 libqt3-mt{a} libresid-builder0c2a{a} libsidplay2{a} libsox-fmt-alsa{a} libsox-fmt-base{a} libsox1b{a} libvamp-sdk2{a} muse python-pyasn1{a} python-twisted{a} 
  python-twisted-conch{a} python-twisted-lore{a} python-twisted-mail{a} python-twisted-news{a} python-twisted-runner{a} python-twisted-words{a} wine1.2 
The following packages will be REMOVED:
  lmms-vst{u} 
0 packages upgraded, 40 newly installed, 20 downgraded, 1 to remove and 5 not upgraded.
Need to get 100 MB/101 MB of archives. After unpacking 292 MB will be used.
The following packages have unmet dependencies:
  jackd2-firewire: Conflicts: jackd-firewire which is a virtual package.
  libavformat-extra-53: Conflicts: libavformat53 but 4:0.7.2-1ubuntu1 is to be installed.
  jackd1-firewire: Conflicts: jackd-firewire which is a virtual package.
  wine1.3: Conflicts: wine1.2 but 1.2.3-0ubuntu1 is to be installed.
  libjack0: Conflicts: libjack-0.116 which is a virtual package.
  libavutil-extra-51: Conflicts: libavutil51 but 4:0.7.2-1ubuntu1 is to be installed.
  libjack-jackd2-0: Conflicts: libjack-0.116 which is a virtual package.
                    Conflicts: libjack0 but 1:0.121.0+svn4469-2ubuntu2 is to be installed.
  jackd1: Conflicts: jack-daemon which is a virtual package.
  jackd2: Conflicts: jack-daemon which is a virtual package.
  libavcodec-extra-53: Conflicts: libavcodec53 but 4:0.7.2-1ubuntu1 is to be installed.
open: 195; closed: 1177; defer: 78; conflict: 276                                                                                                                                                                                                 oThe following actions will resolve these dependencies:

       Remove the following packages:                                   
1)       acroread                                                       
2)       ia32-libs-multiarch                                            
3)       libacl1                                                        
4)       libatk1.0-0                                                    
5)       libattr1                                                       
6)       libaudio2                                                      
7)       libavahi-client3                                               
8)       libavahi-common3                                               
9)       libc6                                                          
10)      libcairo2                                                      
11)      libcomerr2                                                     
12)      libcups2                                                       
13)      libcupsimage2                                                  
14)      libcurl3                                                       
15)      libdatrie1                                                     
16)      libdb5.1                                                       
17)      libdbus-1-3                                                    
18)      libdrm-intel1                                                  
19)      libdrm-nouveau1a                                               
20)      libdrm-radeon1                                                 
21)      libdrm2                                                        
22)      libexpat1                                                      
23)      libffi6                                                        
24)      libfontconfig1                                                 
25)      libfreetype6                                                   
26)      libgcc1                                                        
27)      libgcrypt11                                                    
28)      libgdbm3                                                       
29)      libgdk-pixbuf2.0-0                                             
30)      libgl1-mesa-dri                                                
31)      libgl1-mesa-glx                                                
32)      libglapi-mesa                                                  
33)      libglib2.0-0                                                   
34)      libgnutls26                                                    
35)      libgpg-error0                                                  
36)      libgssapi-krb5-2                                               
37)      libgtk2.0-0                                                    
38)      libice6                                                        
39)      libidn11                                                       
40)      libjasper1                                                     
41)      libjpeg62                                                      
42)      libk5crypto3                                                   
43)      libkeyutils1                                                   
44)      libkrb5-3                                                      
45)      libkrb5support0                                                
46)      liblcms1                                                       
47)      libldap-2.4-2                                                  
48)      libllvm2.9                                                     
49)      libmng1                                                        
50)      libnspr4                                                       
51)      libnss3                                                        
52)      libpango1.0-0                                                  
53)      libpciaccess0                                                  
54)      libpcre3                                                       
55)      libpixman-1-0                                                  
56)      libpng12-0                                                     
57)      libqt4-dbus                                                    
58)      libqt4-declarative                                             
59)      libqt4-designer                                                
60)      libqt4-network                                                 
61)      libqt4-opengl                                                  
62)      libqt4-qt3support                                              
63)      libqt4-script                                                  
64)      libqt4-scripttools                                             
65)      libqt4-sql                                                     
66)      libqt4-svg                                                     
67)      libqt4-test                                                    
68)      libqt4-xml                                                     
69)      libqt4-xmlpatterns                                             
70)      libqtcore4                                                     
71)      libqtgui4                                                      
72)      librtmp0                                                       
73)      libsasl2-2                                                     
74)      libsasl2-modules                                               
75)      libselinux1                                                    
76)      libsm6                                                         
77)      libsqlite3-0                                                   
78)      libssl1.0.0                                                    
79)      libstdc++6                                                     
80)      libtasn1-3                                                     
81)      libthai0                                                       
82)      libtiff4                                                       
83)      libuuid1                                                       
84)      libx11-6                                                       
85)      libxau6                                                        
86)      libxcb-render0                                                 
87)      libxcb-shm0                                                    
88)      libxcb1                                                        
89)      libxcomposite1                                                 
90)      libxcursor1                                                    
91)      libxdamage1                                                    
92)      libxdmcp6                                                      
93)      libxext6                                                       
94)      libxfixes3                                                     
95)      libxft2                                                        
96)      libxi6                                                         
97)      libxinerama1                                                   
98)      libxrandr2                                                     
99)      libxrender1                                                    
100)     libxss1                                                        
101)     libxt6                                                         
102)     libxxf86vm1                                                    
103)     nspluginviewer                                                 
104)     nspluginwrapper                                                
105)     wine1.3                                                        
106)     zlib1g                                                         

       Keep the following packages at their current version:            
107)     jackd1 [Not Installed]                                         
108)     jackd1-firewire [Not Installed]                                
109)     libavcodec53 [Not Installed]                                   
110)     libavformat53 [Not Installed]                                  
111)     libavutil51 [Not Installed]                                    
112)     libjack0 [Not Installed]                                       

       Leave the following dependencies unresolved:                     
113)     ia32-libs recommends ia32-libs-multiarch                       
114)     wine1.3-gecko recommends wine1.3                               
115)     libgl1-mesa-glx recommends libgl1-mesa-dri (>= 7.2)            
116)     libqt4-dbus recommends qdbus (= 4:4.8.1-0ubuntu2~oneiric1~ppa2)
117)     libqtgui4 recommends libcups2                                  


Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

Sono abbastanza sicuro che alcuni di questi pacchetti sono molto importanti, semplicemente non capisco perché debbano essere rimossi. Altri suggerimenti per la risoluzione delle dipendenze rimuovono ancora più pacchetti!

Qualcuno può far luce su questo?

    
posta Rob Davies 02.08.2012 - 18:43

2 risposte

3

Per prima cosa cancella manualmente il ppa usando il seguente comando:

sudo rm /etc/apt/sources.list.d/kxstudio*

Ora, usa "apt-pinning" per dare priorità alla tua attuale distribuzione, indipendentemente dal numero di versione del pacchetto. Per prima cosa, crea un file:

sudo nano /etc/apt/preferences

e copia / incolla quanto segue nel file sostituendo "fidato" con la tua attuale versione di Ubuntu:

Package: *
Pin: release a=trusty*
Pin-Priority: 1001

Premere CTRL + O e quindi premere ENTER per salvare il file e premere CTRL + X exit.

Ora elimina i pacchetti specifici di kxstudio:

sudo apt-get purge kxstudio-artwork kxstudio-default-settings kxstudio-desktop kxstudio-desktop-kde4 kxstudio-welcome

Quindi, per applicare il downgrade:

sudo apt-get update
sudo apt-get dist-upgrade

modificato dalla sorgente: link

    
risposta data mchid 15.03.2015 - 06:53
0

Potrebbe essere disponibile nei repository di Ubuntu, ma potrebbe esserci una versione più recente o installata dal PPA installato. Potresti voler controllare i pacchetti interessati e magari reinstallarli dai sorgenti di Ubuntu ..

    
risposta data whiskers75 07.04.2014 - 14:27

Leggi altre domande sui tag