Ubuntu 13.04. mancato avvio dopo l'installazione dei driver nvidia (laptop Vostro)

9

Tutto ha funzionato bene in Ubuntu 13.04 ma poi ho installato nvidia-drivers-103 Ora non viene caricato affatto nella schermata di login. Vedo uno schermo viola vuoto durante l'avvio e poi appare solo una schermata nera vuota e non succede nulla dopo.

Ho avviato la modalità di ripristino e rimosso i driver nvidia, il che non è stato di aiuto. Ho notato che avevo rotto l'ambiente Unity in modalità di ripristino (nessun launcher o barre degli strumenti, solo sfondo) quindi ho seguito:

Unity non viene caricato, nessun Launcher, nessun Dash appare

dove ho reimpostato il mio unity / compiz ma questo non mi ha aiutato ad avviare così finalmente ho installato gdm e ora ho anche compiz e unity completamente rimossi e driver nvidia. Non riesco ancora ad avviare , solo la modalità di ripristino funziona correttamente.

Che cosa dovrei provare per far lavorare felicemente Unity e Compiz? Quali registri dovrei controllare e cosa potrebbe essere sbagliato?

Mi sarei aspettato che unity / compiz fosse un problema, ma dato che non riesco ancora ad avviare il mio sistema operativo, credo che la ragione sia molto più profonda di quanto mi aspettassi. Come ripristinare la versione originale dei driver di grafica? Ovviamente la semplice rimozione dei driver NVidia non ha ripristinato la configurazione originale.

HW: laptop Vostro 3750, Nvidia GT 525M, chipset Intel Mobile HM67

    
posta Martin V. 25.04.2013 - 22:59

5 risposte

5

Ho un Latitude E6500 e ho avuto gli stessi problemi l'unica soluzione che ho trovato è stata la seguente:

  1. Passa alla modalità console: Alt + Ctrl + F1
  2. Elimina x server: sudo service lightdm stop
  3. Rimuovi i driver nvidia: sudo apt-get remove --purge nvidia*
  4. Genera il nuovo file xorg.conf: sudo X -configure - questo verrà creato xorg.conf. Un nuovo file nella tua directory attuale
  5. Rinomina e sposta: sudo mv xorg.conf.new /etc/X11/xorg.conf
  6. Ritorno alla GUI: sudo start lightdm

Naturalmente preferirei una soluzione migliore

    
risposta data Alain 26.04.2013 - 15:27
1

Ho avuto lo stesso problema su Samsung RC530. La grafica era funzionale fino all'installazione dei driver Nvidia che incasinavano i driver (potevo accedere a bassa risoluzione, il monitor non veniva riconosciuto). Devo dire che la risposta fornita da Alain ha funzionato. Dopo aver rimosso i driver Nvidia in modalità console e aggiunto il nuovo file di configurazione, tutto tornava alla vecchia configurazione grafica.

    
risposta data Miroslav Radojević 14.05.2013 - 09:59
0

La soluzione è installare vanilla Ubuntu 13.04 e non toccare alcun nvidia / compiz / strumenti di tweak altrimenti avrai brutto tempo. La configurazione di default funziona bene. Prima di provare alcune importanti modifiche, esegui clonezilla e risparmia tempo prezioso e fai il backup completo.

Se vuoi avere driver nvidia (ad esempio a causa di giochi 3D) ti auguro buona fortuna.

    
risposta data Martin V. 30.04.2013 - 00:33
0

Sono su un Dell Latitude E6410 e ho anche la schermata viola vuota all'avvio.

Se premo il pulsante di accensione, mi mostrerà un po 'di spegnimento, ma poi si bloccherà. Ho tenuto premuto il pulsante di accensione per spegnere il portatile. Se avvio più volte, alla fine riuscirò a raggiungere il login e di solito questo significa che le cose continueranno a funzionare (fino al prossimo avvio).

C'è un po 'di ciò che appare come Oopses del kernel in /var/log/kern.log che sembra coincidere con i problemi di avvio. Sfogliandolo, vedo abbastanza "nvidia" e "nv" per pensare che il problema sia dovuto ai driver Nvidia o ai moduli del kernel.

    
risposta data alnedey 08.05.2013 - 16:13
0

I driver incorporati su Ubuntu non richiedono /etc/X11/xorg.conf , ma i driver Nvidia lo richiedono, quindi dovrai crearlo.

Fortunatamente, Nvidia fornisce nvidia-xconfig per fare proprio questo.

Crea /etc/X11/xorg.conf e riavvia su un sistema funzionante con:

sudo nvidia-xconfig
sudo reboot

I menu e altri aspetti di Unity, incluso il supporto a risoluzione piena per i tuoi schermi, dovrebbero essere ripristinati.

    
risposta data Alain O'Dea 17.06.2013 - 03:07

Leggi altre domande sui tag