I collegamenti ipertestuali non sono stati aperti, nessuna idea su come risolvere il problema?

9

Come è stato spiegato in un altro thread qui nei forum, ho aperto il file /usr/share/applications/mimeinfo.cache per verificare i riferimenti corretti. E notato che questo non sembra essere il problema, ci sono anche 3 browser opzionali da usare.

x-scheme-handler/http=google-chrome.desktop;chromium-browser.desktop;firefox.desktop;
x-scheme-handler/https=google-chrome.desktop;chromium-browser.desktop;firefox.desktop;

Ho già controllato che i programmi siano denominati correttamente, usando il comando "which" nel terminale, come questo:

$ which google-chrome
$ /usr/bin/google-chrome

Quindi google-chrome dovrebbe essere la prima opzione, eppure l'ordine di aprire un URL non sembra arrivare al programma, nemmeno alla seconda o terza opzione, comunque.

Inoltre, il comando "Chiedi aiuto online ..." nel menu "Guida" non funziona. Quindi non è un problema con il file di documento specifico.

Sto usando Ubuntu 12.04 LTS. Se è necessario chiedere ulteriori dettagli rilevanti, si prega di fare. Sarebbe bello avere diverse opinioni su come risolvere questo, grazie: -)

AGGIORNAMENTO: ho eseguito evince dal terminale come richiesto.
Questo è quello che sto ottenendo quando provo ad aprire un link:

/opt/google/chrome/google-chrome: line 42: /opt/google/chrome/chrome: Permission denied
/opt/google/chrome/google-chrome: line 42: /opt/google/chrome/chrome: Success

Devo provare la correzione suggerita anche se il mio log degli errori è diverso?

AGGIORNAMENTO: Ho provato la soluzione di @maggotbrain e BINGO, ora posso studiare i riferimenti pdf più velocemente grazie a voi bro!

    
posta JorgeArtware 08.07.2013 - 23:46

5 risposte

1

Potresti riscontrare un bug con la gestione degli URL esterni da parte di apparmor.

Il problema con cui stavo aprendo URL all'interno di evince ha comportato il seguente errore generato (sulla riga di comando) ogni volta che si fa clic su un URL all'interno di un documento pdf:

(evince:32091): EvinceView-CRITICAL **: ev_document_model_set_document: assertion
'EV_IS_DOCUMENT (document)' failed
/usr/lib/chromium-browser/chromium-browser-sandbox: error while loading shared
libraries: libpthread.so.0: failed to map segment from shared object: Permission denied

Come suggerito in questo commento , sono stato in grado di risolvere questo problema con Chromium nel modo seguente:

  

Aggiungi queste righe a /etc/apparmor.d/abstractions/ubuntu-helpers dopo la riga "/ usr / lib * / {, * /} Pixr,":

# From https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/964510/comments/12
# While the chromium and chrome sandboxes are setuid root, they only link
# in limited libraries so glibc's secure execution should be enough to not
# require the santized_helper (ie, LD_PRELOAD will only use standard system
# paths (man ld.so)).
/usr/lib/chromium-browser/chromium-browser-sandbox PUxr,
/opt/google/chrome/chrome-sandbox PUxr,
/opt/google/chrome/google-chrome Pixr,
/opt/google/chrome/chrome Pixr,
/opt/google/chrome/lib*.so{,.*} m,

Infine, esegui sudo apparmor_parser -T -W -r /etc/apparmor.d/usr.bin.evince

    
risposta data Kevin Bowen 09.07.2013 - 07:43
3

Nessuna delle soluzioni di cui sopra ha funzionato per me, tuttavia questo funziona:

Guarda cosa si trova attualmente nella sua lista di ignori

ls -la /etc/apparmor.d/disable

Ora aggiungi Document Viewer (evince) a quella lista

sudo ln -s /etc/apparmor.d/usr.bin.evince /etc/apparmor.d/disable/usr.bin.evince 

attiva la modifica

sudo service apparmor restart
    
risposta data Scott Stensland 04.11.2015 - 01:07
1

Questo bug è stato corretto qualche tempo fa. Le righe nel file /etc/apparmor.d/abstractions/ubuntu-helpers sono state incluse.

Xpdf non ha avuto problemi, tuttavia.

Ma supponendo che gnome-gmail e gnome-gmail-notifier siano installati, e siano stati specificati nelle impostazioni di sistema, per avere il reindirizzamento dei collegamenti ipertestuali, è necessario disabilitare prima evince e riavviare apparmor in seguito. (Questo è quello che ha funzionato per me comunque).

sudo ln -s /etc/apparmor.d/usr.bin.evince /etc/apparmor.d/disable/usr.bin.evince
sudo /etc/init.d/apparmor restart
    
risposta data doed 17.06.2015 - 04:30
1

Ho Chromium (non Chrome) su Ubuntu 14.04 e aggiungendo

/usr/lib/chromium-browser/chrome-sandbox PUxr dopo la stringa

/usr/lib/chromium-browser/chromium-browser-sandbox PUxr

nel file /etc/apparmor.d/abstractions/ubuntu-helpers , quindi sudo service apparmor reload ha risolto questo problema per me.

Trovato qui .

    
risposta data ademin 19.04.2015 - 03:25
0

Ho avuto lo stesso problema con il MATE. Quando ho cliccato su collegamenti ipertestuali in un documento PDF, ho scoperto che Firefox era aperto, anche se avevo già provato sudo update-alternatives --config x-www-browser .

La discussione completa è su github.com/mate-desktop/mate-control-center/ problemi / 91 . La soluzione era:

$ mate-default-applications-properties

Questo avvierà una GUI in cui è possibile impostare il browser predefinito.

    
risposta data Martin Thoma 07.10.2014 - 12:27

Leggi altre domande sui tag