Impossibile trovare il pacchetto lib32bz2-1.0

46

Sto cercando di installare Simplicity studio su Ubuntu 15.04 (64-bit) e ottengo questo errore

E: Unable to locate package lib32bz2-1.0
E: Couldn't find any package by regex 'lib32bz2-1.0'

Ho provato ad installare il pacchetto lib32bz2-1.0, di nuovo ricevo lo stesso errore. Come installare il pacchetto lib32bz2-1.0 su Ubuntu 15.04 (64-bit)

    
posta Rao 16.06.2015 - 13:35

5 risposte

36

Prova ad installarlo manualmente digitando:

sudo apt-get update
sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6

Aggiornamento:

se rimuovi lib32bz2-1.0 , verrà installato correttamente.

sudo apt-get install lib32z1 lib32ncurses5 lib32stdc++6

In caso contrario:

sudo dpkg --add-architecture i386

sudo apt-get update

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 libstdc++6:i386 libfontconfig1:i386 libxext6:i386 libxrender1:i386 libgstreamer-plugins-base0.10-0:i386
    
risposta data Bilal 16.06.2015 - 13:53
43

Il pacchetto (32 bit) che stai cercando è libbz2-1.0:i386 , la sua versione a 64 bit è libbz2-1.0:amd64 .

In primo luogo abilitare il supporto multi-arch (se non già fatto):

sudo dpkg --add-architecture i386

Ora esegui:

sudo apt-get update

Ora puoi installare il pacchetto da:

sudo apt-get install libbz2-1.0:i386
    
risposta data heemayl 16.06.2015 - 14:17
34

Stai pensando di installare Android Studio su Ubuntu?

Se dici: Sì !!. Questa risposta è per te: -).

Forse stai pensando di installare Android Studio con questo tutorial? . Ha dipendenze deprecate su Ubuntu 16.04.

Questo comando ha problemi:

  

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc ++ 6

Dopo alcune ricerche su Google ho trovato una possibile soluzione in questo post: Bad dependency on install comando .

Questo comando specifica la versione a 32 bit delle librerie extra necessarie per l'installazione di Android Studio. Funziona per me su Ubuntu 16.04:

sudo apt-get install libz1 libncurses5 libbz2-1.0:i386 libstdc++6 libbz2-1.0

Spero che aiuti: -).

    
risposta data mrroot5 31.05.2016 - 15:22
7

Questo funziona per me sulla mia Ubuntu 15.04 (64-bit)

sudo apt-get install lib32z1 lib32ncurses5 libbz2-1.0:i386 lib32stdc++6
    
risposta data Clock ZHONG 15.04.2016 - 20:43
2
sudo apt-get install libz1 libncurses5 libbz2-1.0 libstdc++6

senza 32

    
risposta data adri 10.09.2016 - 23:15

Leggi altre domande sui tag