Non è possibile utilizzare la stampante di rete tramite samba, come eseguire il debug del problema?

9

Ho una stampante di rete disponibile tramite samba e mi piacerebbe usarla dalla mia Ubuntu 14.04. Sfortunatamente semplicemente aggiungerlo tramite Printers non è abbastanza. Se provo a usarlo, dice: Connection failed: NT_STATUS_UNSUCCESSFUL e poi Unable to connect to CIFS host, will retry in 60 seconds...

Come posso eseguire il debug di queste cose e imparare il motivo per cui non funziona?

/var/log/cups/error_log

E [23/Jul/2014:13:58:41 +0200] [Job 5] Connection failed: NT_STATUS_UNSUCCESSFUL
E [23/Jul/2014:13:58:42 +0200] [Job 5] Connection failed: NT_STATUS_UNSUCCESSFUL
E [23/Jul/2014:13:58:43 +0200] [Job 5] Connection failed: NT_STATUS_UNSUCCESSFUL
E [23/Jul/2014:13:58:43 +0200] [Job 5] Unable to connect to CIFS host, will retry in 60 seconds...
E [23/Jul/2014:13:59:44 +0200] [Job 5] Connection failed: NT_STATUS_UNSUCCESSFUL
E [23/Jul/2014:13:59:45 +0200] [Job 5] Connection failed: NT_STATUS_UNSUCCESSFUL
E [23/Jul/2014:13:59:46 +0200] [Job 5] Connection failed: NT_STATUS_UNSUCCESSFUL
E [23/Jul/2014:13:59:46 +0200] [Job 5] Unable to connect to CIFS host, will retry in 60 seconds...
E [23/Jul/2014:14:00:47 +0200] [Job 5] Connection failed: NT_STATUS_UNSUCCESSFUL
E [23/Jul/2014:14:00:48 +0200] [Job 5] Connection failed: NT_STATUS_UNSUCCESSFUL
E [23/Jul/2014:14:00:49 +0200] [Job 5] Connection failed: NT_STATUS_UNSUCCESSFUL
E [23/Jul/2014:14:00:49 +0200] [Job 5] Unable to connect to CIFS host, will retry in 60 seconds...
    
posta Kalmar 23.07.2014 - 17:12

2 risposte

8

Forse sarà utile per qualcuno.

Ho riscontrato lo stesso problema su Ubuntu 14.04. I passaggi qui sotto lo hanno risolto per me:

  • rimuovi stampante aggiunta tramite System Settings->Printers
  • apri localhost:631 nel browser
  • vai alla scheda Amministrazione, fai clic sul pulsante Aggiungi stampante e segui le istruzioni

Non so perché, ma solo dopo aver aggiunto la stampante in questo modo funziona per me e per i miei colleghi.

    
risposta data rkm 24.10.2014 - 15:13
1

Ho risolto questo problema modificando l'URI del dispositivo della stampante per includere nome utente e password, nel formato:

smb://username:[email protected]/printer

(per cambiarlo, vai su Impostazioni di sistema & gt; Stampanti, quindi fai clic con il tasto destro sull'icona della stampante)

    
risposta data geoffrey 08.08.2016 - 12:17

Leggi altre domande sui tag