Come posso risolvere un errore "L'installazione precedente non è stata completata." in Software Center?

9

Ubuntu Software Center si blocca ogni volta che provo a installare qualcosa. Mostra il seguente errore:

  

L'installazione precedente non è stata completata.

     

L'installazione potrebbe essere fallita a causa di un errore nel pacchetto software corrispondente o è stata annullata in modo ostile. Devi ripararlo prima di poter installare o rimuovere qualsiasi altro software.

Come posso risolvere questo problema?

    
posta vaishu 02.01.2013 - 13:55

4 risposte

1

Installa semplicemente qualsiasi cosa attraverso il terminale, ad esempio ccsm utilizzando sudo apt-get install ccsm . Se non riesce a installare, controlla il suo output. Vi dirà una soluzione raccomandata, o un comando da eseguire per risolverlo. Nella maggior parte dei casi, il comando è sudo dpkg --configure -a ma varia in base al problema.

    
risposta data user27731 20.10.2013 - 12:27
0

Se provi

sudo apt-get update && apt-get upgrade

dovresti essere in grado di vedere quale installazione o configurazione del pacchetto sta causando il blocco. Eliminare l'applicazione con

sudo apt-get purge <package-name>

dovrebbe risolvere il tuo problema.

    
risposta data nlmiller206 08.09.2013 - 15:44
0

Quando l'ho ricevuto in passato, di solito ciò che segue mi riporta in pista.

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
    
risposta data Greg 01.12.2013 - 23:32
-1

Hai provato a rimuovere alcuni dei tuoi ppa dal gestore aggiornamenti, a volte se hai installato ppa attraverso il tuo terminale questo li aggiunge anche al tuo gestore aggiornamenti e influenza anche il modo in cui il centro software reagisce quando vengono selezionati troppi ppa, quindi Ubuntu Software Center non è rotto ma non può installare programmi a causa di questo. Fidati di me ho reinstallato il mio sistema operativo tante volte a causa di questo stupido fastidioso problema. Alla fine non ho nemmeno potuto usare il mio terminale.

Prova questo gestore di aggiornamenti di tipo a trattino aperto, aprilo, fai clic su impostazioni, quindi fai clic su altro software, quindi deseleziona tutti i ppa che hai installato e mantieni quelli principali come "Indipendente (codice sorgente)

Deselezionerei tutti quelli sotto il codice sorgente. Non ho mai potuto capire questo fastidioso problema fino a quando non l'ho risolto con questa soluzione. Spero davvero che questo funzioni per te lo ha fatto per me. Cheers!

    
risposta data user130156 12.02.2013 - 05:33

Leggi altre domande sui tag