Esiste un pacchetto per una versione eseguibile di v8?

9

Sto cercando di ottenere plug-in di lanugine Vim JS che funziona con Ubuntu 12.04. Il plug-in richiede il comando d8 , che è una versione eseguibile del motore JavaScript v8 di Google .

Vedo un pacchetto libv8 , ma non sembra che installi d8 o almeno, non metterlo sul mio percorso. Il pacchetto è descritto come

  

libv8-3.7.12.22 - motore JavaScript v8 - libreria di runtime

C'è qualche pacchetto che installerà una versione eseguibile del motore v8, o devo semplicemente costruirlo manualmente?

    
posta James McMahon 23.05.2012 - 18:00

3 risposte

8

Prenderò la mancanza di risposte come no.

Non è difficile creare e installare v8 dal repository SVN di Google.

Tutto ciò che devi fare è provarlo e farlo.

svn checkout http://v8.googlecode.com/svn/trunk/ ./v8
cd v8
make builddeps
make native

Quindi all'interno della directory out/native ci sarà d8 binary, ho appena collegato questo link al mio /usr/local/bin .

    
risposta data James McMahon 24.05.2012 - 17:01
1

Questo potrebbe aiutare (funziona su Debian):

12:38 ~ $ apt-cache search libv8;
libv8-3.8.9.20 - v8 JavaScript engine - runtime library
libv8-dbg - v8 JavaScript engine - debugging symbols
libv8-dev - v8 JavaScript engine - development files
libv8-i18n-dev - Native internationalization extension for libv8 - development files
libv8-i18n0.0.0 - Native internationalization extension for libv8 - runtime library
libv8-i18n0.0.0-dbg - Native internationalization extension for libv8 - debugging symbols

e scegline uno come

12:39 ~ $ apt-get install libv8-3.8.9.20
    
risposta data relipse 12.09.2013 - 19:42
0

Controlla node-webkit , funziona con i principali sistemi operativi (Linux, Windows, Mac) - è un'app motore fatto da chromium e node.js.

    
risposta data CoryG 25.03.2013 - 00:23

Leggi altre domande sui tag