Unity non viene caricato, nessun Launcher, nessun Dash appare

534

Quando accedo, non succede nulla.

Mi viene presentato lo sfondo del mio desktop.

No Dash, no Launcher, niente.

    
posta jrg 14.12.2010 - 18:24

34 risposte

464
  

Questa risposta applica le versioni di Ubuntu su Compiz.

     

Questa risposta presuppone che Unity venga eseguito attraverso Compiz. Se non hai compiz installato questa risposta non si applica a te.

Hai solo bisogno di riattivare il plugin Unity. Il problema è che questo è un dolore in fondo perché ora non hai un metodo grafico per farlo. Quindi:

  1. Prova ad aprire un terminale con Ctrl + Alt + T .
    Questo potrebbe non funzionare ma puoi provare a fare clic destro sul desktop e selezionare "Apri terminale qui". In caso contrario, potrebbe essere necessario passare a un terminale "rigido" premendo Ctrl + Alt + F1 e accedi.

  2. Installa compizconfig-settings-manager eseguendo

    sudo apt-get install compizconfig-settings-manager
    
  3. Quindi eseguilo con questo:

    DISPLAY=:0 ccsm &
    

    La prima parte dice al terminale su quale display vuoi che si carichi (altrimenti non ne ha la minima idea).

  4. Se sei passato a un TTY al punto 1, torna al server grafico premendo Ctrl + Alt + F7 (o Ctrl + Alt + F8 a volte).
    Dovrebbe esserci un gestore delle impostazioni di CompizConfig che ti aspetta.

  5. Trova il plug-in Unity. Abilitalo. Ti verrà chiesto "Ubuntu Unity Plugin richiede il plugin OpenGL. Abilita Ubuntu Unity Plugin / Enable OpenGL"

  6. Tutto dovrebbe germogliare nella vita ma, in caso contrario, potrebbe essere necessario riavviare. Puoi farlo tornando al terminale ed eseguendo sudo reboot .

risposta data Oli 08.11.2011 - 00:23
165

Una soluzione buona per me (ha risolto lo stesso problema):

in un terminale:

export DISPLAY=:0   
sudo dconf reset -f /org/compiz/

e poi

setsid unity
    
risposta data user155373 04.05.2013 - 02:50
72

In 13.04 e 14.04:

unity --replace è deprecato. Invece, usa quanto segue:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Riavvia se non funziona immediatamente.

    
risposta data Brandon Bertelsen 27.04.2013 - 04:39
60

Per 12.10 e seguenti:

Premi Ctrl + Alt + T per un terminale ed esegui ccsm , quindi riabilita il tuo plugin 'Unity'.

Potrebbe anche essere necessario eseguire un unity --replace .

    
risposta data xyzzyman 02.10.2011 - 04:33
51

È una buona idea controllare che il driver della tua scheda grafica sia configurato per utilizzare l'accelerazione hardware e che sia configurato per utilizzare OpenGL. Prova a cercare Forum Ask Ubuntu e Ubuntu per informazioni specifiche per le tue GPU e il gusto di Ubuntu. Per gli utenti di grafica ibrida, consultare l'ultima sezione "Grafica ibrida" di seguito.

Potresti voler eseguire il compizconfig-settings-manager pacchetto e assicurati che il plugin Unity sia spuntato (vedi Quali sono alcuni dei problemi con CCSM e perché dovrei evitarlo? ).

Per 12.04 E più recenti

  1. Passa a tty1 premendo Ctrl + Alt + F1 ed esegui l'accesso.

  2. Installa compizconfig-settings-manager eseguendo

    sudo apt-get install compizconfig-settings-manager
    
  3. Quindi eseguilo in questo modo:

    export DISPLAY=:0
    ccsm
    

    La prima parte dice al terminale su quale display vuoi che si carichi (altrimenti non ne ha la minima idea).

  4. Premi Ctrl + Alt + F7 (o Ctrl + Alt + F8 qualche volta) per tornare al display grafico dove dovrebbe esserci una schermata di Gestione impostazioni di CompizConfig seduta lì.

  5. Trova il plug-in Unity. Abilitalo.

  6. Tutto dovrebbe germogliare nella vita ma, in caso contrario, potrebbe essere necessario riavviare. Puoi farlo tornando a tty1 ed eseguendo sudo reboot .

Se l'unità continua a non caricare, prova:

dconf reset -f /org/compiz/
unity --reset-icons &disown

Riavvia se non funziona immediatamente.

Per 11.10 E precedenti

Se speri in un TTY ( Ctrl + Alt + F1 attraverso F6 ) ed esegui:

DISPLAY=:0 unity --replace

Ripristina Unity su TTY 7 ( Ctrl + Alt + + F7 ).

Puoi anche provare solo:

DISPLAY=:0 unity

Ma questo non funzionerà se un windows manager è già in esecuzione sul display 0 (ti darà un errore, usa solo unity --replace in quel caso).

Se Unity assolutamente rifiuta di riavviare, prova questo:

Installa gnome-panel :

sudo apt-get install gnome-panel

Poi eseguilo sul display 0:

DISPLAY=:0 gnome-panel

Dovresti avere i pannelli di stile Gnome 2 sul desktop, che puoi usare per uscire.

Grafica ibrida

Alcune informazioni molto utili e ulteriori letture per gli utenti di grafica ibrida possono essere trovate qui .

Una volta che le GPU sono state configurate in modo appropriato per l'accelerazione 3D e OpenGL puoi:

  1. Installa i driver Nvidia dal link :

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    o

    Preferirei davvero il PPA stabile , ma non sembra avere pacchetti per la 13.04 ancora . Aggiornamento: questi sembrano essere disponibili dal 25 settembre. Installerei questo PPA stabile - puoi provare ma non l'ho testato.

    I driver Nvidia forniti da Ubuntu erano già installati e ho semplicemente installato da questo PPA aggiungendolo e facendo un aggiornamento del pacchetto usando update-manager .

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    
  2. Installa Bumblebee dal link

    AGGIORNAMENTO: dal 6 ottobre, ppa:xorg-edgers/ppa sembra contenere anche bumblebee. Quindi, se si installa da questo PPA, si potrebbe voler provare a saltare l'aggiunta del PPA Bumblebee e installarlo da qui, invece.

    Se hai scelto il PPA stabile nel passaggio 1, installa il PPA stabile di Bumblebee come segue:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. AGGIORNAMENTO: dopo aver aggiunto i PPA, aggiorna gli elenchi dei pacchetti:

    sudo apt-get update
    

    Se hai già installato i driver nvidia dai repository standard di Ubuntu, esegui semplicemente l'upgrade per ottenere la nuova versione dal repository scelto nel passaggio 1:

    sudo apt-get upgrade
    sudo apt-get install bumblebee
    
  4. Esegui i seguenti comandi per "riparare" Unity (dalla risposta di brandon-bertelsen a Unity non viene caricato, nessun Launcher, nessun Dash appare ):

    dconf reset -f /org/compiz/
    unity --reset-icons & disown
    
risposta data Mark Shuttleworth 27.12.2010 - 13:45
32

Il modo più semplice per farlo è premere Ctrl + Alt + T per ottenere un terminale e poi emettere:

rm -rf ~/.compiz-1 ~/.config/compiz-1

e la tua sessione di unità tornerà davanti ai tuoi occhi ..

Questa tecnica è migliore del rilancio di ccsm, perché puoi entrare nella condizione di errore dell'OP senza deselezionare accidentalmente anche l'unità in ccsm; puoi ottenerlo semplicemente premendo accidentalmente il pulsante "Preferenze" in ccsm.

    
risposta data achiang 10.11.2011 - 06:55
25

Anch'io ho avuto questo problema. L'ho risolto eliminando il contenuto del file ~ / .config / compiz-1 / compizconfig e relog.

rm -rf ~/.config/compiz-1/compizconfig/*
    
risposta data dome cs 30.10.2011 - 07:23
21

Ho avuto esattamente lo stesso problema.

Se hai installato Compiz Config Settings Manager, è possibile che il plugin Unity Desktop sia disabilitato.

Accedi a un desktop Unity 2D e verifica che sia abilitato in CCSM come questo,

Unity Shell non verrà caricato nel desktop predefinito se la casella di controllo non è selezionata e la sessione verrà visualizzata nella tua foto.

    
risposta data Mark Rooney 22.10.2011 - 09:09
19

Gli sviluppatori stanno sempre correggendo i bug, quindi un'alternativa è aspettare e seguire i progressi nella risoluzione dei bug ( iscriviti allo sviluppo di Unity in Launchpad ).

  1. Premi Ctrl + Alt + F2 .

  2. Accedi.

  3. Esegui sudo shutdown -r now in un terminale.

  4. Nella schermata di accesso dopo il riavvio del sistema, scegli Unity 2D (per ora) facendo clic con il pulsante destro del mouse sull'icona della ruota dentata.

  5. Attendi una correzione per Unity 3D / Ubuntu 11.10 (ad esempio a settimana).

  6. Aggiorna il tuo sistema per ottenere la correzione; in un tipo di terminale sudo apt-get update && sudo apt-get upgrade .

UPDATE: sono riuscito a risolvere questo problema utilizzando ccsm , da accesso Unity 2D.

(Questo è adattato da questo forum di Ubuntu post .)

  1. Nella schermata di accesso, seleziona Unity 2D e accedi.

  2. Installa ccsm (CompizConfig Settings Manager) eseguendo in un terminale: sudo apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra .

  3. Avvia ccsm e seleziona la categoria Desktop . Abilita il Plugin Unity di Ubuntu ; se viene richiesto di risolvere i conflitti, selezionare il pulsante MIDDLE per tutti i conflitti. Chiudi ccsm al termine.

  4. Riavvia, seleziona Unity (3D) e accedi.

risposta data david6 15.10.2011 - 23:47
13

Ho un Asus U36SD che utilizza una configurazione "Optimus" (GPU Intel + Nvidia). Avevo Ubuntu 12.04 funzionante, ma con l'aggiornamento a 12.10, questo problema è apparso e persistito in 13.04. Sono riuscito a risolverlo attraverso i seguenti passaggi:

  1. Installa i driver Nvidia dal link .

    O:

    Preferirei davvero il PPA stabile al link , ma non sembra avere pacchetti per 13.04 ancora . Aggiornamento: questi sembrano essere disponibili dal 25 settembre. Installerei questo PPA stabile - puoi provare ma non l'ho testato.

    I driver Nvidia forniti da Ubuntu erano già installati e ho semplicemente installato da questo PPA aggiungendolo e facendo un aggiornamento del pacchetto usando update-manager . UPDATE:

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    (cosa ho fatto) o:

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    

    (versione stabile anche per 13.04 ora - non testato da me)

  2. Installa Bumblebee dal link

    AGGIORNAMENTO: a partire dal 6 ottobre, ppa: xorg-edgers / ppa sembra contenere anche bumblebee. Quindi, se si installa da questo PPA, si potrebbe voler provare a saltare l'aggiunta del PPA Bumblebee e installarlo da qui, invece.

    Se hai scelto il PPA stabile nel passaggio 1, installa il PPA stabile di Bumblebee come segue:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. AGGIORNAMENTO: dopo aver aggiunto i PPA, aggiorna gli elenchi dei pacchetti:

    sudo apt-get update
    

    Se hai già installato i driver nvidia dai repository standard di Ubuntu, esegui semplicemente l'upgrade per ottenere la nuova versione dal repository scelto nel passaggio 1.:

    sudo apt-get upgrade
    

    Installa Bumblebee

    sudo apt-get install bumblebee
    
  4. Esegui i seguenti comandi per "riparare" Unity (dalla risposta di brandon-bertelsen a Unity non viene caricato, nessun Launcher, nessun Dash appare ):

    dconf reset -f /org/compiz/ 
    unity --reset-icons &disown
    
risposta data Thomas Arildsen 02.05.2013 - 12:45
12

Il poster originale della domanda duplicata, risolto modificando la sua stessa domanda:

  

Soluzione trovata: Elimina .Xauthority nella mia home (o rinomina)

    
risposta data mateo_salta 08.08.2012 - 22:41
10

Per 13.10:

Solo per assicurare che tutto sia installato:

sudo apt-get install --reinstall unity ubuntu-desktop

Successivamente, ricarica tutto:

dconf reset -f /org/compiz/ && unity --reset-icons &disown

Ho appena provato questo e funziona!

Fonte:

link

Se tutto il resto fallisce:

Ricorda, crea sempre backup! Tuttavia, a volte una nuova installazione è buona, reinstallare Ubuntu?

    
risposta data Jared Burrows 06.12.2013 - 01:07
10

Questo è successo anche a me in Ubuntu 16.04 dopo un aggiornamento dei pacchetti unity e compiz. Nessuno dei precedenti ha funzionato.

L'unico modo in cui ho trovato i lanciatori e i trattini per tornare era rimuovere (mentre NON è stato effettuato l'accesso a Unity) la directory .cache nella mia home.

    
risposta data lorenzo-bettini 20.09.2016 - 09:27
9

Sembra che ci sia un problema con 12.04 Unity 3D e gli attuali driver Nvidia.

Vedi questo post (Unity 3d non funziona più dopo l'installazione 12.04) per i dettagli su come aggirare il problema.

Ho un Pentium 4 3.06 GHz Compaq D520SFF a 32 bit, con una Nvidia GeForce 6200, con kernel 3.2.0-24-generico-pae, e ha avuto esattamente lo stesso problema (opere 2D, 3D no), e il downgrade dei driver Nvidia ha funzionato in 3D per me in un paio di minuti.

    
risposta data Heimdall 01.05.2012 - 01:38
8

Per le icone, è dovuto a Nautilus. Scrivi nautilus & in un terminale, non chiuderlo e le icone torneranno.

EDIT 10/10/2013 : per Nautilus puoi anche digitare Alt + F2 per aprire il prompt della riga di comando di Unity e scrivere nautilus nella ricerca globale / prompt CLI. Si aprirà un file explorer. Puoi chiuderlo se vuoi.

    
risposta data air-dex 26.12.2012 - 16:14
8

Ho avuto un problema simile:

l'unità con 14.04 in combinazione con IBM Notes9 ha comportato un comportamento strano (i clic del mouse non funzionavano più). La mia soluzione era quella di aprire un terminale e riavviare l'unità digitando unity & .

L'ultima volta che l'ho fatto, ha danneggiato totalmente l'unità: nessun trattino, nessun lanciatore niente. Penso di aver provato OGNI suggerimento che è elencato in questa pagina - nessuno di questi ha aiutato.

Ma finalmente un collaboratore ha avuto la risposta che ha funzionato per me:
Ho installato lo strumento di unità-tweak; di quanto ho eseguito unity-tweak-tool --reset-unity e riavviato.

In seguito, l'unità è tornata in vita. Ovviamente tutte le precedenti modifiche di configurazione all'unità erano sparite, ma questo è il significato di --reset-unity .

E il grande vantaggio di questa soluzione: richiede solo l'aggiunta di un singolo pacchetto e il ripristino delle modifiche di configurazione dell'unità, ma non è necessario reimpostare compiz, installare ccsm o seguire tutte le altre lunghe attività.

Aggiornamento:

la altra soluzione che trovo molto utile oggigiorno viene da qui - il punto : a volte devi rimuovere (o meglio ancora: inserire un backup "funzionante") del tuo file ~ / .config / dconf / user.

    
risposta data GhostCat 04.06.2014 - 12:21
6

Se speri in un tty ( Ctrl + Alt + F1 attraverso F6 ) ed esegui:

DISPLAY=:0 unity --replace

Ripristina Unity di nuovo su tty 7 ( Ctrl + Alt + + F7 ).

Puoi anche provare solo:

DISPLAY=:0 unity

Ma questo non funzionerà se un windows manager è già in esecuzione sul display 0 (ti darà un errore, usa solo unity --replace in quel caso).

Se Unity assolutamente rifiuta di riavviare, prova questo:

Installa gnome-panel :

sudo apt-get install gnome-panel

Poi eseguilo sul display 0:

DISPLAY=:0 gnome-panel

Dovresti avere i pannelli di stile Gnome 2 sul desktop, che puoi usare per uscire.

Trovo che Unity sia davvero buggy in 13.04 con la mia scheda Nvidia .. YMMV.

    
risposta data Seth 19.05.2013 - 20:07
5

Ho avuto circa 3 volte dove avevo bisogno del Ctrl + Alt + F1 per non perdere il lavoro e incasinato ... Ho anche nvidia. Vorrei suggerire questo:

Ctrl + Alt + F1 (ok, schermata vuota) Digita il tuo login, premi Invio, quindi la password (tutto nella schermata vuota) digita questo adesso:

sudo startx -- :1

dovrà digitare nuovamente la password e Invio questo aprirà una sessione X a Ctrl + Alt + F8 (salterà automaticamente ad esso) ora crea un nuovo file di testo vuoto chiamato runBash.sh e digita su di esso:

bash

salvalo, cambia le sue autorizzazioni in eseguibile ed eseguilo, otterrai un terminale veramente rilassante che ti fa ricordare perché Linux è buono! : D

al termine, ricorda di Ctrl + Alt + F1 , premi Ctrl + C (terminerà la nuova sessione X), digita exit, Invio, terminerà la sessione del terminale (schermata vuota). se pensi di aver sbagliato a digitare exit, premi Ctrl + C e digita di nuovo, non farlo troppo velocemente.

quindi puoi migliorarlo, creare uno script che ti permetta di digitare il meno possibile, ma comunque dovrai comunque scrivere molto mentre lo schermo è vuoto, ma è meglio di niente:)

Sto ancora cercando Ctrl + Alt + F1 soluzione corretta Ubuntu 12.04 + nvidia.

    
risposta data Aquarius Power 28.05.2012 - 01:39
4

Se utilizzi una scheda grafica di accelerazione accanto alla scheda grafica predefinita, è probabilmente a causa dell'installazione dei loro driver. Alcuni aggiornamenti dei driver delle schede grafiche di accelerazione in sistemi con due schede grafiche tendono a presentare comportamenti instabili in alcuni sistemi. Ho una scheda Nvidia e una scheda Intel. Accadeva con me quando ho installato i driver Nvidia. Launcher e pannello sparirebbero dal desktop. Se si utilizza una scheda Nvidia, l'installazione di Bumblebee potrebbe essere una soluzione temporanea: collegamento

    
risposta data user153634 01.05.2013 - 12:46
4

La prima risposta funziona bene, tranne che ho bisogno di installare Unity stesso:

sudo apt-get install unity

quindi esegui:

ccsm

e abilita Unity:)

    
risposta data sobi3ch 26.11.2013 - 02:22
4

Avevo più o meno lo stesso problema sotto 12.04. L'unità è stata lenta con la mia vecchia GPU, quindi stavo usando Unity 2d come desktop per mesi. Per nessuna ragione apparente, si è improvvisamente rifiutato di visualizzare il launchpad e la barra del titolo (per tutti gli utenti). Reenabling Unity in CCSM come suggerito qui era parte della soluzione, ma nessuna delle altre misure suggerite qui, lì o in altri thread correlati, inclusi, ma non limitati a:

  • Reinstallazione dell'unità

  • Reinstallazione di Ubuntu desktop

  • Rimozione di tutte le informazioni di configurazione pertinenti (ad esempio compiz, gconf, ecc.)

mi ha aiutato a risolvere completamente questi sintomi in 12.04 (64 bit).

unity --reset

non funzionerebbe per me Dopo aver consegnato una varietà di messaggi di errore e di informazione, si sarebbe sempre bloccato a:

Setting Update "run_key"

come mostrato nel log pubblicato in il thread intitolato "unità è scomparso" per l'unità eseguita senza argomenti .

Ho notato che il messaggio di errore consegnato da:

/usr/lib/nux/unity_support_test -p

era simile ad alcuni degli errori riportati da unity --reset :

errore durante il caricamento delle librerie condivise: libGL.so.1: impossibile aprire il file oggetto condiviso: nessun file o directory di questo tipo.

Dopo una lunga ricerca, ho trovato la seguente soluzione:

  • Ottieni il percorso di libGL.so.1 utilizzando il comando locate libGL.so.1 .

  • Aggiungi un collegamento alla libreria in / usr / lib / come mostrato nel seguente esempio:

    sudo ln -s /usr/lib/i386/mesa/libGL.so.1 /usr/lib
    

    (per gentile concessione di JD Bartlett )

  • Riavvia il computer.

Ciò non solo consentiva l'esecuzione di unity_support_test-p e unity --reset , ma consentiva anche l'avvio di Unity 2D. Non ho idea di cosa abbia causato i miei problemi, ma da quando ho creato i collegamenti sopra (diverse settimane) non ho avuto ulteriori problemi.

    
risposta data R B 20.12.2013 - 11:42
4

Quando ho accidentalmente aggiornato da 12.04 LTS Ubuntu a 13.04, anch'io ho dovuto affrontare gli stessi problemi come la barra dei menu laterale mancante, nessuna opzione di finestra, non essere in grado di passare da un'applicazione all'altra ( alt - scheda ) e non riuscivo nemmeno a trascinare le finestre sullo schermo. Dopo aver seguito così tante opzioni ho finito con il seguente set di comandi per risolvere questi problemi.

sudo apt-get remove aspell #may not be relevant
sudo apt-get remove dictionaries-common

riavvia (puoi usare sudo reboot )

sudo apt-get install compizconfig-settings-manager
sudo apt-get install dictionaries-common
sudo apt-get install lightdm

riavvia (puoi usare sudo reboot )

dconf reset -f /org/compiz/
unity --reset-icons & disown

In realtà ho rimosso Aspell a causa della dipendenza in conflitto. Questo potrebbe non avere alcuna correlazione tra questo problema. Penso che reinstallare il lightdm e resettare il compiz mi abbia aiutato a risolvere questo problema.

    
risposta data Bunti 16.05.2014 - 18:20
4

Succede quando accedi con un altro tty e prova, come lo stesso utente, di avviare X (con startx o initx).

Ad esempio, Ubuntu viene eseguito in tty7. Con Ctrl + Alt + F1 tty1 si apre. Accedi come lo stesso utente ed esegui startx. Torna a tty7, disconnetti e accedi. Si ottiene solo il wall paper desktop.

Per risolvere il problema, scegli tty1, accedi, rimuovi il file .Xauthority nella tua home directory, logout, login. Risolto.

    
risposta data user85164 27.04.2013 - 08:59
2

Ho avuto lo stesso problema dopo aver fatto sudo apt-get install kubuntu-desktop che ha rotto l'installazione di lightdm per qualche motivo. Sono in esecuzione 16.04 qui.

Premi ctrl - alt - F1 per arrivare al terminale, quindi:

sudo service lightdm stop
sudo apt-get remove lightdm
sudo apt-get update && sudo apt-get install lightdm
sudo reboot

Questo lo ha risolto per me dopo ore di tirarmi fuori i capelli.

    
risposta data localhost 07.10.2016 - 17:29
2

Ha funzionato con Ubuntu 16.04:

Ho ripristinato compizconfig rimuovendo la sua cache (in realtà il comando esegue il backup, quindi può essere ripristinato).

Esegui i seguenti comandi e logout successivi:

mv ~/.cache/compizconfig-1 ~/.cache/compizconfig-backup

setsid unity

Attenzione: rimuove l'impostazione Unity personalizzata.

    
risposta data Oleksandr Shpota 09.03.2018 - 00:49
1

Sto riscontrando lo stesso problema e ho risolto utilizzando pycharm's terminal .

 - Go to my-computer -> user -> share ->  
 - open pycharm and its terminal
 - sudo apt-get update
 - sudo apt-get upgrade 
 - sudo apt-get install --reinstall ubuntu-desktop
    
risposta data Muhammad Taqi 02.06.2015 - 14:26
1

Apparentemente, scollegare il mio secondo monitor era la soluzione, e quindi sono stato in grado di installare e aggiornare i driver corretti.

    
risposta data user2580915 27.07.2015 - 20:08
1

Ho provato molte delle soluzioni menzionate in questa discussione e altre. Finalmente questo ha funzionato per me:

dconf reset -f /org/compiz/

poi

setsid unity

Grazie a tutti per aver contribuito.

    
risposta data Ashu 17.01.2016 - 02:00
1

Oggi ho riscontrato situazioni in cui l'utente del mio script ha deciso di avviarlo inserendo la chiamata in script nel suo file $HOME/.profile . Di conseguenza, Unity non poteva essere lanciato.

Gli script per loro natura sono sequenziali, quindi .profile aspettava sostanzialmente che lo script finisse e Unity non poteva avviarsi se .profile non era terminato.

Ho fatto la stessa cosa, chiamato lo script da .profile , e ho ricevuto lo stesso risultato: il mio sfondo dello schermo di login è rimasto lì, nessun trattino o launcher è apparso, non è stato possibile fare clic con il tasto destro sul desktop o eseguire un'azione diversa da accedi a TTY1.

La soluzione era rimuovere la riga appropriata dal .profile . È possibile staccare un comando da .profile usando la forma commerciale, <command> & , ma il problema è che ogni volta che l'utente apre il terminale o accede a TTY, viene generata una nuova istanza di quel comando. Quindi, raccomando vivamente di non lanciare programmi da .profile a meno che tu non sappia cosa stai facendo.

Link allo script originale e discussione qui: link

    
risposta data Sergiy Kolodyazhnyy 28.02.2016 - 04:10
1

Ho avuto questo problema, ho provato un sacco di cose e ho persino abilitato l'unità, ma niente ha funzionato. Innanzitutto, è necessario aprire TTY (ctrl + alt + F1) e accedere. Adesso usa

    env DISLAY:=0 gnome-terminal        

Chiudi TTY con ctrl + alt + F7, quindi usa (nel terminale)

dconf reset -f /org/compiz/

Dopo, usa

sudo reboot
    
risposta data TheEpicstarlord 07.01.2017 - 14:09

Leggi altre domande sui tag