Apache non è in grado di riavviare

56

Cercando di riavviare apache dal terminale usando il seguente comando:

 sudo service apache2 restart

quando si esegue quel comando ottenendo sotto l'errore:

Job for apache2.service failed. See "systemctl status apache2.service" and "journalctl -xe" for details.

In fase di escutazione "systemctl status apache2.service" ottenuto sotto l'output

apache2.service - (null)
   Loaded: loaded (/etc/init.d/apache2)
   Active: failed (Result: exit-code) since Sat 2015-05-30 02:22:41 IST; 12s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 4866 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

apache error.log

AH00489: Apache/2.4.12 (Unix) configured -- resuming normal operations
AH00094: Command line: '/usr/local/apache2/bin/httpd'
    
posta Gautam Savaliya 29.05.2015 - 22:48

10 risposte

49

Forse questo ti aiuterà a trovare la causa:

journalctl | tail

Nel mio caso si è trattato di un errore nel file di configurazione:

AH00526: Syntax error on line 5 of /etc/apache2/sites-enabled/mydomain-wsf.lan.conf
    
risposta data Arek 18.08.2015 - 12:16
32

C'è un errore di sintassi nel file apache2.conf

Nel tipo di terminale:

% Bl0ck_qu0te%

then:

% Bl0ck_qu0te%

Ti mostrerà dove si trova l'errore nel file apache2.conf per correggere.

    
risposta data rancho 01.08.2016 - 20:31
14

Il problema è perché alcuni file di configurazione sono stati cancellati, devi reinstallarlo.

REINSTALLARE APACHE2:

Per sostituire i file di configurazione che sono stati cancellati, senza eliminare il pacchetto, puoi fare:

sudo apt-get -o DPkg::Options::="--force-confmiss" --reinstall install apache2

Per rimuovere completamente i file di configurazione di apache2, dovresti:

sudo apt-get purge apache2

che ti consentirà di reinstallarlo nel solito modo con:

sudo apt-get install apache2

Purge è necessario rimuovere tutti i file di configurazione - se si eliminano i file di configurazione ma si rimuove solo il pacchetto, questo viene ricordato & amp; i file di configurazione mancanti non vengono reinstallati per impostazione predefinita.

Quindi REINSTALLA PHP5:

apt-get purge libapache2-mod-php5 php5 && \
apt-get install libapache2-mod-php5 php5
    
risposta data Rujika Rajan 15.03.2016 - 11:06
2

Ho ricevuto lo stesso errore dopo aver rimosso un host virtuale. Il problema era il persistente file conf SSL associato a quell'host situato in /etc/apache2/sites-enabled . L'SSL era attraverso Let's Encrypt, quindi il codice da rimuovere era:

sudo rm yourdomain.com-le-ssl.conf
    
risposta data iMarketingGuy 01.03.2017 - 20:47
1

Problema:

Job for apache2.service failed because the control process exited with error code. See "systemctl status apache2.service" and "journalctl -xe" for details.

Soluzione:

  • Per rimuovere completamente i file di configurazione di apache2, dovresti:

    1) sudo apt-get purge apache2

  • che ti consentirà di reinstallarlo nel solito modo con:

    2) sudo apt-get install apache2

== & gt; Funziona bene ...

grazie ....

    
risposta data Riyal Padhiyar 27.12.2016 - 08:12
1

molto probabilmente hai un errore di sintassi. per me era nella mia cartella "abilitata ai siti".

Ho erroneamente digitato 'ServerAlias' in 'ServerAlisa'.

    
risposta data Bruce Tong 15.09.2017 - 14:12
0

Questo è principalmente un errore di configurazione. Ho appena avuto un vecchio sito abilitato su Apache, cosa ha causato questo errore. Quindi ho dovuto disabilitarlo prima di ricaricare apache.

sudo a2dissite <my-site>
sudo service apache2 reload

Problema risolto:)

    
risposta data Thomas Venturini 20.08.2016 - 08:15
0

Grazie per il tuo aiuto! Sono stato in grado di installare correttamente con la soluzione:

Per rimuovere completamente i file di configurazione di apache2, dovresti:

  1. sudo apt-get purge apache2 che ti permetterà di reinstallarlo nel solito modo con:

  2. sudo apt-get install apache 2

Adesso funziona bene.

    
risposta data Renata Sembay 16.01.2017 - 02:41
0

Penso che il problema è che hai qualche sito abilitato ma hai cancellato il suo file di configurazione. Prova a disabilitare il sito con     sudo a2dissite "nome" e quindi riavviare il server Apache. Almeno questo era il problema per me e questa azione l'ha risolto.

    
risposta data Ilias Koritsas 16.05.2017 - 16:56
0

Ho ricevuto gli stessi errori mentre lavoravo con .htaccess

Ho appena messo questo comando

<Directory /var/www/html>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
</Directory>

in /etc/apache2/sites-enabled/000-default.conf questa cartella

dopo averlo aggiunto ho ricevuto l'errore

quindi cancello questi comandi di pace dal file e il mio errore è stato risolto.

    
risposta data Kaushikdjay 26.07.2017 - 07:48

Leggi altre domande sui tag