Come disabilitare tutte le animazioni Unity?

43

Se non è possibile, forse solo il Dash mostra / nascondi le animazioni. Mi trovo semplicemente in attesa di animazioni inutili.

    
posta Bucic 17.05.2012 - 22:33

5 risposte

26

1.PerchénonpuoidisabilitarequestaanimazionediDashinUnity12.04

  • Sfortunatamente,l'animazionedidissolvenza/opacitàeitempiassociatisonocodificatinelcodicesorgentediUnity.
  • Ilcodiceeffettivopuòesseretrovatoin unity-5.12/plugins/unityshell/src/ShortcutController.cpp (questo è ciò che dovresti modificare e ricompilare per sbarazzarti delle animazioni)
  • Alcune linee di esempio da questo file che dimostrano l'hard-coding dell'animazione quando usi il tasto Super per lanciare il Dash:

    30:const unsigned int SUPER_TAP_DURATION = 650;
    31:const unsigned int FADE_DURATION = 100;
    39:  , fade_in_animator_(FADE_DURATION)
    40:  , fade_out_animator_(FADE_DURATION)
    65:  fade_in_animator_.animation_updated.connect(sigc::mem_fun(this, &Controller::OnFadeInUpdated));
    66:  fade_in_animator_.animation_ended.connect(sigc::mem_fun(this, &Controller::OnFadeInEnded));
    67:  fade_out_animator_.animation_updated.connect(sigc::mem_fun(this, &Controller::OnFadeOutUpdated));
    68:  fade_out_animator_.animation_ended.connect(sigc::mem_fun(this, &Controller::OnFadeOutEnded));
    120:    show_timer_ = g_timeout_add(SUPER_TAP_DURATION, &Controller::OnShowTimer, this);
    149:    self->fade_out_animator_.Stop();
    150:    self->fade_in_animator_.Start(self->view_window_->GetOpacity());
    213:    fade_in_animator_.Stop();
    214:    fade_out_animator_.Start(1.0 - view_window_->GetOpacity());
    244:  .add("timeout_duration", SUPER_TAP_DURATION + FADE_DURATION)
    246:  .add("about_to_show", (Visible() && !fade_out_animator_.IsRunning() && view_window_ && view_window_->GetOpacity() != 1.0f))
    247:  .add("about_to_hide", (Visible() && !fade_in_animator_.IsRunning() && view_window_ && view_window_->GetOpacity() != 1.0f))
    
  • Naturalmente, dovresti applicare una patch e ricostruire con ogni nuovo aggiornamento Unity ...

  • Nessuna quantità di ingerenza con Compiz può cambiare questo perché tutto è codificato al di fuori del plug-in Compiz.

2. Alternativa A: Passa a Ubuntu 2D

Ubuntu 2D ha un diverso codice Unity Shell, e lì, l'avvio del dash tramite Super è istantaneo e non anima niente.

3. Alternativa B: usa una scorciatoia personalizzata per lanciare il Dash facendo clic sul logo di Ubuntu, ignorando così l'animazione

Possiamo sfruttare il fatto che l'animazione di opacità / dissolvenza non accade quando avvii il Dash tramite il pulsante "start", o, se il tuo cursore è su / attorno alla barra di avvio, anche se premi Super:

L'animazioneverràposticipatafinoaquandoilcursoresimuoveràeffettivamentenell'areadeltrattino.

  1. xdotoolconsentel'automazionedeiclic/movimentidellatastieraedelmouse;installaloconsudoapt-getinstallxdotool
  2. ApriImpostazioni...TastieraevaiallaschedaScorciatoie.Creaunascorciatoiapersonalizzata,nominalacomevuoieimpostail"Comando" su:

    xdotool mousemove --sync 25 60 click 1 --delay 100  mousemove restore
    

    • Potrebbeesserenecessarioregolareleggermentelecoordinate(2560)selarisoluzionedelloschermoèinferiorea1024x768ogiùdilì.
  3. FaiclicsuApplica.Lacolonnadidestradirà"Disattiva", fai clic su di esso e vedrai "Nuovo acceleratore": premi la combinazione di tasti di scelta rapida. Non puoi scegliere Super , anche se lo disattivi in Compiz, perché è difficile da catturare da Unity. Ho scelto Ctrl+Alt+Z poiché si trova vicino al tasto Super.

  4. Ora la tua scorciatoia dovrebbe lanciare Dash molto, molto più velocemente.

    • Ecco una demo video di YouTube . Le prime volte (quando il launcher a sinistra sfoca e si scurisce) è con il tasto SUPER; poi con la scorciatoia personalizzata di xdotool (nota che il launcher non si anima più e il trattino appare più veloce)
risposta data ish 29.07.2012 - 15:18
23

Installa Compiz Configuration Manager.

Software Center di Ubuntu: Compiz Configuration Manager

o

Terminale: sudo apt-get install compizconfig-settings-manager

Una volta installato, aprilo e vai a Ubuntu Unity Plugin - & gt; % Co_de% (Tab)

Da lì puoi impostare Experimental , Lauch Animation e Urgent Animation su 'Nessuno.

Imposta Dash Blur su Hide Animation .

Se lo desideri, puoi cambiare il pannello e la trasparenza del dash per renderlo completamente opaco.

    
risposta data Angel Araya 17.05.2012 - 22:46
6

Mi spiace, non puoi. A questo punto (25 luglio 2012) con Ubuntu 12.04 LTS, c'è NO un modo semplice per disabilitare le animazioni Unity. (almeno senza ricompilazione).

E non penso, ci sarà un'opzione per disabilitare le animazioni nelle versioni future. Perché, Uno degli obiettivi di Unity è fornire un'esperienza utente gradevole e le animazioni sono considerate uno dei modi migliori per farlo.

Una soluzione alternativa:

La possibile soluzione per te è cambiare l'animazione del cruscotto in dissolvenza (perché, a mio parere, le dissolvenze sono più veloci che scorrevoli). Potresti anche voler disabilitare anche le animazioni per tutte le finestre. Per fare ciò,

  1. Scarica e installa compizconfig-settings-manager

    sudo apt-get install compizconfig-settings-manager  
    
  2. Aprilo cercando o digitando ccsm nel trattino. Vai alla scheda Unity plugin Experimental e modifica le impostazioni per Nascondi animazioni a Fade only .

Se vuoi disabilitare le animazioni in tutte le finestre, puoi disabilitare il plugin Animazioni in ccsm. Se vuoi disabilitare Fading, disabilita i plugin Fading windows .

Spero che questo ti sia d'aiuto.

Modifica: come mostrato da izx nella sua risposta modificata Vedi chiaramente che le opzioni le animazioni dei trattini sono codificate nell'Unità, e quelle non possono essere modificate con nessuna delle opzioni di configurazione, perché quelle durate non sono variabili che possono essere modificate. Quindi, questo significa che devi ricompilare l'unità modificando tali durate di tempo a 0 ms per disabilitare completamente le animazioni.

    
risposta data Anwar 13.04.2017 - 14:23
2

Da aggiungere alle istruzioni di Ángel Araya : sono stato in grado di disabilitare tutte le animazioni deselezionando Animations e Fading Windows (praticamente tutto tranne Window Decoration sotto la categoria Effects (scheda) in Gestore impostazioni CompizConfig.

    
risposta data Dune 17.06.2012 - 06:16
1

Penso che disattivare le finestre di dissolvenza sotto effetti in CompizConfig Settings Manager possa fare la differenza in Unity. (Una sottile differenza di velocità, ma ancora una differenza.)

    
risposta data Rob 08.02.2013 - 18:53

Leggi altre domande sui tag