Come faccio a forzare SSH per consentire solo agli utenti con una chiave di accedere?

47

Ho provato a seguire le istruzioni qui: link

per consentire solo agli utenti con una chiave pubblica sul server di autenticarsi, ma non posso ottenere che SSH impedisca l'accesso con solo un nome utente / password.

Ecco il mio file sshd_config - mi manca qualcosa? Ho già provato a riavviare SSH e il computer stesso.

# Package generated configuration file
# See the sshd_config(5) manpage for details


# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes


# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768


# Logging
SyslogFacility AUTH
LogLevel INFO


# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes


RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile        %h/.ssh/authorized_keys


# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes


# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no


# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no


# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication no


# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes


# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes


X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no


#MaxStartups 10:30:60
#Banner /etc/issue.net


# Allow client to pass locale environment variables
AcceptEnv LANG LC_*


Subsystem sftp /usr/lib/openssh/sftp-server


# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM no
    
posta user193805 18.09.2013 - 00:35

5 risposte

66

Di default PasswordAuthentication è impostato su sì, anche se lo commenta. Questo è il caso del tuo /etc/ssh/sshd_config .

Devi impostare in modo esplicito PasswordAuthentication no per consentire solo l'autenticazione con chiave pubblica.

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no

E riavvia sshd service ssh restart (migrazione pre systemd) o systemctl restart sshd.service .

    
risposta data Terry Wang 18.09.2013 - 00:51
8

Secondo questa pagina wiki sulle chiavi SSH e questo risposta , devi modificare queste due righe in sshd_config :

PasswordAuthentication no
ChallengeResponseAuthentication no
    
risposta data Andy J 25.11.2014 - 10:21
4

In /etc/ssh/sshd_config , sotto le impostazioni ha funzionato per me:

PasswordAuthentication no
UsePAM no

Infine, riavvia sshd daemon.

    
risposta data BTR Naidu 09.10.2015 - 10:27
3

La riga che vuoi è anormalmente commentata per impostazione predefinita nel file sshd_config.

# Change to no to disable tunnelled clear text passwords
--->#PasswordAuthentication yes

Per disabilitare le password, modifica yes in no e rimuovi il commento :

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no
    
risposta data Nolan Hergert 07.09.2015 - 21:30
1

dal link : in genere, la home directory dell'utente o qualsiasi file o directory contenente i file delle chiavi non dovrebbe essere scrivibile da nessun altro. Altrimenti qualcun altro potrebbe aggiungere nuove chiavi autorizzate per l'utente e ottenere l'accesso. I file delle chiavi private non dovrebbero essere letti da nessun altro.

Prova con sudo chmod go-rwx /home/username/ in sostituzione di username a seconda dei casi.

    
risposta data Diego Alonso Reyes Molina 07.11.2017 - 22:13

Leggi altre domande sui tag