Impossibile utilizzare le scorciatoie da tastiera IntelliJ IDEA su Ubuntu

116

Sono molto nuovo su Ubuntu e sto avendo un problema che non so come risolverlo. Ho persino provato a cercarlo sul Web per trovare le risposte, ma forse non conosco i termini giusti per cercarlo.

Lavoro con IntelliJ IDEA , un'applicazione per lo sviluppo. E sono molto abituato alle scorciatoie da tastiera, ma quando ho fatto il passaggio da Windows XP a Ubuntu 13.10, alcune scorciatoie non funzionano più. Ad esempio, ad esempio;

  • Ctrl + Alt + & lt; (freccia sinistra)
  • Alt + F8

C'è qualche ragione per cui? e ci sono soluzioni per questo? O forse solo qualcosa per guidarmi nella mia ricerca

Grazie mille in anticipo.

    
posta Rodrigo Sasaki 28.01.2014 - 13:01
fonte

9 risposte

185

Come un po 'di lettura mi ha insegnato che Intellij IDEA è un IDE incentrato sulla tastiera. Che cosa significa, è che un uso può funzionare con esso senza dover toccare il mouse. Gestisco anche l'impostazione della mappa dei tasti.

Per Ubuntu

Vedi come cambiare le scorciatoie da tastiera?

Ecco un elenco di modifiche che è necessario apportare con i collegamenti dei tasti di sistema predefiniti in modo che non interferiscano con le azioni IDEA IntelliJ (elencate tra parentesi).

  
  • Disabilita l'azione della finestra Shade, assegnata a Ctrl + Alt + S (finestra di dialogo Impostazioni)
  •   
  • Modifica o disabilita l'azione Blocca schermo, assegnata a Ctrl + Alt + L (codice riformattato)
  •   
  • Modifica o disabilita l'azione del terminale di avvio, assegnata a Ctrl + Alt + T (Surround with)
  •   
  • Modifica o disabilita l'opzione Passa all'area di lavoro, assegnata a Ctrl + Alt + Tasti freccia (Navigazione)
  •   
  • Disabilita l'azione della finestra Sposta, assegnata a Alt + F7 (Trova usi)
  •   
  • Modifica o disabilita l'azione della finestra Ridimensiona, assegnata a Alt + F8 (Valuta espressione)
  •   

Spero che questo aiuti!

Nota: puoi sempre ripristinare le scorciatoie di Ubuntu al suo stato predefinito. Fai riferimento a Come posso ripristinare le scorciatoie da tastiera predefinite? , nel caso in cui ti perdessi .

Fonte: - Intellij IDEA Keymap

    
risposta data AzkerM 28.01.2014 - 13:39
fonte
28

Ho incontrato anche questo problema, tuttavia la mia soluzione era diversa.

Non è consentito modificare o modificare la mappa dei tasti del sistema

IntelliJ ha diverse Keymap, che puoi modificare in base al tuo sistema operativo.

Puoi modificare IntelliJ Keymap dalle impostazioni.

Basta andare su Settings -> Keymap e selezionare la keymap desiderata dal menu a discesa. Nel mio caso, ho scelto "Default for GNOME" dal momento che sto usando Ubuntu Gnome 16.04.

    
risposta data Francisco C. 25.06.2016 - 07:18
fonte
9

Per ubuntu 18.04 LTS ctrl + alt + sinistra (conflitto di scorciatoie idea Intellij)

  • installa Dconf Editor nel software ubuntu
  • lancia Dconf Editor, vai a / org / gnome / desktop / wm / keybindings / switch-to-workspace-left

  • doppio clic come sotto

  • usa il valore predefinito (fai clic su Off) - & gt; Valore personalizzato (come me o altro)

  • potresti usarlo nell'intellij idea ora

    
risposta data think 06.05.2018 - 11:42
fonte
5

Ho creato questo script che disabilita tutte le scorciatoie in conflitto tra Ubuntu (testato con 15.10) e IntelliJ (e probabilmente più prodotti Jetbrains). Li disabilita in Ubuntu.

Crea anche un file di backup in modo da poter ripristinare le impostazioni precedenti.

Per non disabilitare alcune scorciatoie, commentale nell'array KEYS .

#!/bin/bash
set -euo pipefail

# Disables Ubuntu shortcuts that clash with IntelliJ Idea (and probably other
# Jetbrain products).
#
# Creates a backup file to restore the previous settings. To not have some
# shortcuts disabled, comment them out in the 'KEYS' array.
#
# Tested on : Ubuntu 15.10
# Author    : Jonas Gröger

readonly BACKUP_FILE="undo-fix-shortcuts-$(date +%s%N).sh"
readonly KEYS=(
    "/org/gnome/desktop/wm/keybindings/toggle-shaded"
    "/org/gnome/settings-daemon/plugins/media-keys/screensaver"
    "/org/gnome/settings-daemon/plugins/media-keys/terminal"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-down"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-up"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-left"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-right"
    "/org/gnome/desktop/wm/keybindings/begin-move"
    "/org/gnome/desktop/wm/keybindings/begin-resize"
    # To disable resetting a value, just comment out the line
)
readonly DISABLED_VALUE="['disabled']"

main() {
    # Make backup
    printf "#!/bin/bash\n" >>  "$BACKUP_FILE"
    for key in "${KEYS[@]}"; do
        local value
        value=$(dconf read "$key")
        printf "dconf write \"%s\" \"%s\"\n" "$key" "$value" >> "$BACKUP_FILE"
    done

    # Disable all Ubuntu shortcuts
    for key in "${KEYS[@]}"; do
        dconf write "$key" "$DISABLED_VALUE"
    done
}
main

Puoi ottenerlo da qui:

wget -O fix-shortcuts.sh https://gist.githubusercontent.com/JonasGroeger/94cfa1071fa12572f465/raw/fix-shortcuts.sh
    
risposta data Jonas Gröger 16.12.2015 - 22:40
fonte
3

Vedi qui per un modo per disabilitare le scorciatoie di Ubuntu a livello di programmazione e solo se sono attive le finestre di alcune applicazioni.

In particolare, usa questi valori (assumendo che tu usi la Casella degli strumenti JetBrains con il suo percorso di installazione standard, altrimenti adatta):

apppattern = "JetBrains"
backupfile = "~/.local/share/JetBrains/keymap_backup"

Mentre viene eseguito lo script, le scorciatoie di Ubuntu funzioneranno sempre eccetto quando IDEA et al. avere attenzione.

Ho una raccolta di scorciatoie specifiche di JetBrains qui ; l'input è apprezzato.

    
risposta data Raphael 22.12.2016 - 14:32
fonte
2

Solo per espandere un po 'l'eccellente risposta di AzkerM:

  
  • Disattiva l'azione della finestra Sposta, assegnata a Alt + F7 (Trova usi)      
        
    • da Impostazioni - & gt; Tastiera - & gt; Scorciatoie - & gt; Windows - & gt; Sposta finestra
    •     
  •   
  • Modifica o disabilita l'azione della finestra Ridimensiona, assegnata a Alt + F8 (Valuta espressione)      
        
    • da Impostazioni - & gt; Tastiera - & gt; Scorciatoie - & gt; Windows - & gt; Ridimensiona finestra
    •     
  •   
    
risposta data WillC 24.02.2016 - 12:15
fonte
1

Sto usando Ubuntu 16.04 e quello che stava accadendo è quando ho usato questi tratti di tasto (ctrl-alt-sinistra / destra), la finestra stava ridimensionando e posizionandosi a destra oa sinistra del mio schermo. Ho provato a disattivare questi binding di tasti in: Impostazioni / Tastiera / Navigazione, anche se non ho spazio di lavoro abilitato. Non ha comunque impedito il comportamento che stavo vedendo.

Fortunatamente, ho aperto Compiz e sono incappato nel plugin Window Management / Grid che mappava questi tasti per posizionare le finestre in una posizione di griglia. Ho disabilitato questo plugin e ora le mie scorciatoie IntelliJ funzionano bene con ctrl-alt-left / right.

    
risposta data Jason White 14.06.2016 - 00:08
fonte
1

Solo una soluzione rapida:
Se hai un tasto " Windows " sulla tastiera, puoi semplicemente aggiungerlo all'intera combinazione di tasti di scelta rapida: dovrebbe funzionare. Ad esempio:

  • Ctrl + Win + Alt + T (Surround with)
  • Win + Alt + F8 (valuta espressione )
risposta data guzoff 28.11.2017 - 21:53
fonte
0

Per Ubuntu 16.04 vai a impostazioni & gt; Tastiera e trova la combinazione specifica in conflitto con il tuo desiderato clic su di esso e aggiorna la combinazione con una nuova.

    
risposta data Cengkuru Michael 29.10.2017 - 10:22
fonte

Leggi altre domande sui tag