Come posso disattivare Bluetooth all'avvio del sistema?

272

Come posso disattivare Bluetooth all'avvio del sistema?

    
posta Floqqi 16.10.2011 - 23:02

28 risposte

187

18.04+ utenti che non hanno naturalmente un /etc/rc.local, dovrai crearne uno e renderlo eseguibile. Per semplificare le cose, puoi semplicemente incollare il seguente comando in un terminale:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Esegui sudoedit /etc/rc.local e aggiungi questo prima della riga con exit 0 :

rfkill block bluetooth

Dovresti comunque essere in grado di abilitare il Bluetooth tramite l'applet sulla barra superiore.

Questo dovrebbe funzionare per molti sistemi, ma sembra che ci siano alcuni bug in agguato nell'ACPI del kernel per Thinkpads. Se sei su un Thinkpad, aggiungi quanto segue a /etc/rc.local :

echo disable > /proc/acpi/ibm/bluetooth

Oppure controlla ibm-acpi - Driver IBM ThinkPad ACPI Extra - alcuni rapporti suggeriscono che ibm-acpi include il controllo Bluetooth (tra le altre cose carine). Ma non ho l'hardware, quindi sono completamente incapace di verificare queste affermazioni. Buona fortuna.

    
risposta data Oli 18.08.2010 - 11:00
68

Ho trovato un how-to con una "soluzione" pulita qui ( link di archivio per i posteri)

Cambiare effettivamente /etc/bluetooth/main.conf è stato sufficiente per me.

Dall'articolo:

Cerca la voce:

InitiallyPowered = true

e cambia il valore in:

InitiallyPowered = false

Per me è stato sufficiente, anche se l'articolo descrive alcuni altri passaggi che potrebbero essere o non essere necessari.

On Ubuntu 17.10 e Ubuntu 18.04 l'opzione InitiallyPowered è stata sostituita con AutoEnable

    
risposta data Stepbaer 25.06.2012 - 20:00
23

Per disabilitare il caricamento del driver bluetooth all'avvio:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

add:

blacklist btusb

Abilitarlo in un secondo momento dovrebbe essere:

sudo modprobe btusb
    
risposta data maco 18.08.2010 - 18:59
16

Passaggio 1: vai al terminale e digita il seguente comando per modificare il file /etc/rc.local del sistema:

gksudo gedit /etc/rc.local

Passaggio 2: aggiungi la seguente riga prima della riga exit 0 :

rfkill block bluetooth
    
risposta data Varun 04.05.2012 - 22:44
12

Da ubuntu 16.04 in poi systemd gestisce i servizi di avvio come bluetooth ... per visualizzare il problema dello stato corrente seguito in un terminale

sudo systemctl status bluetooth.service 

per disattivare Bluetooth in caso di avvio questo

sudo systemctl disable bluetooth.service

quindi al prossimo riavvio il bluetooth non sarà attivo ... per abilitare il problema Bluetooth

sudo systemctl enable bluetooth.service
    
risposta data Scott Stensland 01.08.2017 - 17:08
7

Digitare quanto segue in un terminale:

sudo gedit /etc/modprobe.d/blacklist.conf

Nella parte inferiore del file, aggiungi la riga:

blacklist bluetooth

Salva il file e riavvia - Bluetooth ora dovrebbe essere disabilitato.

    
risposta data Nathan Osman 16.10.2011 - 23:25
7

Puoi cambiare i servizi avviati all'avvio con l'aiuto di BUM .

Installalo: sudo apt-get install bum

Esegui: sudo bum

Deseleziona la casella e fai clic su Applica .

    
risposta data desgua 05.05.2012 - 02:09
5

Penso che il modo migliore sia disabilitare il servizio dall'inizio. Esiste un metodo generale per disabilitare i servizi che funziona perfettamente:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Questo funziona con Ubuntu 13.10 e probabilmente anche con versioni precedenti.

    
risposta data Felipe 18.01.2014 - 10:49
5

Aggiungo

"/etc/init.d/bluetooth stop"

in

"/etc/rc.local" 

prima del comando "exit 0" per l'avvio con bluetooth disattivato.

    
risposta data Saeed Zarinfam 23.08.2012 - 15:00
5

1. blocca il bluetooth in rc.local

Aggiungi questa riga alla fine del file /etc/rc.local subito prima della riga exit 0 :

rfkill block bluetooth

Questo farà il trucco, ma solo nelle vecchie versioni di Ubuntu usando upstart .

2. riattivabile rc.local su systemd

Su Ubuntu 15.10 con systemd come gestore di avvio il file /etc/rc.local non viene più utilizzato di default, quindi chiama questo terminale su un terminale:

sudo systemctl edit --full rc-local

Che apre un editor. Alla fine del file ho aggiunto:

[Install]
WantedBy=multi-user.target

Queste modifiche sono attivate da

sudo systemctl reenable rc-local

Ora il file /etc/rc.local è usato come lo sai.

3. disattiva blueman-applet all'avvio

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop
gnome-session-properties

Ora blueman-applet è visibile e puoi disabilitarlo dai programmi di avvio

4. Riavvia per vedere l'effetto

    
risposta data rubo77 10.11.2015 - 13:29
4

Puoi modificare le impostazioni di update-rc.d . Ho usato qualcosa di simile a:

sudo update-rc.d bluetooth remove

In Debian Wheezy. Scopri man update-rc.d per maggiori informazioni su come usarlo.

    
risposta data Keith Smiley 13.02.2013 - 16:50
2

Forse puoi spegnerlo nelle applicazioni di avvio. Ma queste applicazioni sono nascoste di default. Scopri le applicazioni nascoste di avvio in 12.04: apri il terminale ed esegui questi due comandi:

cd /etc/xdg/autostart/

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Ora puoi deselezionare bluetooth. (Non rimuovere!)

    
risposta data schiemanski 05.05.2012 - 10:50
2

No. Non è sempre presente nell'elenco delle applcations di avvio. Penso che la soluzione migliore sia aggiungere il comando rfkill nello script rc.local o impostare il parametro InitiallyPowered in /etc/bluetooth/main.conf .

    
risposta data Robert 05.05.2012 - 02:06
2

1) Installa il pacchetto smbios-utils e aggiungilo a Applicazioni di avvio con:

sudo smbios-wireless-ctl --bt 0

2) In tipo di terminale:

sudo visudo

e aggiungi alla fine del file aperto /etc/sudoers la riga:

<your username> ALL = NOPASSWD: /usr/sbin/smbios-wireless-ctl

3) Per attivare la funzionalità Bluetooth durante la sessione, eseguire il terminale:

sudo smbios-wireless-ctl --bt 1

Funziona per me sul mio Dell D630 con Ubuntu 13.10

    
risposta data victor 15.03.2014 - 16:58
2

Su Ubuntu 16.04, ho semplicemente disabilitato il servizio dall'avvio usando systemctl.

Per fare ciò, apri una finestra di terminale e digita quanto segue:

sudo systemctl disable bluetooth

Puoi riavviare il computer da quando il bluetooth sarà disattivato all'avvio, oppure se non vuoi riavviare e vuoi interrompere il bluetooth subito, puoi digitare:

sudo service bluetooth stop

    
risposta data Ken 22.08.2017 - 05:57
2

Possiamo disabilitare l'avvio automatico del bluetooth in questo modo:

sudo gedit /etc/bluetooth/main.conf

( gedit è il mio editor fav, puoi sostituirlo con xed o qualsiasi cosa sia installata sul tuo sistema.)

Nella parte inferiore di questo file, c'è questa riga:

#AutoEnable=false

Annulla commento, in questo modo:

AutoEnable=false
    
risposta data Shayan 20.02.2018 - 15:47
1

Utilizzo Sputnik Kernel , che ha risolto questo problema sul mio Dell Inspiron 14R N4110.

    
risposta data Alex Wiedermann 25.09.2012 - 01:53
1

Penso che dovresti modificare

/etc/default/bluetooth

e impostare

BLUETOOTH_ENABLED=0

per disabilitare il servizio Bluetooth all'avvio

    
risposta data Fabio 06.03.2014 - 21:17
1

Per quelli di voi in cui l'inserimento della riga rfkill block bluetooth (o qualsiasi altro) in /etc/rc.local non funziona, prova ad includere la stessa riga alla fine di ~/.bashrc

Nella mia configurazione (Ubuntu 14.04, Thinkpad W540), nessuna opzione funzionava inserendola in /etc/rc.local ma la prima funzionava in bashrc. Nota che funzionerà solo per l'utente corrente, non globalmente per tutti gli utenti.

    
risposta data Sam 19.10.2014 - 14:10
1

Su Ubuntu Studio 16.04 puoi disabilitare l'applet Bluetooth in Avvio in:

  

Sessione e avvio & gt; Autostart dell'applicazione & gt; Applet Bluetooth

Qui puoi fare clic sul campo per disabilitarlo.

    
risposta data ateymuri 26.08.2016 - 20:05
0

Aggiungo

"/etc/init.d/bluetooth stop"

in

"/etc/rc.local" 

prima del comando "exit 0" per l'avvio con bluetooth disattivato.

    
risposta data Saeed Zarinfam 23.08.2012 - 15:05
0

Soluzione per il mio taccuino

"BIOS - Configurazione USB - EHCI2: disabilitato"

EHCI1 è per porte USB (in realtà Il mio notebook ha 2 porte USB 2.0)

    
risposta data MSP 27.03.2014 - 19:46
0

Modifica /etc/default/grub :

sudo nano /etc/default/grub

e modifica la seguente riga:

GRUB_CMDLINE_LINUX=""

per dire questo:

GRUB_CMDLINE_LINUX="bluetooth.blacklist=yes"

Quindi aggiorna grub e riavvia:

sudo update-grub
    
risposta data mchid 21.09.2015 - 07:58
0

Questo dovrebbe disabilitare il bluetooth per l'avvio su sistemi basati su Debian:

sudo chkconfig bluetooth off

o su sistemi basati su RedHat

systemctl disable bluetooth.service
    
risposta data Stanislav 16.10.2017 - 22:18
0

Se stai usando l'applet Bluetooth nel pannello superiore (blueman-applet), ha la sua impostazione che attiva automaticamente il Bluetooth anche se lo hai disabilitato in altri posti (come / etc / bluetooth / main .conf o / etc / default / tlp).

Per impedire al Bluetooth di accendersi all'avvio usando la riga di comando:

gsettings set org.blueman.plugins.powermanager auto-power-on false

O tramite la GUI:

  1. Fai clic sull'applet Bluetooth & gt; Plugin & gt; PowerManager & gt; Configurazione
  2. Deseleziona Accensione automatica

La prossima volta che riavvierai, l'applet Bluetooth sarà ancora visibile ma Bluetooth sarà spento. Per accenderlo:

Fai clic sull'applet Bluetooth & gt; Attiva Bluetooth

    
risposta data bmaupin 27.07.2018 - 19:12
-1

Ho dovuto usare un metodo a forza bruta per impedire a bluetoothd di essere avviato automaticamente all'avvio. Ho rinominato l'eseguibile in modo che non possa essere trovato.

    
risposta data bluesdiva2001 06.07.2012 - 03:02
-1

Puoi anche usare questa applicazione grafica che fa anche questo gestore bluetooth

    
risposta data deFreitas 27.12.2014 - 14:26
-3

Devi disabilitarlo dall'elenco Start Up Applications in System Settings.

Fai clic sul pignone nella parte in alto a destra della barra dei menu e seleziona Impostazioni di sistema.

Fai clic su Avvia applicazioni, quindi scorri verso il basso finché non trovi l'impostazione Bluetooth, prendi il segno di spunta dalla casella e hai finito.

    
risposta data Mark Rooney 16.10.2011 - 23:13

Leggi altre domande sui tag