Scarse prestazioni grafiche a causa di impostazioni mtrr errate

7

Sto usando il kernel più recente su Dell LAtitude E4310 con 8Gbyte RAM

2.6.38-10-generic #44-Ubuntu SMP Thu Jun 2 21:32:22 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

All'avvio ricevo il seguente messaggio

[drm] MTRR allocation failed.  Graphics performance may suffer.

e infatti il ​​mio /proc/mtrr sembra strano

reg00: base=0x000000000 (    0MB), size= 8192MB, count=1: write-back
reg01: base=0x200000000 ( 8192MB), size=  512MB, count=1: write-back
reg02: base=0x0e0000000 ( 3584MB), size=  512MB, count=1: uncachable
reg03: base=0x0dc000000 ( 3520MB), size=   64MB, count=1: uncachable
reg04: base=0x0db400000 ( 3508MB), size=    4MB, count=1: uncachable
reg05: base=0x21c000000 ( 8640MB), size=   64MB, count=1: uncachable

Ho provato mtrr-uncover ma non funziona:

./mtrr-uncover 
Initial MTRR configuration:
 0  0x000000000-0x1ffffffff write-back
         4  0x0db400000-0x0db7fffff uncachable
         3  0x0dc000000-0x0dfffffff uncachable
         2  0x0e0000000-0x0ffffffff uncachable
 1  0x200000000-0x21fffffff write-back
         5  0x21c000000-0x21fffffff uncachable
./mtrr-uncover: 9 MTRRs needed but only 8 in architecture.

Qualcuno sa come impostare correttamente il mtrr nella mia architettura?

qui l'output rilevante di lspci -v

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
    Subsystem: Dell Device 0410
    Flags: bus master, fast devsel, latency 0, IRQ 42
    Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 60b0 [size=8]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915
    
posta elforma 11.06.2011 - 23:47

1 risposta

5

C'è una soluzione semplice per questo. Usa solo il parametro di avvio del kernel enable_mtrr_cleanup .

Modifica /etc/default/grub file di configurazione:

$ sudo nano /etc/default/grub

trova una riga contenente GRUB_CMDLINE_LINUX_DEFAULT e probabilmente vedrai questi parametri predefiniti:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Quindi per usare enable_mtrr_cleanup lo aggiungerai in questo modo:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash enable_mtrr_cleanup"

Quindi devi aggiornare la configurazione di grub con questo comando:

$ sudo update-grub2

E riavvia:

$ sudo reboot

Quindi il messaggio scomparirà e vedrai che il sistema ha trovato i valori corretti per MTRR.

    
risposta data k23 24.09.2011 - 00:09

Leggi altre domande sui tag