Il controllo della luminosità dello schermo non funziona su Lenovo T530

7

Il mio controllo della luminosità non funziona con una nuova installazione di 12.10 (nuovo laptop). È impostato sull'impostazione più luminosa quando avvio e quando provo a cambiarlo, vedo la barra di notifica che si avvicina ma la luminosità non cambia in realtà. Ho provato tutte le soluzioni che ho trovato su Internet ma nessuno di loro funziona. Le cose che ho provato includono:

  

Modifica / sys / class / backlight / acpi_video0 / brightness

     

In /usr/share/X11/xorg.conf.d/10-brightness-control.conf: Option   "RegistryDwords" "EnableBrightnessControl = 1"

     

In / etc / default / grub: GRUB_CMDLINE_LINUX_DEFAULT="splash silenzioso   acpi_osi = Linux acpi_backlight = fornitore "

Non c'è un file xorg.conf in 12.10 che ho trovato, quindi le soluzioni che suggeriscono di modificare quel file non mi fanno un sacco di bene.

Attualmente sto usando il driver Nouveau, ma il passaggio ai driver proprietari Nvidia non ha fatto alcuna differenza.

Qualche altra idea? Quando verrà corretto questo bug? Con tutti i rapporti che ho incontrato, penserei che riceverebbe molta attenzione. Grazie.

    
posta Matt 28.11.2012 - 03:57

4 risposte

6

Ho avuto un problema simile sul mio thinkpad W530. Ho finalmente trovato una soluzione qui:

link

  

In questi giorni X si configura automaticamente, quindi non puoi semplicemente modificare il file xorg.conf, devi invece aggiungere una sezione in un file in /usr/share/X11/xorg.conf.d/ e X includi quella sezione nella configurazione che genera automaticamente.

     

Quindi, per far funzionare i tasti di luminosità dello schermo con la tua scheda grafica Nvidia, crea un file nella directory xorg.conf.d, ad es.

sudo gedit /usr/share/X11/xorg.conf.d/10-nvidia-brightness.conf
  

Incolla quanto segue nel file:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K1000M"
    Option         "RegistryDwords" "EnableBrightnessControl=1"
EndSection
    
risposta data phewner 27.11.2013 - 06:36
1

Ubuntu ha fatto il backport delle patch dal kernel 3.7 al 3.6? Questa potrebbe essere la causa, vedi qui: link

Prova ad usare il cursore di luminosità vom "Impostazioni di sistema" & gt; "Luminosità e lucchetto" in GNOME.

    
risposta data Peter Weber 02.12.2012 - 18:02
0

Hai aggiornato grub ( sudo update grub ) dopo aver modificato /etc/default/grub e riavviato?

Se sopra non funziona Prova anche solo con acpi_backlight=vendor .

Se è richiesto anche un parametro thinkpad thinkpad-acpi.brightness_enable=1 .

Puoi verificare se il tuo sistema utilizza il driver thinkpad-acpi utilizzando il seguente comando:

lsmod | grep thinkpad_acpi

Controlla questa pagina (vedi il primo paragrafo e le tecniche di diagnostica)

Aggiornamento:

Un'altra cosa che ho appena mostrato, hai modificato /etc/X11/xorg.conf file? nella tua domanda stai indicando un altro luogo di cui non ho mai sentito parlare. Esegui nvidia-xconfig per generare il file di configurazione, se /etc/X11/xorg.conf non esiste.

In secondo luogo, prova una soluzione alla volta. se non funziona, ripristina e riavvia, quindi prova un'altra soluzione.

Un'altra soluzione potrebbe essere

Prova a seguire per i percorsi mostrati da ls /sys/class/backlight/*/brightness e sostituisci di conseguenza.

i percorsi di esempio saranno come

/sys/class/backlight/acpi_video0/brightness
  1. Per il percorso sopra Ottieni la luminosità massima:

cat /sys/class/backlight/acpi_video0/max_brightness

Prova un valore più basso per impostare la luminosità, ad esempio l'output è 16, quindi proverò con la metà di esso

echo 8 | sudo tee /sys/class/backlight/acpi_video0/brightness

Se funziona , assicurati che ciò accada automaticamente in ciascun accesso eseguendo quanto segue

sudo gedit /etc/rc.local

Inserisci questa riga poco prima di exit 0 . Dovrebbe apparire come

echo YOUR_VALUE_HERE > /sys/class/backlight/acpi_video0/brightness
exit 0

Puoi anche provare con xdotool

    
risposta data Web-E 28.11.2012 - 05:58
0

Questa è una specie di workaroun, ma puoi provare ad impostare la luminosità tramite la riga di comando usando:

xbacklight -set 100

Se funziona, prova a collegare una scorciatoia da tastiera globale a

xbacklight -inc 5

e

xbacklight -dec 5
    
risposta data rzymek 12.08.2016 - 15:50

Leggi altre domande sui tag