Optirun glxgears: impossibile accedere alla GPU secondaria: errore: [XORG] (EE) Nessun dispositivo rilevato

7

Ho un problema con il comando optirun su Ubuntu 12.10 installato sul notebook DELL M6600. Nel BIOS ho attivato la tecnologia Optimus. Ho due grafici:

lspci -vnn | grep '\''[030[02]\]'
  • Controller grafico integrato Intel Core Generation Core Processore di seconda generazione [8086: 0126] (rev 09) (prog-if 00 [controller VGA])
  • NVIDIA Corporation GF104 [Quadro 4000M] [10de: 0e3b] (rev a1) (prog-if 00 [controller VGA])

Ho installato i driver nvidia:

dpkg -l | grep nvidia

ii  boinc-nvidia-cuda                         7.0.27+dfsg-5ubuntu0.12.04.1               amd64        metapackage for CUDA-savvy BOINC client and manager
ii  bumblebee-nvidia                          3.0.1-3~quantalppa2                        amd64        nVidia Optimus support using the proprietary NVIDIA driver
ii  nvidia-common                             1:0.2.71.1                                 amd64        transitional package for ubuntu-drivers-common
ii  nvidia-cuda-doc                           4.2.9-1ubuntu1                             all          NVIDIA CUDA and OpenCL documentation
ii  nvidia-cuda-gdb                           4.2.9-1ubuntu1                             amd64        NVIDIA CUDA GDB
rc  nvidia-current                            304.64-0ubuntu1~quantal~xup1               amd64        NVIDIA binary Xorg driver, kernel module and VDPAU library
ii  nvidia-experimental-310                   310.14-0ubuntu1                            amd64        Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library
rc  nvidia-settings                           304.64-0ubuntu1~quantal~xup1               amd64        Tool for configuring the NVIDIA graphics driver
rc  nvidia-settings-experimental-310          310.14-0ubuntu1                            amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-settings-updates                   304.51-0ubuntu2                            amd64        Tool for configuring the NVIDIA graphics driver

Quando provo questo:

 optirun -vv -debug glxspheres

Ho ricevuto:

[  912.342326] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  912.497379] [DEBUG]optirun version 3.0.1 starting...
[  912.497472] [DEBUG]Active configuration:
[  912.497560] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  912.497600] [DEBUG] X display: ebug
[  912.497660] [DEBUG] LD_LIBRARY_PATH: 
[  912.497694] [DEBUG] Socket path: /var/run/bumblebee.socket
[  912.497724] [DEBUG] VGL Compression: proxy
[  912.734313] [INFO]Response: No - error: [XORG] (EE) No devices detected.

[  912.734376] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[  912.734399] [DEBUG]Socket closed.
[  912.734447] [ERROR]Aborting because fallback start is disabled.
[  912.734477] [DEBUG]Killing all remaining processes.
    
posta jafan 29.01.2013 - 16:47

3 risposte

3

Penso di aver avuto lo stesso problema. Quando ho bloccato il calabrone, non ha riconosciuto la mia carta discreta. Alla ricerca di questo problema, ho scoperto che Ubuntu utilizza la chiave nvidia invece di nvidia-current per fare riferimento ai driver di nVidia.

Quindi prova questo:

Crea un backup del file /etc/bumblebee/bumblebee.conf

  • sudo cp /etc/bumblebee/bumblebee.conf /etc/bumblebee/bumblebee.conf.backup

(ad esempio)

Modifica quel file (usa l'editor che vuoi, per esempio gedit):

  • sudo gedit /etc/bumblebee/bumblebee.conf

Vai alla sezione [driver-nvidia] .

Qui, modifica il valore di

  • KernelDriver=nvidia-current

a

  • KernelDriver=nvidia

e

  • Module=nvidia-current

a

  • Module=nvidia

Salva il file e riavvia.

Ora riprova:

  • optirun -vv -debug glxspheres

Se ricevi lo stesso errore, ripristina il file di configurazione:

  • sudo cp /etc/bumblebee/bumblebee.conf.backup /etc/bumblebee/bumblebee.conf

Abbi fortuna.

    
risposta data nemugakun 30.01.2013 - 21:48
0

Una volta ho avuto lo stesso identico problema, IIRC non avevo installato bbswitch. Ce l'hai? In caso contrario, installare, riavviare e riprovare. Se hai sospeso il tuo notebook, ho anche avuto problemi con l'utilizzo di optirun dopo la sospensione / ibernazione, prova a riavviare il computer.

    
risposta data Leonardo Dagnino 29.01.2013 - 17:53
0

La mia soluzione a questo problema è stata l'aggiunta della mia carta nel file di configurazione /etc/bumblebee/xorg.conf.nvidia .

Decommenta la riga:

BusID "PCI:01:00:0"
    
risposta data user216637 17.11.2013 - 14:19

Leggi altre domande sui tag