Impossibile installare sqlite3

7

Sistema operativo: Ubuntu 12.04 LTS

$sudo apt-get install libsqlite3-dev

The following packages have unmet dependencies: libsqlite3-dev : Depends: libsqlite3-0 (=3.7.9-2ubuntu1) but 3.7.9-2ubuntu1.1 is to be installed



$sudo apt-get install libsqlite3-0

Building dependency tree
Reading state information... 
Done libsqlite3-0 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 103 not upgraded.

Ho anche provato a scaricare il pacchetto più recente su link

e leggi questo: link

Ubuntu ha risposto: "non è possibile installare libc6: i386" o "non è statisciabile ..."

    
posta CodeFarmer 19.12.2012 - 14:05

1 risposta

3

Questo sembra essere un problema con alcuni pacchetti a 64 bit non sincronizzati con i pacchetti a 32 bit (3.7.9-2ubuntu1 vs. 3.7.9-2ubuntu1.1).

La seguente risposta è spudoratamente ritagliata dal thread in link che consiglio per una descrizione più approfondita (oltre a passaggi per verificare che questo sia effettivamente il tuo problema.)

  1. Scarica la versione a 64 bit:

    apt-get download libsqlite3-0:amd64
    
  2. Scarica la versione a 32 bit:

    apt-get download libsqlite3-0:i386
    
  3. Elimina la versione esistente a 64 bit:

    sudo dpkg --force-depends --purge libsqlite3-0:amd64
    
  4. Elimina la versione esistente a 32 bit:

    sudo dpkg --force-depends --purge libsqlite3-0:i386
    
  5. Installa manualmente la versione a 64 bit:

    sudo dpkg --install libsqlite3-0*amd64.deb
    
  6. Installa manualmente la versione a 32 bit:

    sudo dpkg --install libsqlite3-0*i386.deb
    

Quindi controlla se l'installazione di -dev funziona, poiché uno di questi dovrebbe corrispondere a quello che sta cercando.

    
risposta data Ubuntourist 21.12.2012 - 17:19

Leggi altre domande sui tag