Ubuntu 12.04 - grub-efi-amd64-signed non è riuscito a installare in / target /

7

Ho un laptop HP Pavillion 14-n009tu (i-5, 4GB) con sistema operativo Windows-8 installato su di esso. Sto cercando di installare Ubuntu 12.04 come un sistema operativo dual boot su Windows8. Ho disabilitato anche l'avvio veloce e le opzioni di avvio sicure. Sto affrontando il seguente errore durante l'installazione di Ubuntu 12.04:

grub-efi-amd64-signed failed to install into /target/. Without GRUB boot loader,
the installed system will not boot

Ho creato tre partizioni:

  1. 38 GB-ext4- Montato su root
  2. 08 GB-ext4- /home
  3. Area di scambio da 10 GB

Per favore, spiegami come risolvere questo problema.

    
posta Ramji Makwana 05.01.2014 - 11:06

6 risposte

3

Ehi Ramji aveva esattamente lo stesso problema. Ciò che ha riparato il mio problema è stato che ho ripreso i passaggi e mi sono assicurato di essere connesso a Internet la seconda volta. ripetere la procedura (non ripartire nuovamente perché il disco rigido è ancora partizionato) ma questa volta ha scelto l'opzione per formattare le partizioni in modo da cancellare le informazioni che erano state caricate prima che l'installazione fallisse. guarda i commenti qui Perché 12.04 non installa grub-efi su / target / ? se hai ancora problemi, segui queste istruzioni link

    
risposta data Shule 04.02.2014 - 21:36
2

Ho risolto il problema creando una partizione FAT32 da 200 MB all'inizio del disco con i flag boot e esp . La creazione di una partizione con questa configurazione è stata suggerita dallo strumento di ripristino dopo che ho ricevuto l'errore che hai citato e ho provato a risolverlo usando questo strumento.

Spero che questo aiuti! Buona fortuna!

    
risposta data Cleber de Souza Alcântara 07.03.2017 - 21:25
1

È un bug. Se si sta installando utilizzando una pendrive, è sufficiente modificare il nomefile grub-efi-amd64-signed_1.9~ubuntu12.04.4+1.99-21ubuntu3.10_amd.deb nella directory /pool/main/g/grub2-signed/ aggiungendo 64 alla fine prima di .deb . Funziona al 100%.

link

    
risposta data Lui Suing 23.12.2014 - 19:40
0

Ho lavorato su questo problema in Linux Mint 16 eseguendo il seguente comando prima di avviare l'installazione:

sudo dpkg --remove-architecture i386

Probabilmente è causato dall'installazione di entrambe le versioni a 32 e 64 bit di tutti i pacchetti, nel caso in cui ne esista solo uno (o forse per supportare cluster eterogenei con CPU sia a 32 che a 64 bit). Nel caso di grub-efi-amd64 (che è parte di grub-efi-amd64-signed ), esistono entrambe le versioni, ma dichiarano conflitti l'un l'altro in modo che non possano essere entrambi installati sullo stesso sistema.

    
risposta data user833771 20.07.2014 - 03:33
0

Ho avuto lo stesso problema durante l'installazione di Ubuntu 16.04 e durante l'installazione di Mint.

I seguenti passaggi risolvono il mio problema:

  1. Installa Ubuntu / Mint a seconda di ciò che desideri (dopo l'installazione o tra parentesi, riceverai questo errore).
  2. Start o. con avvio dal vivo.
  3. Installa riparazione di avvio.
  4. Segui i passaggi in questo.

Questo è tutto. Riavvia il PC e ricorda di rimuovere il supporto di avvio che hai usato.

    
risposta data Prakash Kansurkar 02.10.2016 - 19:01
-1

Disabilita le opzioni "Avvio rapido" e "Avvio sicuro" nel menu Opzioni di avvio. Seleziona avvio legacy. Riavvia il processo di installazione. Crea una partizione di avvio & gt; 1 MB durante l'installazione. Questo mi ha risolto il problema con l'installazione di UBUNTU 16.04 LTS. Partizioni create: / boot - 2048 MB swap: 10000 MB / - 50000 MB / home - 100000 MB

Contrassegnati rimanenti per non essere utilizzati.

    
risposta data Swaru 13.08.2016 - 11:19

Leggi altre domande sui tag