Come posso specificare una dipendenza tra 2 versioni di un pacchetto?

7

In un file debian/control , come posso specificare una dipendenza da un pacchetto tra 2 versioni di quel pacchetto?

Ad esempio: python 2.5 o superiore ma inferiore a python 2.7.

Depends: python ($VERSION_STRING)

Che cosa sarebbe $VERSION_STRING ?

    
posta dv3500ea 08.01.2011 - 16:02

2 risposte

4

Gli operatori per le dipendenze della versione sono:

>>  Greater than, but not equal to
>=  Greater than or equal to
=
<=
<<

(nota < e > , che significa anche <= e >= funzionano, ma sono deprivati)

Quindi, per dichiarare il tuo esempio, devi aggiungere due dipendenze:

Depends: python (>= 2.5), python (<< 2.7)

Per una descrizione completa delle dichiarazioni di dipendenza, consultare il Manuale delle policy di Debian, Capitolo 7 . Se vuoi dare un'occhiata ad alcuni usi, vedi questo esempio casuale .

    
risposta data Stefano Palazzo 08.01.2011 - 17:17
1

Puoi usare due clausole per specificare i vincoli. Il primo indica una dipendenza da python 2.5 o superiore e il secondo indica una dipendenza da python precedente alla 2.7.

Depends: python (>= 2.5), python (<< 2.7)
    
risposta data goric 08.01.2011 - 17:19

Leggi altre domande sui tag