Il sistema ripristina la frequenza di aggiornamento di 87 Hz ad ogni avvio dopo aver installato i driver nvidia

7

Ogni volta che il sistema avvia la frequenza di aggiornamento dello schermo torna a 87Hz, il che risulta in una schermata pixelata e sfarfallio che devo manualmente correggere ogni volta selezionando 60Hz come frequenza di aggiornamento.

Ho provato "salva in X file di configurazione" e ho anche provato a fare le modifiche come Root ma senza alcun risultato poiché ritorna a 87Hz su ogni avvio di sistema

I driver Open Source sono OK per Unity regolare ma molti giochi non funzionano su di esso quindi ho dovuto installare i driver nvidia. Sono stato di fronte a questo dal Beta Phase anche se questo è su una nuova installazione di rilascio finale 12.04. Sto anche fornendo il mio file Xorg.conf nel caso in cui potrebbe aiutare link

Anche per qualche ragione Display mostra il mio monitor CRT come portatile ma su driver open source lo menzionava come un CRT da 14 "

Questo bug è presente anche su Edubuntu 12.04

Questo non è presente su Xubuntu 12.04 Avevo scelto di installare gli aggiornamenti e il software di terze parti sull'installazione e sono stato accolto con una schermata di frequenza di aggiornamento corretta sul Boot Up. Mi piace Xubuntu.

    
posta Mohammad Kamil Nadeem 28.04.2012 - 13:38

3 risposte

2

Nessuno dei proccedure citati funzionerà correttamente per te. Lo stesso problema rende anche il mio upgrade alla 12.04. mi sono appena sbarazzato di questo prob & amp; Voglio condividere la mia solita con te. Spero ti possa aiutare il meglio:

A. first u need to set lightdm res.

1. Type/copy this command in terminal to show your display details:

   xrandr -q 

    If you only have one monitor you will see a line in the output like the following ( probably with some different values, its the identifier at the start we are after):

   VGA-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm


2. Now you need to create a bash script:

   Open up your favourite text editor, lets use gedit for this example, press alt+f2 and type ”gedit”          
   Type/copy this line (replacing “1024x768″ with your desired resolution): 

   #!/bin/sh

   xrandr --output VGA-0 --primary --mode 1024x768

  Save this on your home folder as ”lightdmxrandr.sh”.
  You should test this script before you put it into practice. 

3. Now make it executable (by chmod command or from property dialog box)

4. Now run it:

 ./lightdmxrandr.sh 

5. If everything goes right move the script somewhere more appropriate:

    sudo mv ~/lightdmxrandr.sh /usr/share/ 

6. now run this in lightdm, navigate to lightDM  folder & Open up the lightDM conf file:

   sudo gedit /etc/lightdm/lightdm.conf

7. Now add the line below after the last line and save – this instructs LightDM to use the resolution script you just made:

   display-setup-script=/usr/share/lightdmxrandr.sh

B. Now reboot or restart LightDM and the correct resolution should be set on your LightDM log in screen & display.

C. 1. Now install nvidia driver 

   2. set proper display resolution & save the configuration file:

   sudo nvidia-settings

USE VALUES ACCORDING TO YOUR SYSTEM. VALUES USED HERE ARE ACCORDING TO MY SYSTEM .

*********************************************************************************** Enjoy!
    
risposta data saurav 12.08.2012 - 16:55
1

In Xubuntu (dal momento che funziona) Digita xrandr nel terminale per ottenere un elenco delle modalità dello schermo. Ci sarà una stella accanto alla modalità utilizzata corrente, ad esempio

1024x760 60* 87

Potrebbe anche elencare diverse altre frequenze di aggiornamento, quello che dobbiamo fare è modificare il file xorg.conf in modo che Unity non usi i tassi che lo schermo non supporta, quindi digita terminale -

gksudo gedit /etc/X11/xorg.conf

La sezione che vogliamo modificare è il limite superiore di VertRefresh qui

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "LG Electronics 500G"
HorizSync       30.0 - 54.0
VertRefresh     50.0 - 120.0
Option         "DPMS"
EndSection

Prova a cambiare l'intervallo VertRefresh a qualcosa come 50 - 75 in modo da escludere la modalità di 87Hz all'avvio di Unity, salvare il file e riavviare, quindi provare xrandr per visualizzare nuovamente l'elenco delle modalità dello schermo. Infine, modifica la sessione in Unity per vedere se ha avuto successo.

    
risposta data Mateo 02.06.2012 - 00:16
0

Prova ad aggiungere una modeline per la res specifica e la frequenza di aggiornamento che desideri. Per generare una modeline usa il comando cvt ad esempio:

  

cvt 1024 768 70

Dovresti avere:

  

h24sync 1024x768 a 69,81 Hz (CVT): 55,99 kHz; pclk: 75,25 MHz

     

Modeline "1024x768_70.00" 75.25 1024 1080 1184 1344 768 771 775 802 -sync + vsync

Puoi quindi incollare la riga che inizia "Modeline" nella sua interezza in /etc/X11/xorg.conf nella sezione "Monitor"

Dovrai quindi inserire un'opzione nella riga del metamodo nella sezione "Schermo" che punta alla modelina, ad esempio:

  

Opzione "metamodi" "1024x768_70.00"

Quello che segue è un xorg.conf abbreviato per chiarezza, solo per dimostrare dove e come dovrebbero andare queste righe:

 Section "Monitor"
       Modeline "1024x768_70.00"   75.25  1024 1080 1184 1344  768 771 775 802 -hsync +vsync
 EndSection

 Section "Screen"
       Option  "metamodes" "1024x768_70.00"
 EndSection

Ho avuto risultati variabili con diversi driver Nvidia e sembra cambiare comportamento ad ogni nuova versione. Immagino che sia stato fatto molto lavoro su xorg ma è una sfida quando le cose non vanno come previsto.

    
risposta data fabricator4 01.06.2012 - 22:53

Leggi altre domande sui tag