Come disabilitare la sessione ospite?

182

Come disabilitare la sessione ospite in Ubuntu 11.10 o successiva? Non voglio che le persone siano in grado di usare il mio computer senza usare una password per accedere!

    
posta Jeremy Bicha 22.09.2011 - 17:45
fonte

12 risposte

118

Aggiornato: 2016-ago

Per Ubuntu 16.04 LTS (15.10 o successivo)

Adattato da: LightDM Ubuntu Wiki - Configurazione

  • I file di configurazione forniti dal sistema in /usr/share/lightdm/ sono non previsti per essere modificabili dall'utente. Invece gli utenti dovrebbero usare: /etc/lightdm/
  • Le versioni più recenti di LightDM (Ubuntu 15.10 o successive) utilizzano [Seat:*] anziché [SeatDefaults]

Basta eseguire questo (una volta) sul terminale:

sudo sh -c 'printf "[Seat:*]\nallow-guest=false\n" >/etc/lightdm/lightdm.conf.d/50-no-guest.conf'

Per annullare (ripristinare l'opzione Ospite), rimuovere il file creato :

sudo rm /etc/lightdm/lightdm.conf.d/50-no-guest.conf

Per Ubuntu 14.04 LTS (fino a 15.04)

Adattato da: Forum di Ubuntu - posizione dei file di configurazione di lightdm in 14.04

Basta eseguire questo (una volta) sul terminale:

sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'

Non avrai più l'opzione "Ospite" come accesso, al tuo prossimo accesso.

Per annullare (ripristinare l'opzione Ospite), rimuovere il file creato :

sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf

Per Ubuntu 12.04 LTS (fino a 13.10)

Metodo più semplice

Basta eseguire questo (una volta) sul terminale:

sudo /usr/lib/lightdm/lightdm-set-defaults -l false

Non avrai più l'opzione "Ospite" come accesso, al tuo prossimo accesso.

  • Semplicemente aggiunge allow-guest=false a /etc/lightdm/lightdm.conf .

  • Dovrebbe funzionare da 11.10 in poi (dato che questi usano LightDM pure).

Per annullare (ripristinare l'opzione Ospite):

sudo /usr/lib/lightdm/lightdm-set-defaults -l true
    
risposta data david6 28.07.2012 - 01:38
fonte
115
% Bl0ck_qu0te%

Se utilizzi il LightDM predefinito, modifica /etc/lightdm/lightdm.conf in modo che assomigli a questo:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Se utilizzi GDM (che era l'impostazione predefinita nelle precedenti versioni di Ubuntu), disinstalla gdm-guest-session .

Per Ubuntu 13.10 a 14.10 , il file è stato spostato su /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Per Ubuntu 14.10 o superiore, il file è stato spostato su % Co_de%

    
risposta data Jeremy Bicha 22.09.2011 - 17:48
fonte
24

Scrivilo nel terminale

gksu gedit /etc/lightdm/lightdm.conf

Vedrai quanto segue:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

Aggiungi allow-guest=false alla fine in modo che il risultato finale sia simile a:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Salva il documento e chiudi l'editor di testo.

Di nuovo nel terminale, riavvia il display manager. (Questo finirà la sessione di login grafica, lasciando immediatamente tutti i programmi in esecuzione, quindi assicurati che il tuo lavoro, come tutti i documenti aperti, venga prima salvato!)

sudo restart lightdm

Con la sessione di accesso grafica terminata, si ritorna alla schermata di accesso, dove si noterà che la registrazione degli ospiti è disabilitata.

Ecco fatto - l'account ospite non è più utilizzabile.

    
risposta data sarveshlad 25.10.2011 - 03:08
fonte
17

Puoi farlo usando Ubuntu Tweak .

Per installarlo, usa questi comandi:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Dopo l'installazione, vai a Tweaks Impostazioni di accesso e disattiva l'account "Ospite".

    
risposta data Eliran Malka 21.10.2012 - 19:54
fonte
11

Esegui

gksudo gedit /etc/lightdm/lightdm.conf

Aggiungi la seguente riga

allow-guest=false

Quindi (questo ti disconnetterà immediatamente, chiudendo tutti i programmi in esecuzione nella tua sessione grafica, quindi salva prima il tuo lavoro):

sudo restart lightdm
    
risposta data LnxSlck 27.07.2012 - 18:42
fonte
4

Come disabilitare questa opzione in futuro

Ho appena incontrato lo stesso problema nella mia nuova installazione fidata / 14.04. Inoltre, con mia sorpresa, non sono riuscito a trovare la cartella lightdm.conf.d all'interno di /etc/lightdm/ appena users.conf .

Investigation

$ find / -iname *lightdm* 2>/dev/null | grep -v /mnt | grep -v /media | grep -v /home
[...]
/usr/share/lightdm/lightdm.conf.d
[...]

Aha, eccoti. Cosa c'è lì dentro?

$ ls -1 /usr/share/lightdm/lightdm.conf.d/
50-greeter-wrapper.conf
50-guest-wrapper.conf
50-ubuntu.conf
50-unity-greeter.conf
50-xserver-command.conf

Ok, cosa c'è lì dentro?

$ cat /usr/share/lightdm/lightdm.conf.d/*
[SeatDefaults]
greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
[SeatDefaults]
guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
[SeatDefaults]
user-session=ubuntu
[SeatDefaults]
greeter-session=unity-greeter
[SeatDefaults]
# Dump core
xserver-command=X -core

Conclusione

Troviamo un mucchio di file di configurazione simili al formato INI che segue lo schema di denominazione di 50-${some-descriptive-name}.conf e alla configurazione delle chiavi per la sezione [SeatDefaults] .

Non modificheremo nessuno di questi file poiché questi sono destinati alla gestione da parte del gestore pacchetti, ma ora dovremmo aggiungere e gestire il nostro bit di configurazione personalizzati a /etc .

Soluzione

Considerato quanto sopra, lightdm è il display manager e i file di configurazione sono come sopra. La seguente soluzione dovrebbe funzionare:

  1. Crea le directory mancanti:

    $ sudo mkdir -p /etc/lightdm/lightdm.conf.d
    
  2. Aggiungi un file di configurazione personalizzato eseguendo:

    $ sudo nano /etc/lightdm/lightdm.conf.d/50-disable-guest-session.conf
    

    e incolla le seguenti righe:

    [SeatDefaults]
    allow-guest=false
    

    Quindi salva ( Ctrl + O ) e chiudi ( Ctrl + X ).

  3. Ora effettua il logout e passa a un terminale virtuale ( Ctrl + Alt + F1 ), quindi esegui:

    $ sudo service lightdm restart
    

    L'opzione della sessione ospite ora dovrebbe essere sparita. Se qualcosa non funziona correttamente, ora sai dove è archiviata la configurazione di default e che non l'hai modificata.

Ulteriori letture

risposta data LiveWireBT 16.03.2014 - 03:32
fonte
3

Per Ubuntu 13.10 , aggiungi

allow-guest=false

al file /etc/lightdm/lightdm.conf.d/10-ubuntu.conf .

    
risposta data uahummer 20.10.2013 - 15:27
fonte
3

13.04 e versioni successive

  1. Esegui questo comando in un terminale

    sudo /usr/lib/lightdm/lightdm-set-defaults -l false
    
  2. Riavvia il computer o riavvia lightdm con il seguente comando
    (Questo ti disconnetterà immediatamente, salva i tuoi dati)

    sudo restart lightdm
    

Apparentemente, funziona in 13.10 (non posso mettermi alla prova, ma c'è un commento qui ).

Sto usando 13.04 e tutto questo accoda allow-guest=false a /etc/lightdm/lightdm.conf , ma potrebbe essere diverso in 13.10.

Originariamente david6 da qui: link

    
risposta data kiri 21.10.2013 - 09:33
fonte
2

Installa il tweak di ubuntu, vai alla scheda di modifica, spegni il pulsante guest e riavvia. Questo è tutto!

Si potrebbe trovare il terminale più facile, ma nel caso in cui dovesse sorgere la necessità di attivare l'account ospite, si dovrebbe visitare nuovamente questa pagina e vedere le istruzioni (o meglio annullare). Questo è il vantaggio della cosa della GUI ... lo si ricorda facilmente.

    
risposta data tadatma 27.09.2012 - 19:33
fonte
2

Cambia allow-guest=true in 'false' in /etc/lightdm/lightdm.conf

È quindi possibile riavviare o riavviare il servizio nel terminale:

sudo restart lightdm

Supponendo che stai usando lightdm che è standard in 11.10.

    
risposta data filescraps 21.10.2011 - 12:42
fonte
0

Sono nello stesso caso, il file /etc/lightdm/lightdm.conf non esiste in UBUNTU 13.10.

Provo a creare il file /etc/lightdm/lightdm.conf con questa riga allow-guest=false e CRASH, il sistema non si avvia correttamente, solo la modalità console ...

Cerco di modificare il file /etc/lightdm/lightdm.conf.d/10-ubuntu.conf e funziona correttamente.

Modifica il file

sudo vim /etc/lightdm/lightdm.conf.d/10-ubuntu.conf

E inserisci le linee di cui hai bisogno

# to disable guest login
allow-guest=false
# to enable user login manually
greeter-show-manual-login=true

E l'ultimo, riavvia il tuo sistema

sudo reboot

Penso che funzioni bene se si riavvia solo il ligthgdm

sudo service lightdm restart
    
risposta data Foncu 23.10.2013 - 16:05
fonte
0

Apri terminale

gksudo gedit /etc/lightdm/lightdm.conf

Aggiungi la seguente riga

allow-guest=false

Salva e esci dal file.

    
risposta data scouser73 21.10.2013 - 09:29
fonte

Leggi altre domande sui tag