Modifica dell'editor crontab predefinito

104

Sto cercando di cambiare l'editor predefinito da nano a vim .

Ho eseguito i seguenti comandi:

sudo update-alternatives --config editor

e

update-alternatives --config editor

Ora vengono pubblicati entrambi:

  Selection    Path                Priority   Status
------------------------------------------------------------
  0            /bin/nano            40        auto mode
  1            /bin/ed             -100       manual mode
  2            /bin/nano            40        manual mode
* 3            /usr/bin/vim.basic   30        manual mode
  4            /usr/bin/vim.tiny    10        manual mode

Ho riavviato la mia sessione ssh e riavviato sshd ma crontab -e si apre ancora in nano

Che altro devo fare?

    
posta austinbv 29.07.2011 - 20:15
fonte

8 risposte

95

Prova la tua sessione ssh seguita da

export EDITOR=vim

o possibilmente

export EDITOR=/usr/bin/vim.basic

Il formato dell'impostazione della variabile EDITOR dipende dalla shell che stai usando.

In Ubuntu puoi impostare la variabile d'ambiente EDITOR all'accesso aggiungendo quanto sopra a ~/.profile

La sessione SSH leggerà un file simile (se esistente) sull'host remoto chiamato ~/.ssh/environment . Questo deve essere definito in modo specifico dalla configurazione del daemon ssh. Visualizza man sshd_config e cerca PermitUserEnvironment per ulteriori dettagli.

    
risposta data fossfreedom 29.07.2011 - 20:29
fonte
163

Esegui semplicemente select-editor , questo ti permetterà di scegliere qualsiasi editor che desideri.

    
risposta data Mostafa Shahverdy 06.03.2013 - 15:19
fonte
21

La mia preferenza personale ...

cd /bin
mv nano nano_must_die
ln -s /usr/bin/vim nano
    
risposta data Dave 08.01.2014 - 00:39
fonte
12

Da "man crontab":

   The -e option is used to edit the  current  crontab  using  the  editor
   specified  by  the  VISUAL  or EDITOR environment variables.  After you
   exit from the editor, the modified crontab will be installed  automati‐
   cally.  If  neither  of  the environment variables is defined, then the
   default editor /usr/bin/editor is used.

Forse hai la variabile di enrionment EDITOR impostata su nano?

    
risposta data aureianimus 29.07.2011 - 20:28
fonte
9

Sul mio computer Ubuntu 12.04, crontab usa il file ~/.selected_editor , che contiene il percorso dell'editor selezionato. Modifica:

nano ~/.selected_editor

L'ho modificato direttamente o utilizzato select-editor , che è uno script per fare la stessa cosa. Modifica la seguente riga:

SELECTED_EDITOR="/usr/bin/vim.basic" 

Le persone IHMO non dovrebbero cambiare nulla in / etc o / bin per farlo. È una cosa a livello di utente, non un'attività a livello di sistema.

    
risposta data NormanD 05.01.2016 - 03:37
fonte
6

Se desideri solo temporaneamente selezionare l'editor, puoi fare quanto segue

EDITOR=nano crontab -e

Imposta la variabile di ambiente EDITOR per il comando

    
risposta data Luke Madhanga 08.02.2017 - 12:07
fonte
2

Avevo difficoltà con select-editor e update-alternatives , la mia soluzione era semplicemente modificare il link:

  1. sudo rm /etc/alternatives/editor
  2. sudo ln -s /usr/bin/vim /etc/alternatives/editor

editor ora apre Vim

    
risposta data Dennis Bellinger 16.05.2014 - 17:31
fonte
1

Ho avuto lo stesso problema - crontab -e si basa su select-editor, visudo si basa sulla configurazione di "alternative"

La mia soluzione:

esegui entrambi i comandi come root

# update-alternatives --install /usr/bin/editor editor /usr/bin/sensible-editor 50

# select-editor 

Select an editor.  To change later, run 'select-editor'.
  1. /bin/nano        <---- easiest
  2. /usr/bin/sensible-editor
  3. /usr/bin/vim.basic
  4. /usr/bin/vim.tiny

Choose 1-4 [1]: 3
    
risposta data julian 12.07.2017 - 16:43
fonte

Leggi altre domande sui tag