Wifi non funziona dopo la sospensione dopo l'aggiornamento 16.04

133

Questa particolare versione di "non funziona dopo la sospensione" è arrivata dopo l'aggiornamento alla 16.04. Sembra che l'aggiornamento includa un'applet Wicd (aggiunta alla barra delle applicazioni di Metacity Classic Gnome accanto all'icona di rete normale), ma sembra non funzionare dopo una sospensione. Un sudo service network-manager restart duplica questo problema. È necessario un riavvio completo per riavviare Wifi. Qualche idea, perché?

    
posta 147pm 23.04.2016 - 13:42

11 risposte

160

16.04 gira su systemd. Prova quanto segue:

sudo systemctl restart network-manager.service

Se funziona, puoi creare uno script per automatizzarlo.

Apri un terminale e digita quanto segue:

sudo nano /etc/systemd/system/wifi-resume.service Ora incolla lo script con un clic destro. Esci con CTRL + X e premi Y per salvare. Ora per attivarlo: sudo systemctl enable wifi-resume.service

Script:

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Spero che questo aiuti. Funziona con il mio laptop.

    
risposta data Joakim Koed 23.04.2016 - 15:17
13

Lo stesso con un Lenovo X230. Non succede dopo ogni sospensione, ma a volte.

sudo systemctl restart network-manager.service 

risolve il problema.

    
risposta data Martin 24.04.2016 - 15:29
8

@ 147pm Hai mai funzionato?

Ho scoperto di avere un problema abbastanza simile, anche se sono su Kubuntu 16.10 (basato su KDE, non su Gnome) e con un laptop HP ProBook. E, a differenza di te, non era il mio Wifi che è morto dopo la sospensione / sveglia, ma la mia porta ethernet. Tuttavia, mi chiedo se sono correlati.

Vedo anche che non hai il problema sotto KDE. Ma sarei interessato a sapere se la soluzione qui sotto aiuta sotto Gnome, in quanto la soluzione non è basata su window manager, ambiente desktop o applet.

In primo luogo, solo per confermare che il riavvio del servizio gestore di rete ..

$ sudo systemctl restart network-manager.service

non ha funzionato per me.

Tuttavia, ho trovato una risposta che ha funzionato, grazie alla domanda e alle informazioni di buzhidao all'indirizzo non riesco a collegarmi a Internet dopo la sospensione e il commento di GAD3R lì.

Usando le loro informazioni, ho scoperto che la prima ricerca su quale hardware ethernet e driver / modulo sono in esecuzione, e quindi rimuovere e reinstallare quel modulo, ha funzionato per me (anche se non per buzhidao):

Wifi:

$ lspci -knn | grep Net -A2

Ethernet:

$ lspci -knn | grep Ether -A2

Il secondo di questi (ethernet) era quello che usavo, e ho trovato:

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
        Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:1944]
        Kernel driver in use: r8169
        Kernel modules: r8169

quindi ho reinstallato il driver 'r8169':

$ sudo rmmod r8169 && sudo modprobe r8169

e voilà! Questo ha funzionato. La mia porta / connessione ethernet è tornata attiva (dopo la sospensione / attivazione) senza dover riavviare.

(Inoltre NON avevo un dispositivo Realtek wifi, ma un Qualcomm Atheros (mod: ath9k) che forse spiega perché il wifi continuava a funzionare per me dopo la sospensione dalla sospensione.)

Come puoi vedere dal mio commento su quell'altro post, mi sono chiesto se il problema sia l'elemento comune tra Buzhidao e me: i dispositivi Realtek Semiconductor. Anche se usano moduli diversi, potrebbero condividere un codice comune? O addirittura essere trattato in modo diverso dal nuovo codice del kernel ora in qualche modo?

Hai tu stesso un dispositivo wifi basato su Realtek? (usando lspci sopra)? Hai qualche fortuna a reinstallare il modulo (rmmod / modprobe sopra)?

Ad ogni modo, solo uno sparo al buio. Se hai trovato una risposta definitiva per te, faccelo sapere! Thx.

    
risposta data androclus 16.03.2017 - 23:40
6

Per riavviare automaticamente NetworkManager dopo il ripristino in un ambiente senza sudo di accesso, creare uno script in /etc/pm/sleep.d (qualsiasi nome), impostare il bit eseguibile tramite chmod +x e inserire il seguente contenuto:

case "" in
    resume|thaw)
        # systemctl restart network-manager.service
        service NetworkManager restart
;;
esac

Per me, la riga service ha funzionato, ma systemctl potrebbe funzionare meglio per te.

Fonte: link .

    
risposta data krlmlr 05.11.2016 - 08:50
2

Per me sembra essere casuale, ma a volte il wifi si disconnette solo se sono connesso o non mostra reti se non lo sono. A volte mettere il mio laptop in modalità sleep sembra attivarlo, ma non sempre.

Alcune combinazioni di questi di solito riescono a riavviarsi senza riavvio:

  • sudo iwlist $(ifconfig | grep -Po '^w\w+') scan
  • %codice%
    • Il semplice chiamare sudo service network-manager stop; sleep 5; sudo service network-manager start qui non sembra mai funzionare per me. Sembra che cerchi di avviarlo prima che finisca di chiuderlo, quindi ho più fortuna facendo una pausa tra restart e stop .
  • Disattiva wifi nell'interfaccia utente; aspetta qualche secondo; riaccenderlo

Nessuno di questi sembra funzionare in modo coerente, ma li ho elencati in ordine di massima probabilità di successo.

    
risposta data redbmk 20.12.2016 - 17:07
2

Metodo di lavoro su Ubuntu 16.04:

Crea il servizio: sudo nano /lib/systemd/system/wifi-resume.service

Il servizio sta chiamando il programma da:
/etc/init.d/network-manager

Copia il codice:

#/lib/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart network-manager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target 

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Quindi abilita il servizio:

sudo systemctl enable /lib/systemd/system/wifi-resume.service

Questo crea i symlink nelle directory [Install] indicate di / etc / systemd / system e attiva il servizio

Successivamente puoi controllare lo stato con: systemctl status wifi-resume.service

    
risposta data cryptoboy 23.01.2017 - 01:59
1

Ho avuto lo stesso problema con il bluetooth: dopo aver sospeso il mio mouse bluetooth non ha funzionato. Così ho ricavato la soluzione dall'alto:

sudo nano /etc/systemd/system/bluetooth-resume.service

abilitato il nuovo servizio

sudo systemctl enable bluetooth-resume.service

e modificato il servizio

#/etc/systemd/system/bluetooth-resume.service
#sudo systemctl enable bluetooth-resume.service
[Unit]
Description=Restart bluethooth at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart bluetooth.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Ho provato anche a modificare ...

sudo nano /etc/bluetooth/main.conf

e cambiato

AutoEnable=true

MA questo NON ha funzionato per il "problema di ripresa" e comunque non ha avuto alcun impatto sui nuovi dispositivi bluetooth!

    
risposta data apos 31.08.2016 - 13:11
1

Ho avuto lo stesso problema sul mio portatile Dell Inspiron 15R con Ubuntu 16.04. Per me ha funzionato lo script riportato sulla seconda risposta .

Dopo aver installato lo script ho provato la sospensione con il comando nel menu in alto a destra e anche chiudendo il labbro, risolvendo il problema.

Devo dire che il problema si stava alternando nel suo comportamento (cioè, a volte funzionava prima di installare lo script).

    
risposta data Alessandro D'lncal 18.01.2017 - 15:58
0

Per me la soluzione era eseguire

nmcli nm sleep false

in un terminale

    
risposta data tigerjack89 08.04.2017 - 13:01
0

Ho avuto lo stesso problema durante il collegamento al wifi di casa dopo la sospensione. Ho provato le varie altre risposte suggerite che a volte funzionavano ma non sempre.

Alla fine la seguente correzione consentiva una connessione coerente al wifi:

1) Modifica questo file:

sudo vim /etc/NetworkManager/NetworkManager.conf

2) Aggiungendo questo ad esso:

[device]
wifi.scan-rand-mac-address=no
    
risposta data Ray Vega 28.03.2018 - 08:09
0

Ora probabilmente semplice

sudo apt update
sudo apt upgrade

dovrebbe funzionare.

Nel mio caso, tra i pacchetti aggiornati c'era bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.3) e dopo questo aggiornamento il wifi funziona di nuovo.

    
risposta data Daniel 05.08.2018 - 07:08

Leggi altre domande sui tag