16.04 Problemi di connessione wifi LTS con adattatore Realtek

116

Ho scoperto diversi problemi con la connessione wifi dopo aver installato 16.04 LTS.

Innanzitutto, il wifi non si riconnette normalmente dopo il sonno o il letargo. A volte l'icona della rete diventa "frecce su e giù" (non so a cosa serve) dopo il risveglio, ma è ancora connessa. A volte la rete viene semplicemente persa e non viene visualizzata alcuna rete nell'elenco, quindi non c'è assolutamente alcun modo di utilizzare il wifi.

Ho provato per la prima volta a riavviare il gestore di rete eseguendo sudo service network-manager restart . Funzionava ma non era una soluzione permanente.

Quindi, secondo un altro thread, ho aggiunto SUSPEND_MODULES="iwlwifi" a

/etc/pm/config.d/config

Dopo aver fatto questo, il problema di riconnessione sembra essere risolto (può riconnettersi automaticamente e l'icona non cambia più.) Tuttavia, trovo la connessione wifi si perde in modo casuale (circa ogni 30 minuti) anche quando il computer è in esecuzione e l'icona di rete rimane lo stato connesso quando la connessione è persa.

Un altro problema dopo aver aggiunto il codice è, quando metto in stop il computer, lo schermo si spegne per un secondo ma poi si riaccende per circa 5 secondi (durante i quali il sistema interrompe la connessione wifi). E poi il computer andrà a dormire dopo questo insolito processo "a due fasi".

Plz trova le informazioni sulle schede wireless di seguito

*-network               
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlp2s0
       version: 00
       serial: b0:c0:90:5c:1c:d5
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.4.0-21-generic firmware=N/A ip=192.168.0.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 ioport:d000(size=256) memory:df200000-df203fff

00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK208 HDMI/DP Audio Controller (rev a1)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
03:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller (rev 01)

Aggiornamento 05/01/2016: Non so cosa sia successo ma il problema peggiora ora. La connessione Wi-Fi si perde ogni 5 minuti e devo ricollegare o riavviare il gestore di rete.

    
posta Lixu 25.04.2016 - 07:13

9 risposte

43

Finalmente sono stato in grado di risolvere i problemi dopo aver provato numeri di metodi diversi.

  1. Ottieni i dettagli della tua scheda wireless PCI eseguendo sudo lshw -class network
  2. Ottieni le informazioni sul modello della tua carta in base alla linea di prodotti.
    Ad esempio, come puoi vedere nella descrizione della domanda, si dice in product: RTL8723BE PCIe Wireless Network Adapter , quindi il modello della mia carta è RTL8723BE

    O product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller quindi il modello della mia carta è RTL8101/2/6E

  3. Dai il permesso sudo chmod 755 /etc/pm/config.d/

  4. Apri o crea config e aggiungi SUSPEND_MODULES="rtl8723be" (sostituisci rtl8723be con il tuo numero di modello)
    Quindi esegui
    echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    (nota che quando sostituisci rtl8723be con la mia carta che è RTL8101/2/6E dovrei solo digitare .../modprobe.d/RTL8101.conf e /2/6E non dovrebbe essere scritto)

Infine riavvia il sistema.

Ora il tuo sistema dovrebbe essere in grado di riconnettersi automaticamente dopo il sonno, e la connessione wifi non si è mai persa una volta per me dopo aver fatto questo.

"Le frecce su / giù sono probabilmente un bug del gestore di rete che porta il gestore della rete a pensare che il dispositivo wifi sia effettivamente ethernet.", secondo Jeremy31. vedi le informazioni sui bug qui dovresti essere in grado di risolverli installando NetworkManager-1.2.0.

Grazie a Jeremy31 per aver fornito le soluzioni.

    
risposta data Lixu 06.05.2016 - 05:09
37

Ho esattamente lo stesso problema. Dopo il risveglio dal sonno, la rete wifi funziona ancora ma le reti non vengono visualizzate. Risolvi il problema riavviando il gestore di rete.

sudo service network-manager restart

Ancora molto fastidioso. Spero che risolvano presto questo problema.

    
risposta data eldosoa 28.04.2016 - 06:25
30

Questo è sicuramente un bug. Bug è stato archiviato a link

    
risposta data Shinjan 02.05.2016 - 19:22
10

Informazioni aggiuntive: ho lo stesso esatto problema descritto da OP, ma solo il problema in cui l'icona nm-applet cambia in frecce e non mostra informazioni wifi. Il wifi funziona ancora quando questo accade.

$ killall nm-applet && nm-applet & 

Il trucco per far visualizzare nuovamente l'icona, quindi per ora è solo una soluzione, nel caso qualcuno volesse inserirlo in uno script.

Può confermare questo problema su due computer separati che eseguono il pacchetto xubuntu-desktop.

Inoltre, entrambi i computer eseguono schede wifi Intel recenti. (qualcosa sulla falsariga di AC-7260)

    
risposta data Joel Cressy 26.04.2016 - 04:40
6

Stavo avendo lo stesso problema. Ho risolto il problema di suspend wake creando questo script su /etc/systemd/system/wifi-resume.service (quello pubblicato da OP funzionava solo per la sessione attiva ; al riavvio doveva essere richiamato di nuovo):

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Quindi invia questo comando nel terminale per attivarlo: sudo systemctl enable wifi-resume.service . Questa soluzione proviene da un'altra risposta alla domanda su askubuntu , e funziona sia dopo la sospensione e dopo il riavvio.

Tuttavia, anche dopo che è stato corretto, ottengo lo stesso comportamento che si verificava durante la sospensione dalla sospensione quando provo a cambiare reti wifi : il wifi è essenzialmente morto, con le due frecce, e l'applet dice " dispositivo non pronto ." Posso riavviare il wifi immettendo sudo service network-manager restart , ma non posso cambiare rete.

Qualcun altro sta vivendo questo e / o ha una soluzione ???

    
risposta data Rsync 29.04.2016 - 03:20
2

Sto usando LinxuMint 18 Mate (ubuntu16.04) e ho avuto lo stesso problema.

Tutto il resto sopra non ha funzionato per me sul mio thinkpad T440S.

L'unica soluzione che sembra funzionare fino ad ora è l'aggiornamento del kernel alla versione 4.6.3

  • Vai a questo sito web .

  • Ottieni i seguenti file:

    linux-headers-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    linux-headers-4.6.3-040603_4.6.3-040603.201606241434_all.deb
    linux-image-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    
  • Da un terminale, vai alla cartella contenente i file sopra ed esegui:

    sudo dpkg -i *.deb
    sudo reboot
    

Se utilizzi Virtualbox, esegui questo sudo /sbin/vboxconfig

Nel caso in cui desideri rimuoverli, esegui:

sudo dpkg --purge linux-headers-4.6.3-040603 linux-headers-4.6.3-040603-generic 

Dopo altri test, la situazione è quasi la stessa, ho il wifi, ma il mio nm-applet non è in grado di vedere tutto il WIFI intorno a me. Quindi non sono sicuro se questo è un buon modo per aggirare: -)

    
risposta data SteF 09.08.2016 - 11:28
2

Non c'è alcuna soluzione in questo momento, ma ho trovato uno script che mi ha aiutato a mantenere wlan up:

#!/bin/bash

# Ping you most used DNS Server and reconnect on fail


while true; do
  if ! ping -c 1 -w 1 8.8.8.8 > /dev/null; then

    # with "sudo iwconfig" you can examine your name of 'wlan0'
    nmcli d connect wlan0

  fi
  sleep 2;
done

per avviare automaticamente questo script è sufficiente aprire gnome-session-properties e aggiungerlo all'elenco.

Lo script completo (senza riconnettersi) può essere trovato su questa pagina web .

    
risposta data Steffomio 17.10.2016 - 21:28
1

Imposta il codice paese WIFI per il dominio normativo corrente dei Kernel, se non è impostato

iw reg get

Per impostarlo

sudo nano /etc/default/crda
REGDOMAIN=<ISOCODE>

Reboot.

    
risposta data Janghou 11.05.2016 - 11:34
1

solo per aggiungere la risposta accettata (con quattro passaggi)

per qualche motivo per me è bastato un solo passaggio, anche se non so cosa significhi:

echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    
risposta data nyxee 24.09.2017 - 02:13

Leggi altre domande sui tag