Connetti / disconnetti da VPN dalla riga di comando

111

Ho due configurazioni VPN sulla mia macchina Ubuntu, una che usa vpnc e una che usa PPTP. Questi sono stati entrambi impostati utilizzando l'interfaccia di gestione della rete GNOME e funzionano perfettamente. Tuttavia a volte ho bisogno di accedere a questa macchina da remoto - c'è un modo per connettersi o disconnettersi da queste VPN dalla riga di comando?

    
posta Tim Fountain 16.08.2011 - 17:15

2 risposte

161

Se vuoi interagire con NetworkManager dalla riga di comando puoi usare il comando "nmcli".

elenca tutte le connessioni NM: nmcli con

avvia la connessione (wifi, vpn, ecc.): nmcli con up id ConnectionName

connessione in basso: nmcli con down id ConnectionName

(più comandi di nmcli nella manpage di nmcli ).

Si noti inoltre che gli utenti normali di solito non hanno il permesso di controllare il networking. L'utilizzo dei comandi precedenti con sudo dovrebbe funzionare per la maggior parte delle connessioni, ma in particolare la VPN potrebbe non riuscire con "Errore: attivazione della connessione fallita: nessun segreto VPN valido."

Se ciò accade, è probabile che la password VPN sia memorizzata nel gnome-keyring dell'utente, il che lo rende inaccessibile all'utente root. Questo commento spiega perché.

Per risolvere il problema, modifica / etc / NetworkManager / system-connections / ConnectionName e in [vpn] , modifica password flag linea a:

password-flags=0

Se esiste una riga che inizia con Xauth password-flags , cambialo invece.

Quindi aggiungi quanto segue sotto il blocco [vpn] :

[vpn-secrets]
password=YourPassword

(Se nel passaggio precedente hai modificato la riga Xauth password-flags , aggiungi invece Xauth password=... .)

Ora riavvia il gestore di rete di:

sudo service network-manager restart

Quindi avviare la connessione VPN con sudo nmcli con up id ConnectionName dovrebbe funzionare senza problemi.

    
risposta data ihashacks 17.08.2011 - 05:44
4

La risposta di ihashacks con i commenti di Matt ha funzionato per me ... quasi. Ho dovuto modificare una riga.

la mia linea di flag della password in realtà diceva: "Xauth password-flag". La risposta accettata non funzionerebbe per me fino a quando non ho cambiato il seguente

[vpn]
...
Xauth password-flag=0
IPSec secret-flags=0

[vpn-secrets]
Xauth password=<my pw> ## This is the one I changed.
IPSec secret=<group pw>

Non sono sicuro del motivo per cui le mie connessioni VPN hanno "Xauth" prima di ogni menzione della password.

(Mi spiace, questa è una nuova risposta, non posso ancora fare commenti.)

    
risposta data John 23.03.2015 - 06:03

Leggi altre domande sui tag