NTFS Drive mostra in fdisk -l non quando eseguo blkid non è in grado di montare l'unità

4

Non riesco a vedere un'unità da 750 GB collegata alla mia macchina 12.04 utilizzando un compagno di unità USB 2.0. L'unità è stata estratta da un computer Windows 7 e sto solo cercando di estrarre tutte le informazioni da esso, in modo da poterlo cancellare e ricominciare da capo.

fdisk -l mostra

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0000183e

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   480094207   240046080   83  Linux
/dev/sda2       480096254   488396799     4150273    5  Extended
/dev/sda5       480096256   488396799     4150272   82  Linux swap / Solaris
Note: sector size is 4096 (not 512)

Disk /dev/sdb: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 11400 cylinders, total 183143646 sectors
Units = sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x07f2837e

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1              63      208844      835128   de  Dell Utility
/dev/sdb2   *      212992    41172991   163840000    7  HPFS/NTFS/exFAT
/dev/sdb3        41172992  1465147119  1400929216    7  HPFS/NTFS/exFAT

sudo blkid
sudo blkid
/dev/sda1: UUID="dd81fbe4-0659-4eb8-9ef2-f4851ed6ff3e" TYPE="ext4" 
/dev/sda5: UUID="1cb1a836-7896-4537-9e31-2cacc1a9250b" TYPE="swap" 
/dev/sr0: LABEL="Monsters, Inc." TYPE="udf" 

sudo mount  -t ntfs /dev/sdb /media/windows
NTFS signature is missing.
Failed to mount '/dev/sdb': Invalid argument
The device '/dev/sdb' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

Non sono sicuro del motivo per cui questo non funziona, qualsiasi aiuto sarebbe molto apprezzato.

    
posta Mraganpbr 24.08.2012 - 18:04

2 risposte

2

Probabilmente dovresti usare:

sudo mount -t ntfs /dev/sdb2 /media/windows

Notare il 2 dopo sdb. Stavi cercando di montare l'intero disco invece della partizione.

    
risposta data Javier Rivera 24.08.2012 - 18:07
0

Usando due utilità photorec e testdisk ho scoperto che le partizioni erano completamente danneggiate. Sono stato in grado di estrarre tutti i file. Grazie per l'aiuto

    
risposta data Mraganpbr 24.08.2012 - 19:54

Leggi altre domande sui tag