Dipendenze interrotte dopo l'installazione di Skype

4

Dopo aver installato skype, le mie dipendenze sono rotte. Ho provato ad eseguire apt-get -f install ma ricevo solo messaggi di errore. Sto usando Ubuntu 12.04 su AMD64. Se hai bisogno di maggiori informazioni per favore dimmi.

The following packages have unmet dependencies:
libasound2-plugins:i386:
Depends: libjack-jackd2-0:i386 (>= 1.9.5~dfsg-14)
but it is not going to be installed or libjack-0.116:i386
Get:1 http://ppa.launchpad.net/dns/sound/ubuntu/ precise/main libjack-jackd2-0 i386 1.9.8~dfsg.2-1precise1 [202 kB]
Fetched 202 kB in 1s (105 kB/s)            

Unpacking libjack-jackd2-0:i386 (from .../libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb (--unpack):
 './usr/share/doc/libjack-jackd2-0/buildinfo.gz' is different from the same file on the system
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Grazie per l'aiuto. Forse ha causato LMMS, ma il problema è apparso dopo aver installato skype. :)

    
posta norpol 17.08.2012 - 14:59

3 risposte

2

Grazie per il vostro supporto. Sono stato in grado di risolvere il problema con:

sudo dpkg --remove libasound2:i386 libasound2-plugins:i386

Ho provato ad installare Skype in entrambi i modi (Software Center e Skype.com). Ora eseguo il + x dal tarball ufficiale.

    
risposta data nordpol 18.08.2012 - 01:52
1

Si è imbattuto in un problema simile con WINE per 32bit exes, su x64 Ubuntu 14.04. Il supporto per gli exe a 32 bit è fornito dal multiarch: i386 wine, che dipende dalle versioni: i386 multiarch di varie librerie non WINE.

(A quanto ho capito, questi: i pacchetti i386 sono binari identici a quelli che userebbe Ubuntu i386, risparmiando spazio sui mirror e risparmiando tempo di costruzione dato che non è necessario creare una versione a 32 bit per x64 di qualsiasi cosa. Ovviamente permettendoti di avere la versione a 32 e 64 bit di praticamente qualsiasi cosa installata fianco a fianco, così puoi eseguire qualsiasi binario Linux i386 su un sistema x64. Oltre a risparmiare tempo di costruzione e spazio di mirroring, nessuno ha bisogno di pacchettizzare tutto come 32bit-on-x64.)

wine1.6-i386: i386 1: 1.6.2-0ubuntu4   consiglia: libasound2-plugins: i386 (che ritengo sia necessario che il suono funzioni se un altro programma ha un flusso di output audio aperto, poiché qui è dove vive il modulo pulseaudio alsa- & gt;)

libasound2-plugins: i386 1.0.27-2ubuntu2   dipende da: libjack-jackd2-0 (& gt; = 1.9.5 ~ dfsg-14) | libjack-0,116

Cercando di installare libasound2-plugins: i386 tenta di inserire libjack-jackd2-0, che è in conflitto con libjack0. Ho già installato il libjack0 x64, quindi il gestore pacchetti vede un conflitto.

Sfortunatamente, apt non si rende conto che potrebbe risolvere la dipendenza installando libjack0: i386 invece di libjack-jackd2-0: i386 per soddisfare libasound2-plugins: la dipendenza di i386. Selezionandolo manualmente, mi consente di selezionare libasound2-plugins: i386 senza conflitti. (Ho usato aptitude).

Sì, ha funzionato bene per le app x86 (incluso il vino) quando è necessario pulseaudio. All'inizio ho pensato che si trattasse di un bug di packaging con qualcosa, ma no, risulta che si tratta solo di un bug nel risolutore di dipendenze per il multiarch.

    
risposta data Peter Cordes 18.12.2014 - 03:43
0

Sembra un pacco rotto. Dovrai rimuovere libasound2-plugins. Potrebbe essere necessario forzarlo per rimuovere, utilizzando questa riga sudo dpkg --remove -force --force-remove-reinstreq libasound2-plugins . ( Ecco alcuni altri comandi che possono aiutarti a ripulire apt-get quando diventa indisciplinato.)

Skype, nella sua infinita saggezza, non si è preoccupato di rilasciare una versione a 64 bit del proprio client Linux. Pertanto, dipende dalle versioni a 32 bit di tutto ciò da cui dipende. Quindi, dovrai anche farlo.

Per installare le librerie, esegui apt-get install ia32-libs prima di installare Skype.

    
risposta data Shauna 17.08.2012 - 15:27

Leggi altre domande sui tag