La schermata di Google Chrome Kiosk non massimizza

4

Ho configurato un chiosco Chrome utilizzando una sessione personalizzata in X per eseguire Google Chrome.

In genere funziona piuttosto bene tranne che per un problema di dimensioni dello schermo.

Ho un file di sessione "chrome.desktop" salvato in / usr / share / xsessions con i seguenti contenuti.

[Desktop Entry]
Name=Chrome
Comment=This session logs you into Google Chrome
Exec=/usr/share/xsessions/chromeKiosk.sh
Icon=
Type=Application
Encoding=UTF-8

C'è anche un file chromeKiosk.sh che viene utilizzato per eseguire Chrome. È anche in / usr / share / xsessions. I contenuti sono i seguenti.

#!/bin/bash
while true; do google-chrome http://news.bbc.co.uk --kiosk --start-maximized --disable-restore-background-contents --login-screen-size="1024,768" --disable-translate --disable-new-tab-first-run --enable-vertical-tabs; sleep 5s; done

Il problema che sto avendo è che Google Chrome (o Firefox, o Opera. Ho provato varie app), non massimizzerà l'intero display a 1024x768. Sembra lasciare circa 1 centimetro di spazio sul lato destro del display (posso vedere il desktop), e anche un po 'di spazio nella parte inferiore dello schermo.

Ho provato questo su almeno 2 computer diversi. Uno aveva uno schermo a risoluzione più alta. Ha lasciato uno spazio ancora più grande.

È come se l'applicazione che viene eseguita pensi che lo schermo sia più piccolo di quello che è in realtà.

Qualcuno ha idea di cosa sta succedendo? Sto impazzendo con questo problema.

Ecco un'immagine in modo da poter vedere il bordo

Google Chrome Kiosk Xsession con bordo dispari

Quella immagine proviene da uno schermo con una larghezza di 1280.

    
posta Chris Woollard 23.04.2012 - 22:20

2 risposte

1

Stai per farlo ... vedi i miei codici:

[Desktop Entry]
Name=Chrome
Comment=This session logs you into Google Chrome
google-chrome --start-maximized --kiosk http://google.com
Icon=
Type=Application
Encoding=UTF-8

ora devi modificare la configurazione di Chrome per l'utente
posizione aperta: ~/.config/google-chrome/Default/
e quindi apri Preferences .
Cerca "browser": { e modifica i seguenti:

   "browser": {
      "check_default_browser": false,
      "clear_lso_data_enabled": true,
      "custom_chrome_frame": true,
      "pepper_flash_settings_enabled": true,
      "window_placement": {
         "bottom": 803,
         "left": 1,
         "maximized": false,
         "right": 1366,
         "top": 35,
         "work_area_bottom": 768,
         "work_area_left": 0,
         "work_area_right": 1366,
         "work_area_top": 37
      },

Nel mio PC ho 1366x768, per favore aggiustare il necessario.

(puoi anche aggiungere questo file in / etc / skel location, questo risolverà il problema durante la creazione di un nuovo utente che non è necessario riconfigurare)

    
risposta data Subhasom 27.01.2013 - 20:12
1

Non sei sicuro del perché Chrome stia facendo questo, ma se dai un'occhiata a:

/home/{kiosk_user}/.config/google-chrome/Default/Preferences  

- vedrai browser.window_placement e dovresti vedere una differenza di circa 20 pixel tra il fondo e work_area_bottom , e destra e work_area_right .

Ho modificato i valori in modo che fossero completamente estesi della dimensione del display e ho salvato le preferenze, poi ho chownato poi a root:root e li ho codificati in 644 in modo che Chrome (in esecuzione come kiosk_user ) non è possibile modificare le impostazioni.

Ho riavviato la sessione kiosk_user e tada, Chrome era in esecuzione a schermo intero.

Spero che questo ti aiuti.

    
risposta data chrism 26.05.2012 - 15:00

Leggi altre domande sui tag