Configurazione dell'installazione della versione di sviluppo di Python

4

Durante l'installazione di PSI4 su Modifica: Ubuntu 13.10 ( prima di Ubuntu 12.04), sto riscontrando il seguente errore:

configure: error: 
Could not link test program to Python. Maybe the main Python library has been
installed in some non-standard library path. If so, pass it to configure,
via the LDFLAGS environment variable.
Example: ./configure LDFLAGS="-L/usr/non-standard-path/python/lib"
============================================================================
 ERROR!
 You probably have to install the development version of the Python package
 for your distribution.  The exact name of this package varies among them

Linea di installazione:

../configure --prefix=/usr/local/psi4 --with-blas='-mkl' --with-incdirs=-mkl

Possibili duplicati:

Dove è installata la libreria Python?

Problemi simili:

Errore di Python durante la configurazione di mesos su centos

Errore nella compilazione di un c ++ con collegamenti Python usando mingw e msys

Un'altra possibile soluzione sui forum di Ubuntu .

Quello che ho provato:

Ho installato python-dev e python2.7-dev utilizzando apt-get . Questa è la soluzione menzionata nel primo, secondo e quarto link. Continuo a ricevere lo stesso errore.

Cosa non capisco:

  1. Il problema si presenta a causa del compilatore a 32 bit e della discrepanza Python a 64 bit menzionata nel terzo link (Errore durante la compilazione ... mingw ...)?

  2. Se la risposta a 1 è sì, come faccio a fare in modo che il compilatore usi python a 32 bit?

P.S. Forse è irrilevante, ma il log (prima dell'errore) relativo a python

checking for a Python interpreter with version >= 2.6... python
checking for python... /usr/bin/python
checking for python version... 2.7
checking for python include statements... -I/usr/include/python2.7 -I/usr/include/python2.7
checking for python linker flags... -L/usr/lib/python2.7/config -lpthread -ldl -lutil -lm -lpython2.7 -Xlinker -export-dynamic -Wl,-O1 -Wl,-Bsymbolic-functions
checking consistency of all components of python development environment... no
configure: error: 
    
posta theindigamer 08.04.2014 - 10:28

1 risposta

2

Il tuo problema non è legato all'installazione del pacchetto di sviluppo per python ma poiché hai deciso di utilizzare la libreria MKL di Intel per creare PSI4 devi averli installati correttamente da qualche parte.

Per una compilation Linux, puoi selezionare la libreria ATLAS come indicato in Consigli per librerie BLAS e LAPACK :

sudo apt-get install libatlas-dev

Quindi sarai in grado di avviare configure senza problemi:

../configure --prefix=/usr/local/psi4 --with-blas='-lf77blas -latlas' --with-lapack='-llapack -lcblas'

Testato OK con psi4.0b5.tar.gz in 12.04 LTS e 13.10.

    
risposta data Sylvain Pineau 11.04.2014 - 15:24

Leggi altre domande sui tag