Posso usare il mio VirtualBox 3. * VM con VirtualBox 4.0? In tal caso, come mai il repository non ce l'ha?

4

Ho avuto il seguente repository per virtualbox nel mio /etc/apt/sources.list: deb ttp://download.virtualbox.org/virtualbox/debian maverick non-free

Poi ho scoperto che c'era una nuova versione quando l'ho aperta oggi (il programma mi ha spinto con una finestra per scaricarlo manualmente dal sito di Oracle). Poi ho provato sudo apt-get update && sudo apt-get upgrade and got nothing .

Qui hai un modo per aggiungere virtualbox-4.0 al tuo apt-get, ma il problema è che non si sta aggiornando, il che significa che avrei i due installati. Sono anche preoccupato se dovrò fare qualcosa del genere ogni volta che si aggiorna, poiché ciò avrebbe vanificato il punto di apt-get.

Utilizzo VirtualBox con l'aggiornamento apt-get da più di un anno e questa è la prima volta che succede, quindi mi chiedevo se ci sarebbe stato un modo per aggiornare la mia attuale installazione.

    
posta Takkat 20.02.2011 - 05:29

2 risposte

1

Virtual Box 4.0 è un aggiornamento importante. La versione precedente deve ancora essere supportata. Per ottenere ciò, il repository Virtual Box sarà disponibile per entrambi, la versione 3.xe 4.x.

Se si desidera eseguire l'ultima versione è necessario aggiungere il repository 4.x alle origini. Questo è perfettamente spiegato nella pagina di download della Virtual Box .

Prima di installare Virtual Box 4.0. è necessario rimuovere la versione precedente. Le tue macchine virtuali private non saranno interessate. Tuttavia, sarà necessario reinstallare le nuove aggiunte guest e, se è necessario il supporto RDP o USB, sarà necessario installare anche Oracle Vitual Box Extension Pack.

    
risposta data Takkat 20.02.2011 - 10:27
1

VirtualBox 4 è abbastanza nuovo e ha un nome di pacchetto diverso da non forzare tutti ad aggiornare contemporaneamente (supportano ancora 3.x IIRC).

Per installarlo, aggiungi il repository, come hai fatto e solo:

sudo apt-get install virtualbox-4.0

Questo pacchetto è impostato per entrare in conflitto con 3.x in modo da essere rimosso come parte del processo. Per quanto ne so, non puoi eseguirli entrambi nello stesso momento in cui avrebbero moduli in conflitto con il kernel.

    
risposta data Oli 20.02.2011 - 13:46

Leggi altre domande sui tag